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Warranty and Service Policy
Product Warranty
DATAQ Instruments, Inc. warrants that this hardware will be free from defects in materials and workmanship under 
normal use and service for a period of 90 days from the date of shipment. DATAQ Instruments' obligations under this 
warranty shall not arise until the defective material is shipped freight prepaid to DATAQ Instruments. The only 
responsibility of DATAQ Instruments under this warranty is to repair or replace, at its discretion and on a free of 
charge basis, the defective material.

This warranty does not extend to products that have been repaired or altered by persons other than DATAQ Instru-
ments employees, or products that have been subjected to misuse, neglect, improper installation, or accident.

DATAQ Instruments shall have no liability for incidental or consequential damages of any kind arising out of the 
sale, installation, or use of its products.

Service Policy

1. All products returned to DATAQ Instruments for service, regardless of warranty status, must be on a freight-pre-
paid basis.

2. DATAQ Instruments will repair or replace any defective product within 5 days of its receipt.

3. For in-warranty repairs, DATAQ Instruments will return repaired items to the buyer freight prepaid. Out of war-
ranty repairs will be returned with freight prepaid and added to the service invoice.
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1. Introduction
This manual contains information designed to familiarize you with the features and functions of the DI-2108 USB 
data acquisition system.

Features
The DI-2108 data acquisition instrument is a portable data recording module that communicates through your com-
puter's USB port. Power is derived from the interface port so no external power is required. Features include:

• 8 fixed differential analog inputs protected to ±50V (transient).

• 7 digital ports protected to +25V: Two dedicated for WINDAQ remote control operations; One dedicated to 
WINDAQ rate measurements; and One dedicated to WINDAQ counter measurements.

• ±10V full scale measurement range.

• Up to 220 kHz maximum throughput sampling rate with all eleven channels enabled (analog, digital, frequency, 
counter.).

• A push-button to tag remote events in WINDAQ software.

• LED indication for easy notification of system status.

• Free WinDaq/Lite data acquisition recording software. Records up to four channels of data. Purchase an unlock 
code to record more than four channels.

• Stand-alone option allows the user to configure a recording session through their PC then record data in the field 
to removable flash memory via the USB drive port (without being connected to their PC). Stand-alone data log-
ging requires Unlock code to record more than 1 channel to removable flash memory.

• Low-pass filter per analog channel with automatic corner frequency selection.

• Dedicated counter channel.

• Dedicated frequency channel.

Analog Inputs
The DI-2108 features eight differential channel inputs located on a single sixteen-position screw terminal block for 
easy connection and operation. Note: The DI-2108 does not support Gain.

Utilize the functionality of WINDAQ software to experience all the features encased in these small, inexpensive 
instruments. Unlock code required to record all eight channels.

Digital I/O
The DI-2108 contains seven digital ports, which may be used as a general-purpose digital inputs or for a specific 
function as designated on the device. Digital port D0 is reserved for WinDaq Events; Digital port D1 is reserved for 
WinDaq remote Start/Stop; Digital port D2 is reserved for rate measurements; Digital port D3 is reserved for counts; 
Digital port D6 is reserved for external triggers. Please Note: Digital outputs are not supported in WinDaq software. 
Each port may be configured as a switch using third-party software.

Software
All software required to record and playback waveforms is included with the purchase of any DI-2108 data acquisi-
tion system via download.
Introduction
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WINDAQ® Recording and Playback Software
WINDAQ Acquisition and WINDAQ Waveform Browser allow you to record and playback data acquired through your 
instrument. WINDAQ software is an invaluable resource to record and analyze your data and is available for free from 
our web site (www.dataq.com).

WINDAQ Lite Data Acquisition software (free) can be used to record waveforms directly and continuously to disk 
while monitoring a real time display of the waveforms on-screen. It operates, displays, and records up to four chan-
nels in real time. An optional unlock code is available to record the rest of the channels on the device.

WINDAQ Waveform Browser playback software (also known as “WWB”) offers an easy way to review and analyze 
acquired waveforms. A built-in data file translator allows the user to display multiple waveforms acquired by 
WINDAQ Acquisition software or any of a wide range of data acquisition packages. The software’s disk-streaming 
design allows data files of any length to be graphically displayed rapidly, in normal or reverse time directions. Seven 
standard cursor-based measurements, frequency domain, and statistical analysis functions help simplify waveform 
analysis and interpretation. WINDAQ Waveform Browser is free and installed when installing WINDAQ Software.

Help
All WINDAQ software utilizes context-sensitive help. Help may be accessed through the Help menu or by pressing 
the F1 key with any pull-down menu item selected. This will take you directly to the Help topic most relevant to that 
particular function or feature. Help topics discuss in detail each function available in the software.
Introduction
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2. Specifications
Analog Inputs
Number of Channels: 8

Channel Configuration: Differential

Voltage Measurement Range: ±10V Full Scale

Input impedance: 110k

Dc accuracy: ±5 mV at 16-bit resolution and 25°C, excluding common mode error

Absolute maximum input without damage: ±50 V dc or peak ac (normal mode + common mode)

Common mode range: ±20 V dc or peak ac

Common mode rejection ratio: 80 dB (dc - 60 Hz)

Channel-to-channel crosstalk rejection: -80 dB

Digital Ports
Number of Ports: 7

Type: MOSFET switch

Configuration: Programmable as digital input or switch

Pull-up value: 4.7 k

Input high voltage threshold: 2.4V

Input low voltage threshold: 0.8V

Absolute maximum applied voltage (V): +25V

Reserved Digital Inputs
Port 1: WINDAQ remote events

Port 2: WINDAQ remote start/stop

Port 3: Rate input

Port 4: Count input

ADC Characteristics
Resolution: 12- to 16-bit

Above zero ADC counts: 2,047 to 32,767
Below zero ADC counts: 2,048 to 32,768

Max. sample throughput rate: Standard: 220,000 Hz (160 kHz for analog chs, 20 kHz per digital ch)
Stand-alone: 20 kHz to 160 kHz (dependent on flash memory)

Min. sample throughput rate: Standard: 20 Hz (2.2 samples per hour with WinDaq)
Stand-alone: 0.0017 Hz

Sample rate timing accuracy: 100 ppm

Digital Ports Programmed as Switch
Maximum drain voltage: 25V

Maximum sink current: 100 mA
Specifications
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Count/Rate
Digital port assignment: Count: Port 2 configured as input

Rate: Port 3 configured as input

Internal pull-up value: 4.7 k

Input high voltage threshold: 2.4V

Input low voltage threshold: 0.8V

Terminal count: 65,535

Maximum rate frequency: 50 KHz with one enabled channel, 20 KHz with 2-4 enabled analog 
channels, otherwise 10 KHz

Minimum rate frequency: 0.5 Hz

Maximum count frequency: 50 kHz

Removable Memory
Type: MLC, pSLC, or SLC flash memory (with USB SD card reader); USB 

thumb drive

Required Format: FAT32

Number of Channels: 1; Unlock code required for 2 or more

Indicators and Connections
Interface: USB 2.0 (mini-B style connector)

Indicator light: Multi-color LED

USB A Connector (Drive): USB drive for Stand-alone data logging
Cannot be used concurrently with the USB interface

Input connections: Two 16-position screw terminal strips

Power
Power Consumption: <1.0 Watt, via USB interface

Environmental
Operating Temperature: 0°C to 50°C (32°F to 122°F)

Operating Humidity: 0 to 90% non-condensing

Storage Temperature: -20°C to 60°C (-4°F to 140°F)

Storage Humidity: 0 to 90% non-condensing

Physical Characteristics
Enclosure: Polycarbonate ABS, 0.080 inch thickness

Mounting: Desktop; bulkhead

Dimensions: 6.68D × 3.28W × 1.13H in.
(169.67D × 83.31W × 28.7H cm.)

Weight: 5.7 oz. (162 grams)
Specifications
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Software Support
WINDAQ software: OS support: Check online at http://www.dataq.com/products/windaq/

windows-compatability/

Programming:  Instrument Protocol
Specifications
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3. Installation
The following items are included with each DI-2108 USB Data Acquisition System. Verify that you have the follow-
ing:

• A DI-2108 USB data acquisition instrument.

• 6-foot USB cable.

• A DATAQ Instruments screwdriver for signal lead connections.

• A 32GB USB flash drive with WinDaq software and NIST-traceable calibration certificate (.pdf). Can also be 
used for stand-alone data logging.

If an item is missing or damaged, call DATAQ Instruments at 330-668-1444. We will guide you through the appropri-
ate steps for replacing missing or damaged items. Save the original packing material in the unlikely event that your 
unit must, for any reason, be sent back to DATAQ Instruments.

Install WINDAQ Software
All software for the DI-2108 can be installed via a download-able executable directly from the DATAQ Instruments 
web site. The software is also available on the provided USB flash drive.

1. Disconnect all DATAQ Instruments USB devices from your Computer.

2. Plug the USB flash drive into your computer’s USB port or Go to http://run.dataq.com to download the software.

3. Save the executable (Dataq Software Suite Web Setup.exe) to your local hard drive.

4. Double-click on the executable to extract the program and begin software installation.

5. Follow the on-screen prompts and enter all required information.
Installation
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6. Software installation is complete - you will now see a “Successful Installation” box - click OK to exit WINDAQ 

Installation.

You can now plug the device(s) into your PC. Click on the “WinDaq Dashboard” shortcut to access WINDAQ soft-
ware and stand-alone setup.

Connect the Instrument to Your Computer
DI-2108 instruments can be connected to your computer’s USB port using the provided USB cable. No external 
power is required. Connect one end of the communications cable to the instrument port and the other to your PC’s 
port. WinDaq Dashboard will recognize your device and appear in the device list.

Note: Use a powered USB hub or a USB port on your PC. Non-powered USB hubs may not have sufficient power to 
run the instrument.
Installation
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4. Controls, Indicators, and 
Connections

Mini-B USB Connection
Use the supplied USB cable to connect and power the instrument through your computer’s USB port.

Screw Terminals
All input signal connections are made to the 16-port screw terminals. Each terminal is labeled on the instrument case.

DI-2108 Signal Connections
Refer to the following for screw terminal port identification.

Ch#: Analog channels 1-8 (±10VFS, ±50V transient max.)

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.

Analog In Channels 1-8

Digital Ports 0-6

Even Marker 
Push Button

Activity LED

+5V Out Ground

Mini-B USB 
Connection

Bulkhead 
mounting ear

Bulkhead 
mounting ear

USB Drive

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.
Controls, Indicators, and Connections
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D#: Digital port (0-6). Can also be used for specific WINDAQ functions (+25 Vmax).
D0 Event — WINDAQ Remote Event Marker (or general-purpose) 
D1 Record — WINDAQ Remote Start/Stop (or general-purpose)
D2 Rate — Rate Input (or general-purpose)
D3 Count — Counter Input (or general-purpose)
D4 and D5 — General-purpose digital ports
D6 Ext Trig — External Trigger (or general-purpose)

+5V: +4.75V out. Max current = 100mA. 

GnD: Ground.

Connecting Signal Leads
Connect signal leads to the DI-2108:

1. Insert the stripped end of a signal lead into the desired terminal directly under the screw.

2. Tighten the pressure flap by rotating the screw clockwise with a small screwdriver. Make sure that the pressure
flap tightens only against the signal wire and not the wire insulation. Do not over-tighten.

3. Tug gently on the signal lead to ensure that it is firmly secured.

When an input signal is connected and WINDAQ Acquisition software is run, WINDAQ’s real time display immedi-
ately reveals the input waveform on your computer’s monitor.
Controls, Indicators, and Connections
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Analog Inputs

Eight fixed differential analog inputs measure ± 10V (CH1 to CH8). Designed to withstand ±50 V dc or peak ac.

Use the following diagram to connect Analog Input Channel 1.

100K

Ref

AIN

100K
10K

10K

AIN

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.

Signal + Signal -
Controls, Indicators, and Connections
11



DI-2108 Hardware Manual
Low-pass Filter
Each analog channel employs a low-pass filter with automatic corner frequency selection. The filter is a CIC (cas-
caded integrator comb) type that uses as many as 512 samples per channel to calculate in real time as data is acquired. 
Filter response is optimized when sampling frequency is set to ten times the highest frequency of interest.

When choosing an acquisition method in WinDaq (menu item Edit > Channel Settings) Last Point, Maximum, and 
Minimum turn the filter off. The DI-2108 calculates its own Last Point, Maximum, Minimum, and Filter data making 
it available at the programming level. Acquisition methods “RMS” and “Frequency” are permanently disabled for the 
DI-2108, as are Input Types “Nonlinear” and “Thermocouple” and selections for “Unipolar” and “Fahrenheit.”
Controls, Indicators, and Connections
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Resolution as a Function of Sample Rate
The resolution of the DI-2108 is a function of sample rate. The lower the sample rate the higher the resolution. ADC 
resolution (R) is a function of selected sample rate per channel (F), and the number of enabled analog channels (C):

C Enabled Channels

1 1

2 2

4 3-4

8 5-8
Controls, Indicators, and Connections
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Digital Ports
The DI-2108 contains 7 general-purpose digital ports. Each digital port can be configured as a digital input or used as a 
switch to control an external load (up to 25 V and 100 mA). Many of the ports also provide specific functionality in 
WINDAQ or a third-party program.

D0 Event is for WINDAQ Remote Events. This bit inserts an event marker in your data.
D1 Record is for WINDAQ Remote Storage. This bit can be programmed to begin recording data.
D2 Rate is for Rate measurements: 10Hz to 50kHz.
D3 Count is for Counter/Timer measurements up to 65,536.
D6 Ext Trig is for third-party external triggers.

Equivalent Digital I/O Circuit:

Dig In Dx

Dx

10

4.7K

+5

4.7K

Control

3.3V
Controls, Indicators, and Connections
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WINDAQ Remote Events (D0 Event)
To use a switch closure or TTL signal to record WINDAQ Event Markers, connect signal leads to the appropriate 
Remote Control Event terminals on the DI-2108 as shown below.

Once the switch closure or TTL signal is connected, activate Remote Events through WINDAQ Acquisition Software. 
Events may be automatically placed on the rising or falling edge of the trigger signal. Use the menu command 
Options > Remote Events + to set WINDAQ to place event markers on low-to-high transitions of the Event input. 
Use the menu command Options > Remote Events - to set WINDAQ to place event markers on high-to-low transi-
tions of the Event input.

Event markers may also be placed in your data file manually by pressing the push button on the DI-2108 Instrument. 
You must enable Remote Events in WINDAQ to use the button (use the menu command Options > Remote Events 
+or Options > Remote Events -).

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.

Signal + Signal -

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.
Controls, Indicators, and Connections
15



DI-2108 Hardware Manual
An example event marker in a WINDAQ data file is shown below.

*Please Note: Event Markers do not display in the real-time WINDAQ acquisition software - they only display in the 
WINDAQ playback software (WWB).
Controls, Indicators, and Connections
16



DI-2108 Hardware Manual
WINDAQ Remote Storage (D1 Record)
To use a switch closure or TTL signal to begin recording data remotely, connect signal leads to the appropriate 
Remote Control Record terminals on the DI-2108 as shown below.

Once the switch closure or TTL signal is connected, activate Remote Storage (Record) through WINDAQ Acquisition 
Software. Storage to Disk may be automatically placed on the rising or falling edge of the trigger signal. Use the 
menu command Options > Remote Storage 1 to set WINDAQ to begin recording on low-to-high transitions of the 
Record input. Use the menu command Options > Remote Storage 0 to set WINDAQ to begin recording on high-to-
low transitions of the Record input.

WINDAQ Rate (D2 Rate)
Enable channel 10 to record Rate, or the number of falling-edge transitions per unit of time that are applied to this 
input. Click on Edit > Channels in the WINDAQ Acquisition menu to open the Channel Selection grid. Channel 10 is 

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.

Signal + Signal -
Controls, Indicators, and Connections
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the designated Rate channel. Click on the Channel 10 channel box to enable/disable Rates. The Channel 10 channel 
box will display an “R” when enabled.

Connect any TTL pulse stream (25 VDC max) to the D2 Rate channel on the DI-2108.

Select Channel 10 in the channel display, then select Edit > Channel Settings in the menu to specify a full scale 
range for the Rate channel. Ranges of 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, 10000, 20000, and 50000 Hz are 
available. Choose a range that comes closest to your expected full scale rate or frequency. For example, if you need to 

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.

Signal + Signal -
Controls, Indicators, and Connections
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measure the output of a flow meter that can measure a maximum flow rate of 100 gallons per minute, and the output 
frequency at that rate is 100 Hz, you would choose the 100 Hz range setting. A range setting of 200 Hz full scale sac-
rifices half of the instrument's resolution at 200 gallons per minute, and a range of 50 Hz allows measurements to 
only 50 gallons per minute full scale. 

Check the "Cycles/min" box to display and select frequencies reported in cycles per minute instead of cycles per sec-
ond (the measurement interval remains the same). Tachometer measurements in units of RPM (revolutions per min-
ute) is just one example that benefits from selecting this option. For example, if the 100 Hz range setting is selected 
and "Cycles/min" is checked, the full scale range is actually 6000 cycles per minute.

Please Note: To measure the maximum rate, which is defined as 2 times the Maximum Sample Rate/Channel , the 
current values of Maximum Sample Rate/Channel divided by Sample Rate per Channel MUST be an integer. 

WINDAQ Counter (D3 Count)
Enable channel 11 to record Counts, or the number of falling-edge transitions that are applied to this input. The count 
may be reset via WINDAQ software or under program control as necessary. Click on Edit > Channels in the WINDAQ 
Controls, Indicators, and Connections
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Acquisition menu to open the Channel Selection grid. Channel 11 is the designated Count channel. Click on the 
Channel 11 channel box to enable/disable Counts. The Channel 11 channel box will display a “C” when enabled.

The counter channel accumulates counts over time whether recording or in standby mode as soon as the Counter 
channel is enabled. The accumulated values will be recorded to your data file unless you reset the counts to zero. The 
maximum count value is 65,535 before the counter resets to zero automatically.

Use the Edit > Reset Count command in WINDAQ Acquisition software to reset counts immediately to zero. This 
feature is available in both standby and record modes.

Use the Edit > Preferences > Reset Count on New File Record in WINDAQ Acquisition software to reset the count at 
the start of a new file or when using the Edit > Preferences > Record Next File on Full or Open Next File on Full fea-
ture to reset counts to zero every time a new file is started.

Use the Edit > Preferences > Reset Count on Manual Record in WINDAQ Acquisition software to reset counts to 
zero every time you begin or resume recording a data file using the File > Record command (F4).
Controls, Indicators, and Connections
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Connect any TTL pulse stream (25 VDC max) to the D3 Count channel on the DI-2108.

General Purpose Digital Inputs

Enable Channel 9 for general-purpose digital input functions. Click on Edit > Channels in the WINDAQ Acquisition 
menu to open the Channel Selection grid. Channel 9 is the designated Digital Input channel. Click on the Channel 9 
channel box to enable/disable the digital inputs. The Channel 9 channel box will display an “I” when enabled.

Signal + Signal -

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.
Controls, Indicators, and Connections
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Channel 9 records and displays all the digital inputs, even the state of the Rate and Count inputs if those channels are 
enabled. With Channel 9 selected in the display window click Scaling > Digital Plot to show a digital display and 
make the data more meaningful on screen.

General Purpose Digital Outputs
Take care when configuring the load to be switched to ensure that the digital port is not damaged:

Dx

+5 +V

Dx

+5 +V

Dx

+5 +V

Dx

+5

Dx

+5
Controls, Indicators, and Connections
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4-20mA Current Loop Measurements
Use the following diagram for 4-20mA current loop measurement connections.

The shunt resistor should be placed on the low side of the circuit as shown below:

Status

D0 D1 D2 D3 D4 D5 D6

Model DI-2108

USB

Button

+5V GnD

CH8CH7CH6CH5CH4CH3CH2CH1

±50V Max

0-25V Max

CountRateRecordEventDrive

www.dataq.com

±10V  F.S.

Shunt Resistor 
Model R250

+ -

4-20 mA 
current source

Shunt Resistor

I
4-20mA

Current Loop 
Transmitter

Loop Power 
Supply

To DI-2108
Analog Input Channel

+ -

+
-

Controls, Indicators, and Connections
23



DI-2108 Hardware Manual
Set the engineering units as desired and define upper/lower levels in WINDAQ as 1V = 4mA for the low value and 5V 
= 20mA for the high value. For example, when using WINDAQ Acquisition software, in the EU Settings dialog box:

Enter the following values:

Visit our website at https://www.dataq.com/blog/data-acquisition/4-20-ma-current-loop-measurements/ to address all 
popular 4-20mA configurations.

You can also associate these values to a physical measurement such as pressure, load, flow, torque, etc. Read the Help 
files for more information regarding Engineering Units Settings.

LED Status Indicator
The DI-2108 provides a multicolor LED for instrument status and notification. Use the table below for a detailed 
description of each available state.

Vol
t

EU EU Tag

Upper Level 5 20
mA

Lower Level 1 4

State Mode Description

Connecting The device is looking for a connection to your PC or USB thumb 
drive. It will check the USB interface first, then the USB thumb drive. 
Once a connection is established the device will enter Idle mode.

Blinking White

Idle

USB Connected

The device is connected to and communicating with your PC through 
the USB port. The USB thumb drive and Ethernet port are not accessi-
ble.

Blinking Green

Idle

USB Drive Con-
nected

The is in Stand-alone mode. The USB interface is not accessible.

Blinking Green/
Yellow

Acquiring Data

to PC via USB 
Interface

WinDaq Acquisition Software is running and the device is acquiring 
data to your PC via the USB interface.

Blinking Blue
Controls, Indicators, and Connections
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USB Drive Port
Allows you to record to any USB flash memory device. Not all flash memory is fast enough to record at higher sam-
ple rates. Use the provided USB flash drive for rates below 20,000 S/s Throughput. Please Note: The mini-USB 
interface cannot be used in conjunction with the USB Drive. You MUST disconnect the device from the computer to 
record to the USB thumb drive.

Control Button
The Control Button can be used to stop or start recording data to your memory card (SD) when using the instrument 
as a stand-alone data logger. The Control Button can also be used to reconfigure the instrument to factory default set-
tings and to re-format memory card files left open due to power failure or other circumstance. The Control Button is 
inoperable while running WINDAQ Acquisition software.

Record Data to USB Thumb Drive
Record data to an installed USB thumb drive. The device must be in Idle mode and set for USB Drive (mode LED 
must be flashing Green/Yellow). After the button is pressed, the mode LED will flash Blue/Green or Blue/Cyan to 
indicate it is in a recording mode.

Recording Data

to USB thumb 
Drive

The device is acquiring data and recording to your USB thumb drive. 
Do not remove power - power interruption could result in data file cor-
ruption.

Blinking Blue/
Green

Armed

USB thumb Drive 
is waiting for a trig-
ger condition

The device is acquiring data and waiting for a trigger condition to 
begin recording to your USB thumb drive.  Do not remove power or 
the USB thumb drive - either could result in data file corruption.

Blinking Blue/
Cyan

Re-armed

USB thumb Drive 
is waiting for a trig-
ger condition

The device is acquiring data and waiting for another trigger condition 
to continue recording to your USB thumb drive. Do not remove power 
or the USB thumb drive - either could result in data file corruption.

Blinking Blue/
Cyan

Busy

USB thumb Drive 
is busy

The device is reading from or writing to the USB thumb drive. Do not 
remove power or the USB thumb drive - either could result in data file 
corruption.

Blinking Red

Error The device is unable to perform any operations. Use the control button 
or cycle power to resolve the error. 

Solid Red

Button Pushed The LED turns white to indicate the control button is engaged.

Solid White

Idle

USB connected in 
CDC mode

The device is connected to and communicating with your PC through 
the USB port in CDC mode. WinDaq software will not run. The USB 
thumb drive and Ethernet port are not accessible.

Blinking Yellow
Controls, Indicators, and Connections
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Stop Recording to USB Thumb Drive
Manually stop recording to the USB thumb drive (when the mode LED is flashing Blue/Green, Blue/Cyan, or Blue/
Magenta). After the button is pressed the mode LED witll flash Green/Yellow to indicate Idle.

Fix Errors
The Control Button can also be used to fix some common operating errors. When the instrument is in Error mode 
(mode LED is solid red), some action must be taken to fix the error before you can use it. Generally, the Control But-
ton can be used to make the instrument operational again when in Error mode.

Switching between LibUSB and CDC Modes

The native communication mode of the DI-2108 is LibUSB but it can be switched to the USB CDC (Communication 
Device Class). CDC mode allows the USB port of DI-2108 devices to appear like a traditional RS-232 port, which is 
common across most operating systems and development languages. Please note: LibUSB communication is 
required for WinDaq Acquisition software and programming with our .NET SDK. Only switch to CDC mode when 
writing your own programs at the protocol level (for example, Python applications). Use the following sequence to 
switch your device to/from LibUSB/CDC modes:

1. Connect the device to your PC via the USB port.

2. Apply power to the device.

3. When mode LED stops blinking white and is in Idle mode, push and hold the Control button. This must be com-
pleted within five seconds after the device is in Idle mode.

4. When the mode LED turns red, release the Control button.

5. The Mode LED will flash white then indicate Idle in either LibUSB or CDC mode:

• CDC mode: Blinking Yellow

• LibUSB mode: Blinking Green

Save Stand-alone configuration to Thumb Drive

Save stand-alone configuration settings using the Control Button. Stand-alone configurations can also be saved to the 
thumb drive via the Dashboard (preferred method). See “WinDaq Dashboard” on page 27. Device must be in Idle 
mode for USB thumb Drive (mode LED blinks green/yellow). The Unlock Code must be purchased for your device 
in order to save the stand-alone configuration.

1. Format your USB thumb drive using your PC.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.

4. Plug the formatted (empty) thumb drive into the device (Drive) while holding the button in.

5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the thumb drive and revert to Idle mode when complete.

Configuration files include config.whd or config.whc. Use the WinDaq Dashboard to create configuration files.

Apply Stand-alone Configuration to Device

Load stand-alone configuration settings using the Control Button. Stand-alone configurations can also be applied via 
the Dashboard (preferred method). See “WinDaq Dashboard” on page 27. Device must be in Idle mode for USB 
Controls, Indicators, and Connections
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thumb Drive (mode LED blinks green/yellow). The Unlock Code must be purchased for your device in order to apply 
the stand-alone configuration.

1. Save configuration files to your USB thumb drive.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.

4. Plug the thumb drive into the device (Drive) while holding the button in.

5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the device and revert to Idle mode when complete.

Configuration files include config.whd or config.whc. Use the WinDaq Dashboard to create configuration files.

WinDaq Dashboard
The WinDaq Dashboard allows you to run WinDaq Data Acquisition software, sync the device clock with your PC, 
configure your instrument for stand-alone data logging to record data to a USB flash drive..
Controls, Indicators, and Connections
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Use the Configure menu to access the Stand alone setup window.

Select and configure all channels available on your device, select a sampling interval, and setup recording Trigger 
conditions. The Stand alone configuration also allows you to Save/Load configurations via the File menu. Use the 
help file provided in WinDaq Dashboard to learn more.
Controls, Indicators, and Connections
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5. Unlock WinDaq or Stand-
alone Operation
The DI-2108 will record up to four channels using WinDaq/Lite software and a single channel to the USB thumb 
drive. An unlock code is required to record all of the channels on the device. There are two unlock codes available for 
the DI-2108. Go to https://www.dataq.com/products/di-2108/ to purchase the unlock codes (go to Accessories) or call 
330-668-1444. Once purchased, you will be given a Key code to enter into WinDaq or the WinDaq Dashboard.

WinDaq/Unlock
Allows you to record more than four channels to WinDaq.

1. Start WinDaq Acquisition software.

2. Click the menu item Help > Unlock WinDaq.

3. Enter the Key in the appropriate dialog boxes.

4. Click OK.

SA-Enabled
Allows you to unlock all channels for stand-alone data logging as well as all the channels in WinDaq.

1. Start WinDaq Dashboard software.
Unlock WinDaq
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2. Select your device and click the menu item Configure > Stand Alone Setup.

3. Click on the Yes button to enter your code. Click on the No button to go to Stand-alone configuration for a single 
channel.

4. Enter the Key in the appropriate dialog boxes.

5. Click OK.
Unlock WinDaq
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6. Dimensional Drawing

Top View

Side View

All dimensions in inches
Dimensional Drawing
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DATAQ Instruments, Inc.
241 Springside Drive
Akron, Ohio 44333

Telephone: 330-668-1444
Fax: 330-666-5434

Submit a support ticket to: www.dataq.com/ticket

Direct Product Links
(click on text to jump to page)

Data Acquisition | Data Logger

http://www.dataq.com/data-acquisition/
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