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Waveform Recording with WINDAQ/Tach 
 
 
GENERAL 
WINDAQ/Tach is a special version of WinDaq/Pro software that allows the X-axis of WinDaq data acquisition 
software to be incremented based on distance as opposed to time.  WinDaq/Pro is a Windows™ based data 
acquisition software package that gives any of our hardware products simultaneous real-time display and data 
storage to disk capability.   
 
At this time, WinDaq/Tach operates only with model DI-720-USB and DI-730-USB data acquisition hardware from 
DATAQ Instruments.  This hardware provides the best balance in terms of channel count and flexibility, but other 
hardware support may be added in the future.    
 
To operate WINDAQ/Tach, you will need two TTL signals: a direction signal and a speed, or tachometer, signal.  For 
the DI-720, the direction signal connects to the event input on the front of the instrument (pin 25 of the secondary 
connector).  The tachometer signal connects to the start/stop input (pin 6 of the secondary connector).  Common for 
both signals should connect to pin 28 or pin 19.  Operation with the DI-730 requires an adapter cable, part #100679.  
When this cable is plugged into the back of the instrument, the pinout for the signals becomes the same as the DI-
720. 
 
Using WINDAQ/Tach, you will be able to perform the following functions: 
 
• Record waveform data to disk in the background while running any combination of programs in the foreground. 
 
• Annotate your data with descriptive event marker comments, even while recording to disk. 
 
• Monitor the real time display in a smooth scroll or triggered sweep mode of operation, scaled to any unit of 

measure. 
 
• And much, much more. 
 
This manual covers the WINDAQ/Tach waveform acquisition package for Windows™ and is intended for users of 
all proficiency levels. The reference information at the beginning of this section describes how to start the 
WINDAQ/Tach waveform acquisition package, what you will see when in WINDAQ/Tach, and how to navigate 
within WINDAQ/Tach. After this reference information, each acquisition command or function is described in detail. 
 
To help you find the information you want, the reference information contains a menu hierarchy with page 
references. Also included is a chart cross referencing commands with menus. 
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Required Hardware Connections 
 
WinDaq/Tach software requires two digital inputs: one for tachometer and a second for direction.  Digital inputs 
DI0 and DI1 on the auxiliary IO connectors of DI-720 and 730 series products are reserved for these connections.  
DI0 connects to a TTL level direction signal and DI1 connects to a TLL level tachometer signal.  The following 
describes how each is connected to a DI-720 or 730 in a variety of different configurations. 
 
For the DI-720 Only: 
 

 
You can connect the digital inputs to the auxiliary connector (circled) of the DI-720.  The tachometer input connects 
to DI1, Pin 6, and the direction input connects to DI0, Pin 25. 
 
For the DI-720 and 730: 
 
Both the DI-720 and 730 can be accessed through their expansion port connector by using adapter cable #100679.  
This cable provides the necessary mating connector for the expansion output, and a standard 37-pin D-sub 
connector on the other end that matches the auxiliary connector of the DI-720 (circled).  Once the cable is 
connected to the expansion port, the pinout on the D-sub end will be the same as with the DI-720: tachometer input 
connects to DI1, Pin 6, and direction input connects to DI0, Pin 25. 
 
For the DI-720 and 730 with DI-75B or DI-725 Expander Units 
 
Both the DI-720 and 730 can be expanded with DI-75B or DI-725 expander units.  All expander units have 
connectors labeled “Expansion In” and “Expansion Out”.  An expansion cable always connects the expansion port 
connector to the “Expansion In” connector on the expander unit.  Regardless of the number of expander units you 
use, there will always be an “Expansion Out” connector available on the last unit.  You will need to connect adapter 
cable # 100679 to this “Expansion Out” connector.  Once the cable is connected to the expansion port, the pinout on 
the D-sub end will be the same as with the DI-720: tachometer input connects to DI1, Pin 6, and direction input 
connects to DI0, Pin 25. 
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REFERENCE INFORMATION 
 
 

CONVENTIONS USED IN THE DOCUMENTATION 
Before you start using WINDAQ/Tach, it’s important to understand the terms and notational conventions used in this 
documentation. 
 
General Conventions 
 • Commands you choose are given with the menu name preceding the command name. For example, the phrase 

“Choose File Open” tells you to choose the Open command from the File menu. This naming convention 
describes the sequence you follow in choosing a command — first you select the menu, then you choose the 
command. 

 
 • WINDAQ/Tach functions are presented with both mouse and keyboard procedures, and where applicable, with 

the corresponding ToolBox button. When separate mouse and keyboard procedures are listed for a function, 
you can identify each procedure by the mouse or keyboard icon. The mouse icon represents procedures that 
are accomplished using the mouse and the keyboard icon represents procedures that are accomplished using 
the keyboard. The button icon represents the procedure accomplished with the ToolBox. 

 

Mouse icon Keyboard icon  
 

 
ToolBox button icon (typical) 

 

Mouse Conventions 
In general, most WINDAQ/Tach mouse actions require only the left mouse button. For example, carrying out a menu 
command or working in a dialog box requires only the left mouse button. However, the right mouse button is not 
totally neglected. Among other things, the right mouse button is used for copying waveform data to the clipboard, 
waveform scaling, selecting a waveform channel, centering the cursor on the screen, and moving the horizontal 
crosshair on a spectrum plot when in the WINDAQ Waveform Browser FFT mode.  
 
Since the majority of mouse procedures are done with the left mouse button, we will not specify which mouse 
button to click, drag, or double-click with in the procedures unless it is the right mouse button. When the right 
mouse button is required, it will be specified as such. For example, “Double-click the right mouse button anywhere 
in the bottom annotation line to move the cursor to the lowest displayed waveform valley.” When not specified, the 
left mouse button is assumed for the procedure. 
 
 • “Point” means to position the mouse pointer until the tip of the pointer rests on what you want to point to on 

the screen. For example, “Point to the View menu.” 
 
 • “Click” means to press and immediately release the mouse button without moving the mouse. For example, 

“To display the menu that contains the command you want, click the menu name in the menu bar.” 
 
 • “Double-click” means to click the mouse button twice in rapid succession. For example, “Double-click the 

WINDAQ/Tach icon to start the WINDAQ/Tach waveform acquisition program.” 
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 • “Drag” means to press the mouse button and hold it down while you move the mouse; then release the button. 

For example, “Drag down to Data Cursor to enabled the cursor for on-screen display.” 
 

Keyboard Conventions 
 • Key names match the names shown on most keyboards and appear in capital letters. For example, the Shift 

key appears as SHIFT. 
 
 • A plus sign (+) used between two key names indicates that you must press both keys at the same time. For 

example, “Press SHIFT + F1” means that you press the SHIFT key and hold it down while you press the F1 
key. 

 
 • A comma (,) between two key names indicates that those keys must be pressed sequentially. For example, 

“Press ALT, F, O” means that you press the ALT key and release it, press F and release it, and then press O 
and release it. 

 
 • The keys that you use to move around in WINDAQ/Tach are referred to as cursor control keys; they include the 

↑ , ↓ , ←, and → keys, HOME, END, PG UP, and PG DN.  
 

STARTING THE WinDaq/Tach WAVEFORM 
ACQUISITION PROGRAM 
To start WINDAQ/Tach, you must first start Windows . From Windows , use the mouse to double-click on the 
WINDAQ/Tach icon, or use the cursor keys to highlight the WINDAQ/Tach icon and then press ENTER. When 
successfully invoked, WINDAQ/Tach displays its default screen. The default settings are as follows:  
 
1. The SET UP operating mode enabled. 
 
2. Waveform storage to disk disabled. 
 
3. One channel enabled (channel 0), configured for single-ended operation. 
 
4. One waveform channel displayed. 
 
5. Oscilloscope display mode enabled. 
 
6. Channel 0 scale set to ±5 volts full scale. 
 
7. Channel 0 screen full scale and base line annotation enabled. 
 
8. Waveform window 1 is assigned to channel 0 (annotated as “1=0” in the left annotation margin). 
 
9. The sample rate is set to 100 samples per second. 
 
10. The waveform compression factor is set to 1. 
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THE WINDAQ/Tach WAVEFORM ACQUISITION 
WINDOW 
The typical WINDAQ/Tach acquisition window consists of six fundamental components: the title bar, menu bar, 
status bar, left/right annotation margin, waveform strip area, and the bottom annotation line. These components are 
shown in the following illustration. 
 

 
 
 
Title bar: The title bar has two purposes: it identifies a file through the file name and it serves as a visual cue 

that the window may be moved or manipulated. The title bar consists of two parts: the window title 
and the window sizing icons. 

 

 
 
 Window title: The window title contains the WINDAQ/Tach utility name and the currently active data 

storage file name. 
 
 Window sizing icons: The window sizing icons provide a fast, convenient way to reduce, enlarge, 

close, or return the window to its previous size. Selecting one of these icons with the mouse performs 
that action. 

 
Menu bar: Like other Windows  applications, WINDAQ/Tach contains a menu bar. The commands available in 

WINDAQ/Tach are grouped on menus. These menus appear in the bar across the top of the window 
and represent the heart of the WINDAQ/Tach waveform acquisition package.  

 

 
 
 With these menus you can apply the powerful waveform acquisition capabilities of WINDAQ/Tach. 

To choose a command from a menu, you can either point to the desired menu and click, or press the 
ALT key and then the underlined letter of the desired menu. This causes the commands available on 
that menu to be “pulled down” or displayed. Once displayed, the commands on the pull-down menu 
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can be chosen (and thus performed) by clicking on the desired command or by pressing the 
underlined letter in the desired command. Also provided on the pull-down menus are keyboard 
shortcuts or accelerators. Accelerators are function keys or combinations of keys displayed next to 
the menu item that when pressed, immediately invokes the desired action. This lets you bypass the 
pull-down menus and carry out commands directly from the keyboard, a time-saving feature when 
processing repetitive tasks. Refer to the WINDAQ/Tach Acquisition Menu Hierarchy for a listing of 
accelerators. Refer to the WINDAQ/Tach Pull-Down Menus chart for a “roadmap” of command 
locations. 

 
 When you choose a command that is followed by an ellipsis (…), WINDAQ/Tach displays a dialog 

box indicating that more information must be entered or an option must be selected before the 
command can be carried out. 

 
 Some command names occasionally appear dimmed. This indicates that the command does not apply 

to the current situation or that you may need to make a selection or complete an action before 
choosing the command. 

 
Status bar: The status bar has two purposes: to display the current status of acquisition parameters and to provide 

a fast, convenient, short-cut method for selecting display mode, sample rate, channels, and 
compression for modification. 

 
 The settings of all current acquisition parameters are shown here. Additionally, the progress of data 

storage to disk is shown in the Storage:  % used field and the number of screen updates per 
second (how many times the display is redrawn) is shown in the Frames/s: field. 

 
 Double clicking on the Mode: field toggles the operating mode between scroll mode and 

oscilloscope mode (the same as choosing Options Scroll Mode or Options Oscilloscope Mode…). 
Double clicking on the S/s (F3): field displays the sample rate dialog box (the same as choosing 
Sample Rate… from the Edit menu or clicking the Sample Rate button in the ToolBox). Double 
clicking on the Channels: field displays the channels selection block cursor (just like selecting 
Edit Channels…). Double clicking on the Compress (F7): field displays the compression dialog 
box (similar to selecting Edit Compression…). 

 

 
 
Left/Right The left and/or right annotation margin has three purposes: it can be used for channel selection, it can 
Margin be used with the mouse to scale the displayed waveform, and it displays the numerical values of the 

waveform. 
 
 When more than one waveform is displayed on the screen, clicking the left mouse button in the 

unselected channel’s annotation margin selects that channel. 
 
 Clicking the left mouse button in the annotation margin of a selected channel doubles the vertical size 

of the waveform. Conversely, clicking the right mouse button in the annotation margin of a selected 
channel reduces the vertical size of the waveform by one half. 

 
 Clicking the right mouse button in the annotation margin of an unselected channel starts a graphic 

selection rectangle, which is used by the Edit Copy command. 
 
 A selection rectangle can also be used with the annotation margins to scale the waveform. For 

example, if you wanted to examine a small section of waveform in greater detail, it is possible to fill 
the entire channel with the small section of waveform. This is done by drawing a selection rectangle 
and then clicking the left mouse button in the annotation margin. A selection rectangle is drawn by 
dragging anywhere in the strip until the area of interest is enclosed in the rectangle. When the left 
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mouse button is released, the rectangle remains on the display framing the area of interest. Now click 
the left mouse button in the annotation margin to enlarge the contents of the selection rectangle to full 
strip size. Conversely, the entire waveform can be shrunk to fit inside a similarly drawn rectangle 
using the right mouse button. 

 
 Only the left annotation margin is displayed when a non-overlapped screen format is selected, and 

both the right and left annotation margins are displayed when an overlapped screen format is selected. 
The information displayed in either margin is identical in format and consists of three parts: the 
variable waveform assignment indicator, the numeric value of the waveform at the real time point, 
and the ±full scale values for the waveform strip. 

 

 
 
 Variable waveform assignment indicator: The variable waveform assignment indicator allows any 

enabled channel to be assigned to a specified display window. The highlighted box surrounding the 
X=Y annotation indicates that the window is selected, meaning the waveform contained in the strip 
can be scaled, offset, or otherwise adjusted. Note that the waveform can only be scaled or adjusted 
when the window is selected. 

 
 Numeric value of waveform at real time point: This field appears when Data Display is enabled from 

the Options menu. When Current Data is enabled (also from the Options menu) in the oscilloscope 
display mode, this field displays the waveform value at the cursor position. When Current Data is 
enabled in the scroll display mode, this field displays the waveform value at the real time point 
(rightmost edge of window). When Current Data is disabled, this field displays the baseline value of 
the waveform window. 

 
 ±Full scale values for the waveform strip: These values indicate the ±full scale values of the 

waveform window. If desired, these values may be specified and the waveform will be automatically 
scaled to fit the new values. This is useful for displaying the waveform strip in whole numbers (e.g., 0 
- 200 mmHg instead of 10.372 - 189.628 mmHg). 

 
Waveform While acquiring data continuously to disk, the waveform strip area maintains a real time display  
strip:  of the acquired waveforms. The real time display provides the most flexible and functional waveform 

display available. It allows you to maintain complete control over data acquisition parameters in real 
time through mouse and/or keyboard features. Control sample rate, waveform compression, the 
number of channels enabled, event markers, disk storage, and much more.  
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Bottom The bottom annotation line consists of three elements: the equivalent per channel sampling rate, the  
annotation distance per grid division, and the current operating mode. 
line: 
 

 
 
 Equivalent per channel sampling rate: The equivalent per channel sampling rate is derived by dividing 

the selected sample throughput rate (displayed in the S/s (F3): field of the status bar) by the number of 
channels enabled. 

 
 Distance per grid division: The distance per grid division is a function of the selected sample rate, the 

number of channels enabled, and the selected waveform compression factor. The grid on the display 
provides a convenient distance reference for the display in meters per division.  

 
 Current operating mode: The current operating mode field displays one of the three data acquisition 

operating modes: SET-UP, RECORD, or STBY. 
 

DRAWING A SELECTION RECTANGLE AND A 
GRAPHIC SELECTION RECTANGLE 
In WINDAQ/Tach, you can draw a graphic selection rectangle and just a plain selection rectangle. A graphic 
selection rectangle is used to copy the graphics bounded by the graphic selection rectangle (drawn with the mouse) 
to the clipboard. The selection rectangle is used with the mouse just to offset and/or scale a waveform.  
 
Both rectangles are drawn the same way, only the graphic selection rectangle is created with the right mouse button 
while the selection rectangle is created with the left mouse button. 
 
A graphic selection rectangle is drawn by positioning the mouse pointer anywhere in the waveform strip area and 
dragging with the right mouse button until the rectangle encloses the area you wish to copy to the clipboard. When 
the mouse button is released, the rectangle remains fixed in size. You can now choose Copy from the Edit menu to 
copy the enclosed graphics to the clipboard. 
 
A selection rectangle is drawn by positioning the mouse pointer anywhere in the waveform strip area and dragging 
with the left mouse button until the rectangle reaches the desired size. When the mouse button is released, the 
rectangle remains fixed in size. The following examples illustrate how the selection rectangle can be used in typical 
offsetting and scaling operations. 
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Offsetting a Specified Channel’s Waveform 
 

 
 

 1. The original waveform. The object is to offset the waveform from its current position to a position centered 
on the screen. Note that the “1=0” annotation in the left annotation margin is highlighted, indicating 
window 1 is enabled for adjustments. 

 

 
 
 2. Drag the left mouse button to draw a selection rectangle. The size (and placement) of the rectangle is 

immaterial. In this example, it was drawn to approximate the vertical limits of the waveform so it could be 
accurately centered at the center of the screen. Note that the rectangle remains fixed in size when the left 
mouse button is released. 
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 3. With the mouse pointer positioned inside the selection rectangle, drag the rectangle to achieve the desired 

offset (in this example, vertically centered at the center of the screen). 
 

 
 
 4. The offset waveform. When the left mouse button was released, the waveform was vertically offset by the 

amount the rectangle was dragged (within the limits of the A/D converter’s dynamic range). Note the 
waveform’s numerical values in the left annotation margin reflect the new position. 
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Scaling a Specified Channel’s Waveform 
 

 
 
 1. The original waveform. The object is to scale a small section of waveform so it fills the entire strip area, 

thus allowing the small section to be examined in greater detail. Again note that the “1=0” annotation in the 
left annotation margin is highlighted, indicating window 1 is enabled for adjustments. 

 

 
 
 2. Drag the left mouse button to draw a selection rectangle. Once again, the size of the rectangle is 

immaterial. In this example, it was drawn on the very tip of the waveform because this is the area of 
interest that we would like to examine in greater detail. Note that the rectangle remains fixed in size when 
the left mouse button is released. 

 



WAVEFORM RECORDING WITH W INDAQ/Tach 
 
 

16 

 
 
 3. The scaled waveform, accomplished by clicking the left mouse button in the left annotation margin. The 

contents of the selection rectangle have been scaled to fill the entire waveform strip area. 



WAVEFORM RECORDING WITH W INDAQ/Tach 
 
 

17 

 

A TYPICAL DATA ACQUISITION SCREEN USING 
WinDaq/Tach 
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WinDaq/Tach Pull-Down Menus 
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WINDAQ/Tach COMMAND HIERARCHY 
 
Menu Command Command Options Accelerator key(s) Reference 
File 
 Open…  CTRL+O 4-18 
 Open Reference File…   4-61 
 Close   4-40 
 Save Default Setup   4-44 
 Record  F4 4-21 
 Stop  CTRL+F4 4-21 
 Browse  Alt+J  
 Freeze  Ctrl+F 
 Exit…   4-74 
 
Edit 
 Undo  CTRL+Z 4-93 
 Copy  CTRL+C 4-43 
 Sample Rate…  F3 4-79 
 Channels…  F5 4-41 
 Channel Settings…  F10 4-32 
 Low Calibration…  F9 4-102 
 High Calibration…  F11 4-103 
 Fixed Calibration…  F12 4-97 
 User Annotation…  F11 4-94 
 Insert Mark  CTRL+Space 4-55 
 Insert Commented Mark… SHIFT+Space 4-55 
 Compression…  F7 4-106 
 Compression x2  Page Up 4-107 
 Compression /2  Page Down 4-107 
 Location  Alt+Shift+O 4-52 
 Tachometer  Alt+T 4-78 
 Preferences Update Interval…  4-66 
  Scroll Limit…  4-67 
  Skip Factor…  4-68 
  Buffer Size…  4-69 
  Beep on Gap  4-69 
  Frame Rate  4-70 
  Maximum Sample Rate…  4-70, 79 
  Event Mark Capacity…  4-71 
  Open New File on Full  4-71 
  Record Next File on Full  4-72 
  Thermocouple Type… (Not functional in WinDaq/Tach)  
  New Password...  
  Broadcast Sync Messages 
  Exit on Full 
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Menu Command Command Options Accelerator key(s) Reference 
 
View 
 Assign Channel…  = 4-95 
 Assign Range…  : 4-75 
 Forward Range  CTRL+Down 4-76 
 Backward Range  CTRL+Up 4-76 
 Format Screen   4-50 
 Next Palette  ALT+P 4-62 
 Previous Palette  ALT+SHIFT+P 4-62 
 User Palette…  CTRL+U 4-63 
 ToolBox  CTRL+T 4-89 
 
Scaling 
 Limits…  ALT+F9 4-99, 104 
 Show Dynamic Range  ALT+R 4-87 
 Grow 2X  Up 4-109 
 Shrink 2X  Down 4-109 
 Invert  CTRL+I 4-60 
 Waveform Down 1 Pixel Gray - 4-110 
 Waveform Down 10 Pixels CTRL+Gray - 4-110 
 Waveform Up 1 Pixel  Gray + 4-110 
 Waveform Up 10 Pixels  CTRL+Gray + 4-110 
 Analog Plot  ALT+SHIFT+N 4-45 
 Digital Plot…  ALT+SHIFT+T 4-46 
 
Options 
 Current Data  ALT+F2 4-83 
 Data Display  F2 4-83 
 Limit Display  ALT+L 4-84 
 Grids  ALT+G 4-86 
 Grid Spacing  Ctrl+G 
 User Annotation  ALT+U 4-84 
 Scroll Mode  CTRL+F1 4-52 
 Oscilloscope Mode…   4-52 
 Fast Scroll   4-58 
 Pause Graphics  ALT+F1 4-52 
 Beep on File Full   4-39 
 
Help    4-50 
 Contents    
 Keyboard    
 Mouse    
 Search for Help On…    
 How to Use Help    
 About WinDaq Acquisition 
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WINDAQ/Tach OPERATING MODES 
 

GENERAL 
WINDAQ/Tach is a special version of WINDAQ/Pro software that allows the X-axis of WinDaq data acquisition 
software to be incremented based on distance as opposed to time.  The software was developed specifically for rail 
inspection applications where there is a need to precisely locate faults in train rails as part of routine and on-going 
maintenance. 
 
At this point, WINDAQ/Tach operates only with model lDI-720-USB and DI-730-USB data acquisition hardware 
from DATAQ instruments.  This hardware provides the best balance in terms of channel count and flexibility for the 
intended application, but other hardware support may be added in the future. 
 
Your WINDAQ/Tach data acquisition system allows three operating modes during acquisition. These are, in logical 
order of occurrence: Setup; Record; and Standby. Each operating mode shares many features with the other three, 
but there are some features accessible only from one given mode. The three modes are discussed in detail as 
follows: 
 
The SET UP operating mode is active when WINDAQ/Tach is first started. SET UP is used to configure data 
acquisition parameters such as the number of acquired channels, their type (differential or single-ended), channel 
programmable gain, and channel programmable offset. In addition, this mode is used to adjust the real time display 
for a visually pleasing presentation. Virtually all other data acquisition functions and adjustments are available from 
the SET UP operating mode including control of the real time display screen’s scaling and offset functions. In this 
mode only the real time display is active, data is not yet being streamed to disk. When in this mode, the Status: area 
of the bottom annotation line displays SET-UP. 
 
The RECORD operating mode is active when a file has been opened and the Record command has been chosen. 
RECORD is used to stream waveform information to disk. While in this mode, all data acquisition features and 
functions are available (with some restrictions) except the following: all channel-specific operations (i.e., channel 
number, type, gain, offset); sample rate adjustments; and REMOTE CONTROL features. In this mode, waveform 
information is being continuously streamed to disk while the real time display remains active. When in this mode, 
the Status: area of the bottom annotation line displays RECORD. 
 
The STANDBY operating mode becomes active when waveform recording to disk is temporarily suspended by 
choosing the Stop command. While in this operating mode, all data acquisition features and functions are available 
except: Channel-specific operations (i.e. channel number, type, gain, and offset) and Sample rate adjustments. In 
this mode only the real time display is active, data acquisition to disk has been stopped. When in this mode, the 
Status: area of the bottom annotation line displays STBY. 
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WINDAQ/Tach GENERAL INFORMATION 
 

INSTALLATION 
To install WINDAQ/Tach software under Windows 98, 2000 or ME, insert the floppy and click Start, Run.  Type 
A:/NEW_TCH.EXE before pressing Enter. 
 

DIGITAL INPUT 
WINDAQ/Tach uses two digital input lines of the DI-720 or -730: one for detecting forward/backward direction and 
the other for detecting distance.  Both are assumed to be TTL compatible signals.  The distance signal is further 
assumed to be a pulse train (tachometer) whose frequency is directly proportional to speed.  By combining the 
information from these two sources along with acquired analog information, any anomaly detected on an analog 
waveform and subsequently stored to disk may be correlated with a precise location during playback. 
 
When using WINDAQ/Tach distance-based data acquisition, the operator must specify an analog channel sample rate 
high enough so that the reciprocal of the rate per channel is less than the minimum width of the tachometer pulses 
and the minimum  spacing between pulses.  For example, while recording three channels at 10,000 s/s, the 
tachometer pulses applied to the tachometer digital input must be at least 300 us wide and 300 us apart to ensure 
detection.  In order to avoid having to write the tachometer-handling code in assembly language, it will be 
implemented in 32-bit code for Win95/98 or Windows 2000. 
 
The digital inputs are sampled each time an analog data value is converted for the first channel in the scan list.  The 
state of the direction input when the tachometer pulse happens to be sampled will determine whether it is treated as 
a forward or backward motion.  The set of channel data on which the pulse was first detected will be displayed on 
the screen (and stored to the file is recording).  The time skew between readings will be the reciprocal of the A/D 
converter burst rate, which is a multiple of the total sample rate, less than or equal to Edit-Preferences-Maximum 
Sample Rate but greater than half that rate. 
 
To distinguish it from the location values in kilometers displayed by acquisition, the word distance in what follows 
refers to tachometer displacement while storing to disk.  The acquisition display will always update from left to 
right, or scroll new data in from the right regardless of the direction of the lower right corner of the screen.  This is 
the kilometer-post location of the tachometer when the number is displayed, about 9 times per second.  If Edit-
Preferences-Update Interval is not zero, the graphics and location display will continue while menus and dialog 
boxes are open. 
 
The standard WINDAQ/Pro options Triggered Mode, Triggered Storage, Remote Storage and Remote Events will all 
be disabled with the WINDAQ/Tach version of software. 
 
Appending to a WINDAQ/Tach or opening a reference file will set the tachometer calibration to match the file, and if 
it changes, the displayed location will change and will need to be readjusted. 
 
The 32-bit positive file trailer items normally used for time stamps will instead be used for location stamps.  The 
low-order 30 bits will be a 2’s complement signed number of tachometer pulses, with a range of ±5368.709110 KM 
for a tachometer producing one pulse every 10 mm.  Data bit 30 will be a direction flag, with a 1 indicating that the 
data starting at that file point until the next acquisition start represents decreasing location.  While recording, each 
time the tachometer reverses a location stamp will be automatically generated, using 2 trailer items toward the 
maximum of 16, 384 allowed per manual start in Edit-Preferences-Event Mark Capacity.  Each user-generated 
commented event mark uses 2 trailer items. 
 
The WINDAQ/Tach application is named DI200TNT.EXE instead of DI200ANT.EXE, and File Browse executes 
WWB/Tach (WINDAT32.EXE) instead of WINDAQ32.EXE.  The help files DI200TNT.HLP and 
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WINDAT32.HLP are named for their corresponding applications.  A special tachometer-scanning process 
DISCN740.EXE in \WINDOWS\SYSTEM or \WINNT\SYSTEM32 is used instead of the usual DISCN720.EXE 
from WINDAQ/Pro, but DI740NT.DLL is just the normal DI720NT.DLL renamed to launch the special 
DISCN740.EXE.  The other processes DICMP740.EXE and WDQDK740.EXE are just renamed copies of the usual 
DICMP720.EXE and WDQDK720.EXE.  The default extension for WINDAQ/Tach is .WDT to distinguish them 
from .WDQ files and WWB/Tach should be associated with this extension in My Computer-View-Folder Options-
File Types.  WINDAQ/Tach and WINDAQ/Pro can coexist in the same directory if the user is careful to avoid Options 
Triggered Mode, Triggered Storage, Remote Storage, and Remote Events.  File Save Default Setup from 
WINDAQ/Pro will destroy the Edit Tachometer calibration, but it can be restored manually or by reading a .WDT 
reference file.  If you plan to use WINDAQ/Pro for much more that checking out the hardware when tachometer 
problems cause WINDAQ/Tach display to not advance, you can avoid this problem and the above restrictions by 
putting the WINDAQ/Tach data files and CODASPAR.BIN in a separate directory, which the shortcut that launches 
it should start in. 
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COMMAND REFERENCE 
 
GENERAL 
This is the part of the manual that describes in detail all of the data acquisition commands. The following 
information describes how the information is presented. 
 
FUNCTION  describes what the command is used for and what it will do. 
 
ACTIVATING PROCEDURE  describes the action required to activate the command. Whenever applicable, the 
information presented under this heading contains both mouse and keyboard procedures, identified by the mouse 
and keyboard icon in the left margin. 
 
SPECIAL CONSIDERATIONS  describes information beyond activating the command. 
 
EXAMPLE  shows an example of how the command is used. 
 



WAVEFORM RECORDING WITH W INDAQ/Tach 
 
 

26 

ACQUIRE DATA TO DISK FUNCTION 
 
 
FUNCTION 
Used to record data  to the selected disk drive. 
 
 
ACTIVATING PROCEDURE 
The Record function on the File menu controls data acquisition to disk. When first enabled, WINDAQ/Tach is 
automatically placed in the SET-UP operating mode (the status field in the bottom annotation line indicates SET-
UP). This mode allows you to configure the front-end instrumentation (i.e., sample rate, channels, gain, etc.) and the 
real time display so the waveform looks pleasing on your monitor. In the SET-UP mode, the Record function on the 
File menu is dimmed until a file name is specified. After all aspects of the waveform are configured and you are 
ready to record data to disk, you must assign a file name to enable the Record function. This is done as follows: 

 Click the Open/Close File button in the ToolBox. 

 Point to the File menu and drag down to Open… 

 Choose File Open (ALT, F, O). 
 
This displays the Open dialog box. It is here that you specify a file name (to create a new file) or open an existing 
file (to append to it).  
 

 
 
 
Appending to an Existing File 

 In the File Name list box, double-click the name of the file you want to open. 

 1. In the File Name text box type the filename or press the TAB key then the ↑  or ↓  key to select the 
filename. 

 2. Press ENTER. 
 
If the file you want is not listed in the File Name box, select a new drive or directory in the Open dialog box. If the 
file you want is not a WINDAQ/Tach file, select a different type of file in the List Files of Type box: 
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 Do one of the following: 
If the file is To display its name in the File Name box

In a different subdirectory Double-click the directory in the Directories box.

On a different drive Click the arrow in the Drives box, and then click the 
drive letter.

Of a different file type Click the arrow in the List Files Of Type box, and 
then click the type of file.

 
 

 Press ALT+D to select from the Directories box, ALT+V to select from the Drives box, or ALT+T to select 
from the List Files of Type box. 

 
When the desired file is selected, the following confirmation box appears: 
 

 
 
Choosing No aborts the file open procedure. Choosing Yes invokes the following File Size dialog box, which allows 
you to specify (in either kilobytes or time) how much additional data to add to the end of the file.  
 

 
 
“At a tachometer pulse every 10 mm,” indicates the rate at which the file is being written to as a function of the 
tach signal. When appending to an existing file, this relationship cannot be changed. In the above illustration, the 
tachometer is active every 10 mm. This means that 360 additional kilobytes of data will be appended to the original 
file in a distance of 0.9216 kilometers. Note that you can append to a file by specifying either a file size (in 
kilobytes) or a recording distance (in kilometers). When a value is entered in one of the text boxes, the other text 
box can be updated to display the other equivalent value by pressing the TAB key.  
 
With WINDAQ/Tach acquisition software, the File Size dialog box shows the current pack factor, which is the ratio 
of the original data file size to the data file size when different channels at different rates are employed. This pack 
factor is used to calculate data file size or recording time. 
 
Enter in the text box the desired file size in kilobytes or the desired distance in kilometers. When the desired value is 
entered, close the dialog box by: 
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 Clicking the OK command button. 

 Pressing the ENTER key. 
 
The Record function on the File menu is now enabled. To start acquiring data to disk, refer to the Recording Data to 
Disk heading below. 
 
 
Creating a New File 
Enter in the File Name box the name of the data file to which WINDAQ/Tach is to store data. When the desired file 
name is entered, close the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key. 
 
After a valid file name is entered, the following File Size dialog box is opened. This dialog box provides a way for 
you to specify the maximum file size (in kilobytes) or the maximum recording distance (in kilometers) of the target 
data acquisition file. 
 

 
 
“At a tachometer pulse every 10 mm,” indicates the relationship of tachometer signal to distance. In the above 
illustration, two bytes are written to the data file every 10 mm, assuming a single channel is enabled. This means 
that 360 kilobytes (default value) of data will be stored to disk in 0.9216 kilometers. Note that modifying the 
Tachometer function, which is found in the Edit pull-down menu, affects both the file size and recording distance. If 
the relationship of distance to the Tachometer is unsatisfactory, you can cancel out of this dialog box and adjust the 
relationship to your preference. Note that you can create a new file by specifying either a maximum file size (in 
kilobytes) or a maximum recording distance (in kilometers). When a value is entered in one of the text boxes, the 
other text box can be updated to display the other equivalent value by pressing the TAB key. 
 
Enter in the text box the desired file size in kilobytes or accept the default. When the desired file size is entered, 
close the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key. 
 
The Record function on the File menu is now enabled. To start acquiring data to disk, refer to the following 
procedure. 
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Recording Data to Disk 
To start acquiring data to disk: 

 Click the Start/Stop Recording button in the ToolBox. 

 Point to the File menu and drag down to Record. 

 Choose File Record (ALT, F, R). 
 
This places you in the active record-to-disk operating mode where enabled analog channel data is digitized, 
displayed and streamed to disk simultaneously. The status field in the bottom annotation line indicates RECORD. 
 
To stop acquisition to disk: 

 Click the Start/Stop Recording button in the ToolBox. 

 Point to the File menu and drag down to Stop. 

 Choose File Stop (ALT, F, T). 
 
This suspends data storage to disk, but the real time display remains active. The status field in the bottom annotation 
line indicates STBY when acquisition has been stopped. Note that the Stop function on the File menu only becomes 
enabled when in the record-to-disk operating mode. 
 
Data acquisition to disk may be started and stopped as many times as you desire. When the target data file has been 
filled, data acquisition to disk will cease, the “Storage:” field of the status bar will display “100% used”, and the 
“Status:” field of the status bar will display FILE FULL. 
 
 
SPECIAL CONSIDERATIONS 
If the sample rate is displayed in reverse video when you attempt to acquire data to disk, then you may not be able 
to reliably store data to disk. Refer to Appendix A; Different Ways of Allocating Memory for more details.  
 

Reverse video
 

 
The default file size is 360kB (368,640 bytes). The minimum file size that may be specified is 1,156 bytes, which is 
equivalent to the size of the WINDAQ/Tach file header (refer to the WINDAQ/Tach DATA STORAGE FORMAT 
chapter in the WINDAQ Waveform Browser manual for detailed information related to the WINDAQ/Tach file 
header). The maximum file size that may be specified is equivalent to the amount of space available on the target 
disk drive in bytes. 
 
Data acquisition to disk may also be enabled and disabled remotely through digital input port DI1. Refer to the 
REMOTE CONTROL function in this chapter for further information. 
 
As data is being recorded to disk, the amount of file space consumed is displayed in the “Storage:” field of the status 
bar as a percentage of total file space consumed. 
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Each time data recording to disk is activated, an event marker is automatically inserted in the waveform stream. This 
feature allows data acquisition break points to be reviewed through WINDAQ Waveform Browser playback 
software. Refer to the EVENT MARKER FUNCTION in this manual and the SEARCH-FOR-EVENT function in 
the WINDAQ Waveform Browser playback manual for further information related to event marker operation. 
 
AUTOMATIC RECORDING MODE 
It is possible to force WINDAQ/Tach to immediately start acquiring data to disk upon start up, thus bypassing the 
File Open procedure and file size specification. Windows™ allows you to consolidate these preliminary recording 
steps (i.e., choosing File Open, specifying a file name, specifying a file size, and choosing File Record) by creating 
a new shortcut. To do this, you must either modify the existing WINDAQ/Tach program item or create a new 
program item and name it WINDAQ FAST START, WINDAQ AUTO RECORD, or anything similarly appropriate. 
To implement the “auto-record” feature: 
 
1.  Click the right mouse button on the Start button in the taskbar. 
 
2. Click Open. This displays the Start Menu window. 
 
 For the next step, you must decide whether you will create a new shortcut or modify the existing program item. 
 
 If you wish to create a new shortcut, continue with step 3 below. If you wish to modify your current 

WINDAQ/Tach program item, skip to step 4 of this procedure. 
 
3. To create a new shortcut: 
 

a. In the Start Menu window, click on File, point to New, and click on Shortcut. The Create Shortcut dialog 
box appears. 

 
b. In the Command Line box, type: 
 

[d:path]di200tnt.exe [d:path]targetfilename [filesize] [-F[d:path]setupfile] -A.  
 
 Where: items in brackets [] are optional. 
 
  [d:path] is the drive and directory where file di200tnt.exe resides.  
 
  [d:path]targetfilename is the name of the data file (including optional drive, path, and 

extension specifiers) to which WINDAQ/Tach is to store data (the target file).  
 
  [filesize] is an optional number that specifies the maximum file size of the target data 

acquisition file. If not specified, the filesize defaults to 360 kb. The minimum size that may 
be specified is 1,156 bytes, which is equivalent to the size of the WINDAQ/Tach file header. 
The maximum size that may be specified is equivalent to the amount of space available on the 
target disk drive in bytes. 

  A file size using “K” nomenclature may be supplied. The “K” designator is interpreted as 
being equal to 1024. For example, if “100K” is specified, the file size created is 102400 (1024 
x 100) bytes. It is not necessary to use “K” nomenclature when specifying data file size. The 
actual size of the waveform data file ultimately created on disk following data acquisition 
depends on the following: If WINDAQ/Tach is terminated before the end of the data file is 
reached, the size of the resulting data acquisition file will be less than that specified by 
filesize. WINDAQ/Tach data only consumes enough of the target file to contain its acquired 
waveform information, releasing the excess. If WINDAQ/Tach is terminated without storing 
any data to disk, a file will exist that contains only the WINDAQ/Tach data file header. This 
file may be deleted or used as a set up file to provide default conditions for another data 
acquisition file. If WINDAQ/Tach is allowed to acquire data to disk until the target data 
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acquisition file is full, the file size of the target file may or may not be exactly equal to that 
specified in the command line. The precise size depends upon the number of channels 
enabled during acquisition and whether this number is an even multiple of the specified file 
size. When specifying a file size, remember that one sample stored to disk requires two bytes. 

 
  [-F[d:path]setupfile] is an optional previous data acquisition file (including optional drive, 

path, and extension specifiers) created by WINDAQ/Tach that when specified, forces 
WINDAQ/Tach into exactly the same configuration as “setupfile”. Virtually all data 
acquisition parameters are ported from the setup file to become the default conditions of the 
new data acquisition file specified by d:\path\filename.ext. Such parameters include but are 
not limited to: the number of channels and type enabled, scaling constants, engineering units, 
display format, compression, display mode, DAC offsets, and gain. The purpose of the setup 
file is to allow instantaneous setup for similar but separate data acquisition runs. 

 
  -A is the switch that forces WINDAQ/Tach to immediately start acquiring data to disk upon 

start up.  
 

 Examples of syntax:  
 a.) C:\WINDAQ\DI200TNT.EXE TEST1.DAT -A 
 b.) TRIAL1 -A 
 c.) C:\WINDAQ\DI200TNT.EXE TEST1.DAT 200K -Fdata.dat -A 

 
 
c. Click the Next> button. The Select a Title for the Program dialog box appears. 
 
d. In the text box, type a name for the new shortcut. Choose something that uniquely identifies it as an 

“immediate start” application. This name will become the label that appears under the shortcut icon in the 
Start Menu window. 

 
e. Choose the Finish button. The dialog box closes and the new shortcut icon appears in the Start Menu 

window. You can now immediately start recording with WINDAQ/Tach by clicking the Start button on the 
taskbar and then clicking the name you chose in step d (should be at the top of the Start Menu). 

 
4. To modify the existing WINDAQ/Tach program item: 
 

a. In the Start Menu window, double-click the Programs icon. The Programs dialog box appears. 
 
b. Double-click the WINDAQ item (or whatever you named the destination directory for WINDAQ files during 

the installation). 
 
c. In this dialog box, click the right mouse button on the WINDAQ/Tach icon, and click Properties. The 

WINDAQ/Tach Properties dialog box appears. 
 
d. Choose the Shortcut tab, if not already displayed. 
 
e. In the Target: text box, add to the end of the statement (at a minimum) the target file name and the -A 

switch in the following order; 
 

[d:path]di200tnt.exe [d:path]targetfilename [filesize] [-F[d:path]setupfile] -A.  
 
 Refer to step 3b above for an explanation of the arguments. 
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f. Click the OK button. The dialog box closes and the new shortcut icon appears in the Start Menu window. 
You can now immediately start recording with WINDAQ/Tach by clicking the Start button on the taskbar, 
pointing to Programs, pointing to WINDAQ, and then clicking the WINDAQ/Tach icon. 

 
SLAVE MODE 
It is possible to run WINDAQ/Tach in a slave mode, where some other application controls WINDAQ/Tach and at the 
same time prevents the user from doing so. It is also possible to send messages or otherwise communicate with 
WINDAQ/Tach (through Windows) without preventing user interaction. For complete slave mode details, contact 
technical support. 
 
 
EXAMPLE 
 
Accelerator key version 
 
KEYSTROKE COMMENT 
CTRL+O Assign a file name and size 
F4 Start acquiring data from the RECORD operating mode (Status: indicates RECORD) 
CTRL+F4 Stop acquiring data (Status: indicates STBY) 
F4 Start acquiring data from the RECORD operating mode (Status: indicates RECORD) 
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AMPLIFIER GAIN CONTROL FUNCTION  
(nonfunctional when used with serial port instrumentation) 
 
FUNCTION 
Allows the selection of channel-by-channel gain and measurement range. If you are using an EXP Series analog 
channel multiplexer, refer to Appendix B for gain control function details. 
 
ACTIVATING PROCEDURE 
Gain 
To select channel-by-channel gain, you must be in the SET-UP operating mode. Gain cannot be adjusted once the 
RECORD mode has been entered. Additionally, the desired channel must be enabled. An analog channel is enabled 
for gain adjustments by: 
 

 Clicking the left mouse button in the unselected channels annotation margin. 

 Typing the number or letter of the display window that contains the waveform to be adjusted. 
 
The focal point for enabling any waveform for any type of adjustment is the variable waveform assignment 
indicator of each channel. This is the two-element equality (X=Y) displayed for every enabled ADC channel. 
Element “X” is the waveform window number or letter and element “Y” is the ADC channel number assigned to 
that window (refer to the VARIABLE WAVEFORM ASSIGNMENTS section of this chapter). Element “X” (the 
waveform window) is always the element specified to enable the waveform contained in that window for 
adjustment. When a waveform window is selected, a highlighted box surrounds the X=Y annotation, indicating that 
the window is enabled for adjustment.  
 

 
 
When the waveform contained within a specified window is enabled, gain adjustments to that channel are now 
possible. To adjust the gain for the enabled channel: 
 

 Click the Channel Setup button in the ToolBox. 

 Point to the Edit menu and drag down to Channel Settings… 

 Choose Edit Channel Settings… (ALT, E, G). 
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This displays one of the following “Channel X Settings” dialog boxes (where X represents the enabled channel): 
 

 
 
The gain factors you see displayed at the top of this dialog box are hardware dependent. Gain factors will be 
different, depending on your instrument. Displayed next to each gain are the equivalent plus and minus full scale 
voltages that result from selecting that gain factor.  To specify a gain: 
 

 Click on the desired gain factor.  

 1. Press the “↑ ” or “↓ ” arrow key until the desired gain factor is highlighted. 
 2. Press ENTER. 
 
Unipolar/Bipolar Measurement Range Option 
Not applicable to WINDAQ/Tach software. 
 
Reset Cal. Command Button 
Whenever the gain or unipolar/bipolar setting is changed in this dialog box (confirmed by selecting the OK 
command button) any calibration to significant engineering units is preserved and adjusted to reflect the new gain or 
unipolar/bipolar setting. However, the screen scaling for the selected channel is restored to the default values shown 
next to the gain factor, so that the top and bottom screen limits show the extremes of the A/D converter input range. 
Selecting the Cancel command button cancels any proposed changes thus keeping previous limits intact. 
 
Selecting the Reset Cal command button allows you to reset the selected channel from a significant engineering 
units calibration back to the default voltage (or temperature, if using thermocouples) calibration. 
 
Acquisition Method 
The Acquisition Method buttons allow you to select the method used for displaying data on your monitor and 
storing it on your hard drive.  
 
All of our hardware products continuously sample data using a burst sampling technique. With the burst sampling 
technique, the board or hardware device samples data at one rate (referred to as the maximum sampling rate or burst 
rate) while your computer reports (i.e., displays and stores) this data at another rate (called the sample rate or 
throughput rate). Again, the burst rate determines how fast the board or hardware device samples your data and the 
sample rate determines how fast the sampled data is reported. Your board or hardware device can sample data much 



WAVEFORM RECORDING WITH W INDAQ/Tach 
 
 

35 

faster than it can report it. For example, let’s say we want to record one channel of data at 100 Hz and our burst rate 
is set at 50kHz. (burst rate is modifiable through the Maximum Sample Rate command on the Preferences submenu 
of the Edit menu and sample rate is modifiable from the Edit menu). In this example, we are sampling the data at 
50kHz and reporting it at 100Hz. This means that for every 500 data points sampled, only 1 will be reported. The 
dilemma becomes: which data point out of the 500 gets reported? Fortunately, you have a choice of methods for 
reporting this single data point: 
 
Average - This method averages all of the data points in the burst sample and reports this average as the single value 
for storage and display. This is the most universal method and should be left on in all cases unless you wish to 
report peak or valley values (in which case you would select the Maximum or Minimum button respectively).  
 
Last Point - This method simply reports the last input data point in the burst sample for storage and display. The rest 
of the data points in the burst sample are ignored. 
 
Maximum - This method reports the highest value data point in the burst sample for storage and display. The rest of 
the data points in the burst sample are ignored. 
 
Minimum - This method reports the lowest value data point in the burst sample for storage and display. The rest of 
the data points in the burst sample are ignored. 
 
 
Input Types: 
Linear - The default input type, available on all instruments. Should be used with all linear inputs. 
 
Nonlinear Input Types - Not applicable to WINDAQ/Tach software. 
 
Thermocouple Input Types – Not applicable to WINDAQ/Tach software. 
 
Next and Previous Command Buttons 
The Next and Previous command buttons allow you to step through the next or previous enabled channel (in order), 
setting up each channel for gain, unipolar/bipolar, sample rate, etc., without closing this dialog box. Note that when 
either the Next or Previous button is activated, the channel number in the title bar of the dialog box changes to 
indicate the channel you are currently setting up. 
 
SPECIAL CONSIDERATIONS   
 
As the gain factor for a channel is sequenced upward and downward through gain ranges, ±full scale annotation 
adjusts to reflect the application of the various gain factors.  
 
A channel's gain factor cannot be adjusted following the initiation of data storage to disk. Only the SET-UP 
operating mode allows gain factor adjustments. 
 
 
EXAMPLE 
Accelerator key version 
 
KEYSTROKE COMMENT 
2 Enable waveform window 2. 
F10 Displays the “Channel X Settings” dialog box. 
4 Selects a gain factor of four for the waveform contained in window 2. 
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BEEP ON FILE FULL FUNCTION 
 
 
FUNCTION 
When enabled, this option sounds an audible beep when the target data acquisition file is full.  
 
 
ACTIVATING PROCEDURE 
To enable the beep on file full function: 
 

 Point to the Options menu and drag down to Beep on File Full.  

 Choose Options Beep on File Full (ALT, O, B).  
 
 
SPECIAL CONSIDERATIONS  
Before a file can be opened, you must specify a file size (or accept the default) in the File Size dialog box. When 
enough data has been recorded to fill the allocated file space, an audible beep sounds (when this function is enabled) 
to warn you that acquisition has stopped and WINDAQ/Tach is in the STBY operating mode.  
 
EXAMPLE 
None. No accelerator keys for this function. 
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CLOSE FUNCTION 
 
FUNCTION 
Allows you to close the data file you are currently working with. Closing a data file removes the file from your 
screen, but does not quit WINDAQ/Tach.  
 
ACTIVATING PROCEDURE 
A new data file must first be opened and data must be recorded to it before the Close command becomes selectable 
(undimmed). However, the Close command is immediately selectable on an existing data file that you are appending 
to. Once Close becomes selectable, you can close a currently open data file as follows: 
 

 Point to the File menu and drag down to Close.  

 Choose File Close (ALT, F, C).  
 
SPECIAL CONSIDERATIONS  
None. 
 
EXAMPLE 
None. No accelerator keys for this function. 
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CONFIGURE ADC CHANNELS FUNCTION 
 
FUNCTION 
Used to specify the ADC channels to be acquired and whether these channels are configured for single-ended, 
differential, or digital operation.  
 
ACTIVATING PROCEDURE  
 
The following procedure is used to specify the analog channels to be acquired and whether these channels are 
configured for single ended, differential, or digital operation.  
 
To enable or configure channels for acquisition, you must be in the SET-UP operating mode. Channels cannot be 
added to, deleted from, or configured in the data acquisition file once the RECORD mode has been entered. To 
activate analog channel configuration:  
 

 Click the Enable Channels button in the ToolBox. 
 

 Point to the Edit menu and drag down to Channels… 
OR 

 Double-click on the Channels: field in the status bar. 
 

 Choose Edit Channels… (ALT, E, C). 
 
This displays the channel selection grid as follows. 
 

 
 
Each box in this grid represents an input channel. An input channel is enabled by clicking the desired box. Where in 
the grid you click, which mouse button you click with, and how many times you click the mouse button determines 
whether the input channel is enabled for differential operation, for operation defined by the 5B module (if used), or 
for differential operation between a pair of channels (automatically defined by the grid). Since there are so many 
variables, each instrument will be presented individually. 
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Enable single-ended Channels 

 Point to the box in the grid that represents the desired channel and click the left mouse button to enable the 
channel as a single-ended input or as an input defined by the 5B module (when used). A checkmark (✓ ) is 
displayed in the desired channel box, indicating that a single-ended input has been enabled. A second 
activation removes the checkmark and thus disables the channel. 

 
Enable differential Channels 

 Point to the box in the grid that represents the desired channel and double-click the left mouse button to 
enable a pair of differential channels for differential operation (this allows you to see the difference 
between 2 differential input channels). A plus sign (+) is displayed in the desired channel box, indicating 
one differential channel and a minus sign (—) is automatically displayed eight channels away (i.e., channels 
1 and 9, 2 and 10, 5 and 13, etc.), indicating the other differential channel. You can select the first or 
positive channel (from 1 through 8), but the second or negative channel is automatically selected by the 
software. Clicking the left mouse button on the plus sign removes both plus and minus signs and thus 
disables the channel pair.  

 
 This configuration is useful anytime you need to monitor the difference between two differential input 

channels. For example, say we are monitoring the temperature of a long, narrow widget. We want the 
widget to be of uniform temperature throughout its entire length. We could use two temperature sensors 
(one per channel, on each end of the widget) to monitor temperature. The temperature of one end of the 
widget would be measured by one thermocouple and the temperature of the other end of the widget would 
be measured by the other thermocouple. However, in the differential channel pair configuration as described 
above, only the difference between the two thermocouples would be reported by WINDAQ software. This 
difference in temperature could then be used to control a process (i.e., if one end is 5° hotter than the other, 
then turn on a heater to evenly distribute the widget temperature). 

 
SPECIAL CONSIDERATIONS 
Both single-ended and differential channels may coexist providing that any one or both of the channels needed to 
form the differential channel pair have not already been added to the list as single-ended channels. If such is the 
case, the single-ended channel already specified will be deleted from the list and the new differential channel added.  
Differential channel numbers greater than 8 are not recognized as valid entries. 
 
WINDAQ/Tach always sequentially samples from the lowest channel number specified to the highest. 
 
Checkmarks do not have to be placed sequentially.  You can sample only channels 3, 8 and 9, for instance, if those 
are the channel blocks that are enabled. 
 
The number or type of channels enabled for acquisition cannot be changed after the RECORD mode has been 
activated. 
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COPY FUNCTION 
 
FUNCTION 
Copies the graphics in the graphic selection rectangle to the clipboard. 
 
ACTIVATING PROCEDURE 
Graphics are copied to the clipboard using the mouse, the Copy command on the Edit menu, and the graphic 
selection rectangle. The Copy command on the Edit menu is dimmed until a graphic selection rectangle is drawn, 
thus enclosing the desired graphics. The graphics selection rectangle is drawn by positioning the mouse pointer 
anywhere in the waveform strip area and dragging with the right mouse button until the rectangle encloses the 
desired graphics. When the right mouse button is released, the rectangle remains fixed in size on the screen. With 
the graphics rectangle drawn, the Copy command on the File menu is enabled and the enclosed graphics can be 
copied to the clipboard as follows: 
 

 Point to the Edit menu and drag down to Copy. 

 Choose Edit Copy (ALT, E, C). 
 
SPECIAL CONSIDERATIONS 
The graphic is copied to the clipboard in bitmap and device-independent bitmap (DIB) formats. 
 
EXAMPLE 
(Assumes a graphic selection rectangle is drawn) 
 
KEYSTROKE COMMENT 
CTRL+C Copies current contents of graphic selection rectangle to the clipboard. 
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DEFAULT CONDITIONS FUNCTION 
 
FUNCTION 
Allows all current WINDAQ/Tach parameters to become the default condition, so all subsequent data recording 
sessions will have the current display format, sample rate, channels enabled, etc. 
 
This function sets default parameters for all future data files. The Open Reference File function is similar, but it 
only sets default parameters for the one new data file being created. 
 
ACTIVATING PROCEDURE 
When you have set up WINDAQ/Tach exactly the way you like, you can make this configuration the default, so 
every time you start WINDAQ/Tach, it always appears this way. To make the current screen design the default 
condition: 
 

 Point to the File menu and drag down to Save Default Setup. 

 Choose File Save Default Setup (ALT, F, D). 
 
SPECIAL CONSIDERATIONS 
Virtually every WINDAQ/Tach data acquisition parameter is saved to determine the default condition: Enabled 
display format, sample rate, compression, channels enabled, etc.  
 
EXAMPLE 
 
KEYSTROKE COMMENT 
ALT, F, D Save current screen design as default condition. 
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DIGITAL INPUT CHANNEL FEATURES 
 
FUNCTION 
Two separate functions on the Scaling menu allow you to manipulate and store digital input channel information 
along with all of the analog data. The Analog Plot function toggles the digital input channel display between a 
bipolar analog plot and a digital individual bit plot. The Digital Plot function displays the digital input channel as a 
digital subchannel featuring each individual bit. 
 
A digital input channel is going to display either a high signal or a low signal, nothing more or nothing less. These 
two functions offer two different ways of displaying the same high or low digital signal information. The Analog 
Plot function allows you to toggle the display of these high or low signals between an analog plot of a digital 
channel (with a display similar to the output of a D/A converter) and a digital plot that shows the state per bit. The 
Digital Plot function allows you to display the high or low state per bit (0 to 7), with a display option for normally 
open or normally closed conditions. Each feature is described as follows: 
 
ACTIVATING PROCEDURE 
Both of these functions are normally dimmed on the Scaling menu until a channel is specified as a digital input 
(refer to the Configure ADC Channels Function for details on how to make a channel a digital input). When the 
selected channel is a digital input, both of these functions are selectable.  
 
Analog Plot — This function has two purposes. It displays a bipolar analog plot of a digital input channel and it 
also serves as a toggle switch between an analog plot and a digital plot of the selected digital input channel. The 
analog plot displays the digital input channel in a way similar to the output of a D/A converter. 
 
When this function is enabled, the selected digital input channel information is displayed as an analog plot and a 
checkmark is displayed on the Scaling menu immediately preceding the Analog Plot command. When this function 
is disabled, the selected digital input channel information is displayed as a digital plot and the check mark is 
removed from the Scaling menu in front of the Analog Plot command. 
 
To enable an analog plot of a digital input channel: 
 

 Point to the Scaling menu and drag down to Analog Plot. 

 Choose Scaling Analog Plot (ALT, C, N). 
 
Digital Plot…  — This function displays the digital input channel as a digital subchannel featuring each individual 
bit. 
 
The default display shows a vertical line for each data point that contains at least one high signal. If the signal you 
wish to monitor is usually high, the vertical line can be inverted so it is displayed for each data point that contains at 
least one low signal. 
 
When this function is enabled, the selected digital input channel is displayed as a digital plot with each individual bit 
(digital inputs 0 through 7) displayed as a vertical line, and a check mark is displayed on the Scaling menu 
immediately preceding the Digital Plot… command. 
 
For example, display window 1 of the following illustration shows a digital plot of a digital input channel. The 
vertical line indicates a high condition on bits 2 and 6. The absence of the vertical line on bits 2 and 6 indicate a low 
condition. Display window 2 shows an analog plot of the same two input bits. 
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To enable a digital plot of a digital input channel: 
 

 1. Point to the Scaling menu and drag down to Digital Plot… 

 1. Choose Scaling Digital Plot… (ALT, C, T). 
 
This displays the “Channel X Digital Input Inversions” dialog box (where X represents the enabled channel, in this 
example it is channel 0): 
 

 
 
It is here that you can invert the digital input bit line display to accommodate your preference. The default 
configuration, shown by a check mark in the desired digital input box, is a dark line on a light background for a high 
signal condition and no line for a low signal condition. Clicking in the digital input box removes the X and inverts 
the line display (a light line on a dark background for a high signal condition and no line for a low signal condition). 
Multiple combinations are possible.  
 
 
SPECIAL CONSIDERATIONS 
None. 
 
EXAMPLE 
None. 
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DISPLAY FORMAT SELECTION 
 
FUNCTION 
Used to select a specific waveform display format. WINDAQ/Tach supports 11 different display formats. The 
particular display format you choose for any given application will be defined by a number of variables, but perhaps 
the most important of these is choosing a format that you feel most comfortable viewing. It is important to note that 
any display format may be enabled at any time during data acquisition without affecting the information stored to 
disk. Display format changes only affect the way you view waveforms on the computer’s monitor. 
 
The choice of a given display format revolves around the distance relationship of your input signals. Given two 
waveforms of interest, you may wish to choose an overlapping display format (e.g., format two) that will allow you 
to closely examine their relationship in both the distance and amplitude domains. On the other hand, a 
nonoverlapping format (such as format three or five) may be used to isolate each waveform’s transition within a 
defined area. 
 
The following chart and the accompanying illustrations provide a graphic example of each display format offered. 
 

Format Number Window Design Maximum Channels 
1 1 window 1 
2 2 windows, overlapped 2 
3 2 windows, non-overlapped 2 
4 4 windows, overlapped 4 
5 4 windows, non-overlapped 4 
6 8 windows, overlapped 8 
7 8 windows, non-overlapped 8 
8 16 windows, overlapped 16 
9 16 windows, non-overlapped 16 
10 32 windows, overlapped 32 
11 User-specified format 32 
 

As you review the following illustrations, keep these points in mind: 
 
1. A waveform channel is always assigned to a display window (as indicated by the X=Y annotation in the 

left/right annotation margin. X designates the display window and Y designates the waveform channel). 
However using the VARIABLE WAVEFORM ASSIGNMENT function, you can assign any waveform to any 
given window. What’s more, you can display any block of consecutive display windows on your monitor with 
the ASSIGN RANGE function. Keep in mind that nothing about the display format is fixed. The default is 
channel 0 assigned to window 1, channel 1 assigned to window 2, etc. 

 
2. The particular display format enabled at any given moment simply affects the way you view the waveforms 

being acquired. It in no way affects information being stored to disk during data acquisition. 
 
3. Each display format may be selected “on-the-fly” through simple keystrokes fully described in this manual. 
 
4. Any data acquisition channel number may be assigned to any waveform window, as an overlapping or non-

overlapping display, and as a function of the enabled display format. This waveform window/waveform 
channel assignment capability is available during the data acquisition process using simple keystrokes. 

 
5. The following illustrations all depict full screen displays (that is, WINDAQ/Tach is taking up the whole screen). 

It is entirely possible and most probable that you will have other application windows open simultaneously with 
WINDAQ/Tach. In order to do that, you must make the individual windows small enough for more than one to 
fit on your monitor. Therefore, the screens depicted here will not necessarily be what you see when you are 
running other applications concurrently. 
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Display Format 1

Waveform Window 1 
Number of displayed channels: 1 
Number of displayed windows: 1

Display Format 2

Waveform Windows 1 & 2 overlapped 
Number of displayed channels: 2 
Number of displayed windows: 2

Display Format 3

Waveform Windows 1 & 2  
Number of displayed channels: 2 
Number of displayed windows: 2

Display Format 4

Waveform Windows: 1 & 2 overlapped 
3 & 4 overlapped 

Number of displayed channels: 4 
Number of displayed windows: 4

Display Format 5

Waveform Windows 1, 2, 3, & 4  
Number of displayed channels: 4 
Number of displayed windows: 4

Display Format 6

Waveform Windows: 1 & 2 overlapped 
3 & 4 overlapped 
5 & 6 overlapped 
7 & 8 overlapped 

Number of displayed channels: 8 
Number of displayed windows: 8  
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Display Format 7

Waveform Windows 1, 2, 3, 4, 5, 6, 7, & 8  
Number of displayed channels: 8 
Number of displayed windows: 8

Display Format 8

Waveform Windows: 1 & 2 overlapped 3 
& 4 overlapped 

5 & 6 overlapped 
7 & 8 overlapped 
9 & A overlapped 
B & C overlapped 
D & E overlapped 
F & G overlapped 

Number of displayed channels: 16 
Number of displayed windows: 16

Display Format 9

Waveform Windows 1 through 16  
Number of displayed channels: 16 
Number of displayed windows: 16

Display Format 11 (User specified)

Any non-standard display

Display Format 10

Number of displayed channels: 32 
Number of displayed windows: 32
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ACTIVATING PROCEDURE 
To enable a particular display format and display it on your computer’s monitor:  
 

 1. Point to the View menu and drag down to Format Screen. 
 2. In the format box, click the desired display format. 

 1. Choose View Format Screen (ALT, V, F). 
 2. In the format box, select the desired display format (with ↑  or ↓  keystrokes). 
 3. Press ENTER. 
 
It is possible to display a format design other than the standard display formats listed. For example, suppose you 
wanted to monitor three waveforms on the screen. Your best choice among the standard display formats capable of 
displaying at least three waveforms is the four waveform format. However, the fourth displayed waveform would be 
blank. It would simply occupy screen space without conveying any useful information. The tool used to devote the 
entire window to the exact number of waveforms you wish to monitor is called the User-specified format option. To 
use the User-specified format option: 
 

 1. Point to the View menu and drag down to Format Screen. 
 2. In the format box, click User-specified format… 

 1. Choose View Format Screen (ALT, V, F). 
 2. In the format box, select User-specified format… (with ↑  or ↓  keystrokes). 
 3. Press ENTER. 
 
This displays the User-specified dialog box as follows: 
 

 
 
When the User-specified dialog box is first displayed, a blinking vertical line (called the insertion point) appears 
behind the number in the Number of Channels text box. This insertion point indicates the active area of the dialog 
box—the next action you perform will occur in this area. To specify a non-standard format: 
 

 1. Enter the desired number of channels to be displayed (up to 16 overlapped), and click OK. You also 
have the option of overlapping the specified number of waveforms. To overlap the waveforms, click 
the Overlapped check box. An X appears in the box indicating an overlapped format. A subsequent 
click removes the X, indicating a non-overlapped format. 

 1. Enter the desired number of channels to be displayed (up to 16 overlapped), and press ENTER. You 
also have the option of overlapping the specified number of waveforms. To overlap the waveforms, 
press the TAB key until a dotted box appears around Overlapped, then press the space bar. An X 
appears in the Overlapped check box indicating an overlapped format. A second press of the space bar 
removes the X, indicating a non-overlapped format. 
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SPECIAL CONSIDERATIONS 
The number of channels you will see displayed on your screen is a function of monitor resolution. A 640 x 480 
display may not be able to display all 32 channels (if selected), however a 1024 x 768 display will show all 32 
channels when enabled.  
 
The following describes each display format in terms of its window design, maximum number of displayed 
channels, and enabling keystrokes: 
 
FORMAT WINDOW  MAXIMUM  ENABLING 
NUMBER  DESIGN  CHANNELS KEYSTROKES 
One 1 full screen window. 1 ALT+1 
 
 
Two 2 full screen windows; 2 ALT+2 
 overlapping waveforms. 
 
Three 2 windows 2 ALT+3 
 
 
Four 4 windows; 4 ALT+4 
 overlapping waveforms. 
 
Five 4 windows 4 ALT+5 
 
 
Six 8 windows; 8 ALT+6 
 overlapping waveforms. 
 
Seven 8 windows 8 ALT+7 
 
 
Eight 16 windows; 16 ALT+8 
 overlapping waveforms. 
 
Nine 16 windows 16 ALT+9 
 
 
Ten 32 windows 32 ALT+0 
 
 
User Specified any non-standard 32 ALT+- 
 
 
See the VARIABLE WAVEFORM ASSIGNMENTS section of this chapter for information pertaining to the 
assignment of any waveform channel to any window. 
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DISPLAY MODE SELECTION 
 
FUNCTION 
Used to select the way information is displayed on your monitor, either in a continuous smooth scroll mode or in a 
triggered sweep oscilloscope mode.  
 
The display mode you choose for any given application is defined by many variables, but perhaps the most 
important of these is choosing a mode you feel most comfortable viewing. It is important to note that either display 
mode may be enabled at any time during data acquisition without affecting the information being stored to disk. 
Display mode changes only affect the way you view waveforms on your computer’s monitor. 
 
 
ACTIVATING PROCEDURE 
To select a display mode: 
 

 Click the Scroll Mode button in the ToolBox. 
OR 

 Click the Oscilloscope Mode button in the ToolBox. 
 

 Point to the Options menu and drag down to Scroll Mode or Oscilloscope Mode… 
OR 

 Double-click on the Mode: field in the status bar. 
 

 Choose Options Scroll Mode (ALT, O, S) or Options Oscilloscope Mode… (ALT, O, O). 
 
Note that in either display mode, the waveform display can be paused. This allows you to get a stationary look at 
some point on the waveform. While paused, the Mode: field in the status bar changes from the chosen display mode 
to Paused. To enable/disable the waveform display pause feature: 
 

 Point to the Options menu and drag down to Pause Graphics. 

 Choose Options Pause Graphics (ALT, O, P). 
 
 
When the pause feature is enabled, a subsequent pause attempt disables the pause feature. The display mode that 
was active before pausing is restored. 
 
When Oscilloscope Mode… is chosen, the Oscilloscope Triggering dialog box is displayed as follows: 
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This dialog box allows you to choose between a triggered sweep oscilloscope display or a free-running oscilloscope 
display. Checking the Free Run check box selects the free running oscilloscope display. Leaving the Free Run 
check box unchecked selects the triggered sweep oscilloscope display.  
 
If free running is selected, the waveform is displayed constantly on your monitor in a manner identical to an 
oscilloscope display and the rest of this dialog box can be ignored. 
 
If triggered sweep is selected, you can also set display trigger conditions (such as channel, level, and slope) that 
define the “trigger” or starting point for displaying the waveform on your monitor. In this mode, the waveform is 
not displayed until a trigger condition is detected. The waveform will be displayed for a single sweep on your 
monitor only when a trigger (i.e., that point on the waveform in the selected channel that corresponds to the level 
and slope specified) is detected. Although it looks similar to the Acquisition Triggering dialog box, this dialog box 
only sets triggering conditions for the waveform display (not for acquisition to disk). 
 
The triggered sweep display (best used with repetitive waveform signals) allows you to set a level and a slope 
defining the starting point or “trigger” for the waveform display. The waveform will be sweep-displayed on your 
screen only when a trigger (i.e., that point on the waveform that corresponds to the level and slope you selected) is 
detected. This produces a stable display, easily measured or compared with other waveforms since it starts at the 
same point on the screen with every sweep. This single sweep display will remain on your monitor until the next 
trigger is detected. 
 
The free-running display allows the waveform signal to “free run” without any triggering conditions. Without 
triggering conditions to define a starting point, the free-running display updates continuously. 
  
Slope option buttons - The slope option buttons allow you to select the slope (positive or negative) at which the 
waveform display will trigger. Selecting the + option button triggers the display to start at the trigger level, but on 
the waveform’s rising slope. Selecting the - option button triggers the display to start at the trigger level, but on the 
waveform’s falling slope.  
 
Select the trigger slope by: 
 

 Clicking the desired option button. When a slope is selected, a dotted box surrounds the slope name and a 
dark dot appears in the slope option button. 

 Pressing the TAB key until one of the two slope options becomes selected. When selected, a dotted box 
surrounds the slope name and a dark dot appears in the slope option button. At this point, the ↑  or ↓  cursor 
control keys can be used to select the desired slope. 

 
Channel text box - Allows you to specify or select a channel for the trigger source. 
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Level field - Indicates the current trigger level in volts. 
 
Free Run check box - Allows you to select between a triggered sweep oscilloscope display or a free-running 
oscilloscope display (see discussion above). Note that this box must be unchecked to set the trigger level. 
 
Erase Bar check box - Allows you to enable/disable the display of the vertical erase bar (cursor) on the waveform. 
Whether the erase bar is displayed or disabled, the waveform information screen is still “erased” and replaced with a 
fresh sweep of data. 
 
OK command button - Allows you to close the Oscilloscope Triggering dialog box and apply the just configured 
display trigger conditions. 
 
Set Level command button - Allows you to adjust or set the trigger level. Note that the Free Run check box must 
be unchecked to set a trigger level. When selected, the Oscilloscope Triggering dialog box closes and causes the 
cursor to point to a short horizontal line at the right side of the annotation margin. This short horizontal line is the 
trigger level indicator. 
 

 
 
At this point, the mouse is limited to dragging the line up or down to the desired trigger level. Note that when the 
mouse is moved, the data display in the left annotation margin changes to indicate trigger level (in volts). When set 
where desired, clicking the left mouse button sets a new trigger level while clicking the right mouse button retains 
the existing level. Note that if the trigger level is set somewhere above or below the current signal, the signal will 
disappear from the display. 
 
Cancel command button - Allows you to close the Oscilloscope Triggering dialog box and cancel any changes 
made to trigger conditions, provided that the changes were not saved with the OK command button.  
 
SPECIAL CONSIDERATIONS 
If the display is paused while in the Record operating mode, data acquisition to disk continues unimpeded.  
 
The trigger level is saved as a digital A/D converter value, so the associated level in engineering units will change if 
the channel gain is changed or the channel is recalibrated. 
 
Changing the trigger conditions with the Oscilloscope Mode dialog box also affects the Acquisition Triggering 
conditions and vice versa, even though the modes trigger on different channels. 
 
KEYSTROKE EXAMPLE 
KEYSTROKE COMMENT 
CTRL+F1 Select the scroll mode 
No accelerator keystrokes for the oscilloscope mode. 
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EVENT MARKER FUNCTION 
 
FUNCTION 
Allows you to insert event markers (either commented or uncommented) at any point in the data stream going to 
disk. Event markers (along with appropriate comments) can be used to mark an event, or flag an uncommon 
occurrence in the data stream going to disk, thus providing a complete record of what happened and why.  
 
After the data acquisition session, WWB/Tach playback software allows you to automatically search and move to 
the point in the data file where the event markers were placed during data acquisition (refer to the SEARCH-FOR-
EVENT function of the WINDAQ Waveform Browser playback software user’s manual for more details). 
 
ACTIVATING PROCEDURE 
A transition from the SET-UP or STBY operating mode to the RECORD operating mode automatically inserts a 
positive going time and date stamped event marker in the data stream going to disk, thus marking the start of 
acquisition. You must be in the RECORD mode to insert additional event markers into the data going to disk. 
 

 While in the RECORD operating mode, click the Commented Event Marker button in the ToolBox. 
 

 While in the RECORD operating mode, point to the Edit menu and drag down to Insert Mark for an 
uncommented event marker or Insert Commented Mark for a commented event marker. 

 

 While in the RECORD operating mode, choose Edit Insert Mark for an uncommented event marker or Edit 
Insert Commented Mark for a commented event marker. 

 
A commented event marker allows you to enter up to a 39-character comment that will be associated with the event 
marker. When Insert Commented Mark is chosen from the Edit menu (or when the Commented Event Marker 
button is clicked in the ToolBox), the Event Marker Comment dialog box is displayed as follows: 
 

 
 
Enter the desired comment (up to 39 characters) in the text box. The comment will be displayed with its associated 
event marker by the SEARCH FOR EVENT function of the WINDAQ Waveform Browser playback software 
package. A commented event marker is anchored at its position in the data file the instant the event marker function 
is enabled. Data acquisition to disk continues while you enter your comment.  
 
If the Cancel command button is chosen while recording, the event marker will not be deleted from the data or 
trailer file but the comment will be blank. If the Cancel command button is chosen while not recording, the 
comment will be applied to the “start acquisition” marker generated automatically when the next RECORD mode is 
activated. In this case, the comment may be changed or canceled at any time before activating RECORD. 
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When the desired comment is entered, close the dialog box by: 

 Clicking the OK command button. 

 Pressing the ENTER key. 
 
It is possible to “preprogram” a comment for the automatically generated “start acquisition” marker. While in the 
SET-UP or STBY operating modes, choosing Insert Commented Mark immediately causes the Event Marker 
Comment dialog box to appear, prompting you for an event marker comment. When entered, the comment will be 
automatically associated with the very next event marker stored to the data file upon transition to the RECORD 
operating mode.  
 
SPECIAL CONSIDERATIONS 
Event markers are saved to disk along with A-D data. Any event marker comments that were provided ride with the 
data acquisition file as a trailer (refer to the DATA STORAGE FORMAT chapter of the WINDAQ Waveform 
Browser manual for further information). 
 
Event markers may be enabled either locally (manually) by pressing the appropriate accelerator key (as in the 
example below), or remotely through a switch closure or TTL signal. Refer to the REMOTE CONTROL function of 
this chapter for details related to remote triggering of event markers. 
 
An event marker is automatically inserted in the data stream each time the RECORD operating mode is activated. 
An event marker created in this manner is always tagged with a time and date stamp that allows any point in a 
recorded waveform file to be correlated with a precise date and time of occurrence (to the nearest second) . Refer to 
the SEARCH-FOR-EVENT function of the WINDAQ Waveform Browser user’s manual for further information 
related to viewing and using time and date stamp information. 
 
WINDAQ/Tach allocates 4 bytes of Global DOS memory per entry for event marker, time and date stamp, and 
comment information as follows:  
 
1. Event marker without time and date stamp or comment: 1 entry 
2. Event marker with time and date stamp only: 2 entries 
3. Event marker with comment only: 2 entries 
4. Event marker with time and date stamp and comment: 3 entries 
5. Each character of a comment occupies 1 byte of extended memory. The total number of bytes required for one 

comment is equal to the total number of characters in the comment (39 maximum) plus one character. 
 
The total number of entries per manual start for items 1 through 4 above is configurable by Edit Preferences Event 
Mark Capacity… 
 
These numbers may be used as follows to calculate the total number of event markers of any type that may be used 
per manual start: Divide the capacity less 2 by the number of entries required for each event marker operation. For 
example with the maximum configuration of 16,384 entries, if all event markers enabled by you during data 
acquisition are without comments, then a total of 16,382 may be activated between an uncommented manual start 
and the subsequent stop. A total of 8,191 may be activated with comments only or with remote start time and date 
stamps only. The actual comments you enter are contained in separate memory and therefore consume only one 
entry apiece, and each manual start produces at least one event marker with a time and date stamp activated 
automatically by WINDAQ/Tach upon the initiation of waveform recording to disk.  
 
EXAMPLE 
 
KEYSTROKE COMMENT 
F4 Begin recording. 
CTRL + Space bar Enable uncommented event marker. 
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SHIFT + Space bar Enable commented event marker. 
Enter comment “Control period 1” (event marker comment) 
CTRL + F4 Suspend recording. 
SHIFT + Space bar Specify annotation for next automatically inserted event marker. 
Enter comment “Control period 2” (comment for next automatically-generated event marker) 
F4 Resume recording (event marker is automatically enabled and associated with 
 comment “Control period 2” 
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FAST SCROLL FUNCTION 
 
FUNCTION 
When enabled, this option causes the display to scroll only in multiples of 16 pixels. Useful when scrolling speed is 
limited by display hardware. 
 
Scrolling by 16 pixels is the result of manipulating the display software in whole word chunks rather than individual 
bits. This is the optimum condition for display scrolling. The advantage of these whole word manipulations is they 
take less processor time, which results in faster screen updates. However if the scrolling speed is slow, scrolling by 
16 pixels detracts from the smoothness of the scroll and delays the presentation of new data by 16 samples per 
channel. 
 
ACTIVATING PROCEDURE 

 Point to the Options menu and drag down to Fast Scroll. 

 Choose Options Fast Scroll (ALT, O, F). 
 
When the fast scroll option is enabled, a checkmark (√) will be displayed on the Options menu immediately 
preceding the Fast Scroll command. 
 
SPECIAL CONSIDERATIONS 
None. 
 
EXAMPLE 
Accelerator key version 
No accelerator keys available for this function. 
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HELP 
 
FUNCTION 
HELP is a complete online reference tool that you can use at any time to display a brief summary of the contents of 
this chapter. When you finish reading the HELP information, acquisition returns you to the WINDAQ/Tach 
waveform display screen with everything exactly as you left it.  
 
HELP information is displayed in its own window—you can move and size the HELP window just as you would 
any other window. 
 
ACTIVATING PROCEDURE 
How to navigate within Help is thoroughly documented onscreen, therefore only cursory information will be 
covered here. WINDAQ/Tach Help provides: 
 
 • Information on WINDAQ/Tach commands, concepts, basic tasks, and parts of the screen. 
 • Help on a highlighted command. 
 • The ability to “jump” to a related topic or definition of a term. 
 
You use the various parts of Help by choosing buttons in the Help window and commands from the Help menu.  
 
When you are working in acquisition, you can get help any time you want it. You can request Help in a couple of 
different ways:  
 • From the Help menu, choose a Help category by: 

  Pointing to the Help menu and dragging down to the desired menu item. 

  Choosing ALT, H, and then the desired underlined character. 
 

 • Use the cursor control keys to highlight or select an item on a menu, and then press F1 to get context-
sensitive help on the item. 

 
While in Help, you can move to other topics to find exactly the information you want, including help on Help (how 
to use Help). If you are new to Help, it is strongly recommended that you view Help Basics from the How to Use 
Help category. 
 
When you finish using Help, you can leave the Help window open but out of your way, or you can close the Help 
window. Because Help is an application that appears in its own window, you can display the Help information next 
to the window in which you’re working. As you work, you can switch to the Help window and find the Help 
information you need for a particular task.  
 
To exit Help, choose File Exit from the Help window. If you want to return to your work without closing Help, you 
can shrink Help to an icon by clicking the Minimize button or by choosing Control Minimize.  
 
 
SPECIAL CONSIDERATIONS 
None. 
 
EXAMPLE 
Accelerator key Version 
KEYSTROKE COMMENT 
ALT, H, H Display the Help window and activate the How to Use Help category. 
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INVERT FUNCTION 
 
FUNCTION 
Allows you to flip the selected waveform upside down, exchanging the top and bottom limits. 
 
ACTIVATING PROCEDURE 

 Point to the Scaling menu and drag down to Invert. 

 Choose Scaling Invert (ALT, C, I). 
 
SPECIAL CONSIDERATIONS  
None. 
 
ACCELERATOR KEY EXAMPLE 
 
KEYSTROKE COMMENTS 
CTRL+I Flips selected waveform upside down. 
 
CTRL+I Flips selected waveform back to its original orientation. 
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LOCATION 
 
FUNCTION 
Allows you to change the location and specify whether it should increment or decrement on forward pulses from the 
tachometer.    
 
ACTIVATING PROCEDURE 

 Point to the Edit menu and drag down to Location. 

 Choose Edit Location (ALT, E, L). 
 
If you desire to have a starting point other than 0 kilometers, the desired starting point can be entered in the location 
dialog box and subsequent tachometer pulses will increment or decrement starting at this offset.  In the following 
dialog box, an offset of 12.11839 kilometers has been defined. 
 

 
SPECIAL CONSIDERATIONS  
This command may not be used while storing to disk, but may be changed after File-Stop returns the status to 
STBY. 
 
ACCELERATOR KEY EXAMPLE 
 
KEYSTROKE COMMENTS 
Alt + Shift + O  Edit current location
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OPEN REFERENCE FILE FUNCTION 
 
FUNCTION 
Allows you to specify an existing data acquisition file as a “set up” for a new data acquisition file. All data 
acquisition parameters (such as number of channels, channel type, scaling constants, engineering units, display 
format, compression, display mode, gain, etc.) are ported over from the existing file to become the default 
conditions of the new data file. This function allows instantaneous setup, thus making it easy to run similar but 
separate data acquisition sessions. 
 
This function sets parameters only for the new data file being created. The Default Conditions function is similar, 
but it sets default parameters for all future data files. 
 
 
ACTIVATING PROCEDURE 

 Click the Open Reference File button in the ToolBox 

 Point to the File menu and drag down to Open Reference File… 

 Choose File Open Reference File (ALT, F, F). 
 
 
SPECIAL CONSIDERATIONS  
The file specified as the reference file must be one created by WINDAQ/Tach and must already exist.  
 
This function is enabled only when in the SET-UP operating mode (Status: field in bottom annotation line indicates 
SET-UP). 
 
 
EXAMPLE 
None. No accelerator key version available for this function. 
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PALETTE SELECTION 
 
FUNCTION 
Allows the selection of one of 16 pre-defined display palettes. Additionally, a user-palette option allows you to 
redefine the color scheme of the displays by selecting different background, gridline, user annotation, and waveform 
colors from among 16 choices. 
 
ACTIVATING PROCEDURE 
A different palette can be displayed by selecting either the Next Palette or the Previous Palette command from the 
View menu. These commands allow you to pan through and display all 16 palette selections in either a forward or 
backward direction. 
 

 Display the Next Palette (Forward Direction) 
 1. Point to the View menu and drag down to Next Palette. This displays the next pre-defined display 

palette. Consecutive activation of this command displays all 16 palette selections, updating the display 
each time the command is selected. 

 
 Display the Previous Palette (Backward Direction) 
 1. Point to the View menu and drag down to Previous Palette. This displays the previous pre-defined 

display palette. Consecutive activation of this command displays all 16 palette selections, updating the 
display each time the command is selected. 

 

 Display the Next Palette (Forward Direction) 
 1. Choose View Next Palette (ALT, V, N). This displays the next pre-defined display palette. 

Consecutive activation of this command displays all 16 palette selections, updating the display each 
time the command is selected.  

 
 Display the Previous Palette (Backward Direction) 
 1. Choose View Previous Palette (ALT, V, P). This displays the previous pre-defined display palette. 

Consecutive activation of this command displays all 16 palette selections, updating the display each 
time the command is selected.  

 
 
SPECIAL CONSIDERATIONS 
Note that you are not limited to the color combinations presented on the 16 pre-defined display palettes. It is 
possible to tailor one, several, or all palettes to suit your color preference, taste, or requirements. The tool used to 
accomplish this is the User Palette… command. The User Palette… command allows you to redefine the palettes 
color scheme by selecting different background, gridlines and user annotation, or waveform colors from among 16 
color choices.  
 
When a palette is changed, you have the option of making the new color scheme permanent or canceling all color 
changes. If the changes are canceled, the palette reverts back to the original color scheme you started with. If the 
changes are made permanent, the new color scheme is saved as one of the 16 display choices and the original color 
combinations are overwritten. 
 
To change a palettes color scheme, proceed as follows:  
 

 1. Using the techniques described above, display the palette you want to change. 
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 2. Point to the View menu and drag down to User Palette…, or click the Change Palette button in the 

ToolBox . This displays the Palette dialog box. 
 
 3. In the Palette dialog box, click the Background, Grid Lines and User Annotation, 1st Waveform, or 

2nd Waveform colors you want. A dotted box appears around the selected color sample. 
 
 4. Click Apply to apply the colors you have selected to the display. The display palette changes to reflect 

your new color choices. 
 
 5. If you are satisfied with the color scheme you have selected, click OK. This saves the newly defined 

color scheme as one of the 16 display palettes, overwriting the existing palette. If you are not satisfied 
with the color scheme, you can repeat steps 3 and 4 above to get the desired colors, or you can click 
Cancel to get back to the original palette you started with. 

 

 1. Using the techniques described above, display the palette you want to change. 
 

 2. Choose View User Palette… (ALT, V, U), or click the User Palette button in the ToolBox. This 
displays the User Palette dialog box. 

 
 3. Use the TAB key to move the cursor into the Background, Grid Lines and User Annotation, 1st 

Waveform, or 2nd Waveform color selection bars. Use the ← or → cursor control keys to select the 
colors you want. A dotted box appears around the color sample to indicate selection. 

 
 4. Use the TAB key to highlight the Apply command button. A bold box appears around Apply when 

highlighted. 
 
 5. To apply the colors you have selected, press ENTER. The display palette changes to reflect your new 

color choices. 
 
 6. If you are satisfied with the color scheme you have selected, press the ← cursor control key to 

highlight the OK command button and press ENTER. This saves the newly defined color scheme as 
one of the 16 display palettes, overwriting the existing palette. If you are not satisfied with the color 
scheme, you can repeat steps 3 through 5 to get the desired colors, or you can highlight the Cancel 
command button and press ENTER to get back to the original palette you started with. 

 
User Palette Dialog Box 
The user palette dialog box gives you the ability to manipulate the display palette color schemes. The following 
information can be referred to when using the User Palette…: 
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Palette # = _ - Serves as a label or identifier for the selected color scheme. Range is from 0 to 15. 
 
Increment command button - Allows you to display the color scheme that defines the next palette. Activating this 
button increments the Palette # and updates the background, waveform, and grid lines and user annotation color 
selection bars. The colors surrounded by dotted boxes on the selection bars indicate what the palette will look like 
when the Apply command button is activated. Consecutive activation of this button displays all 16 palette 
selections, updating the color selection bars and palette # with each activation. 
 
Decrement command button - Allows you to display the color scheme that defines the previous palette. Activating 
this button decrements the Palette # and updates the background, waveform, and grid lines and user annotation color 
selection bars. The colors surrounded by dotted boxes on the selection bars indicate what the palette will look like 
when the Apply command button is activated. Consecutive activation of this button displays all 16 palette 
selections, updating the color selection bars and palette # with each activation. 
 
OK command button - Allows you to save a new color combination as one of the 16 display choices. When saved, 
the original color combination is overwritten. 
 
Apply command button - Allows you to apply or “try out” new color combinations without having to save them. 
Also used in conjunction with the Increment/Decrement buttons to view the 16 defined palettes. For example, to see 
what each palette currently looks like, activate the Apply button then the Increment button. Repeat this procedure 16 
times to see each defined palette. 
 
Cancel command button - Allows you to cancel any color changes made to a palette, provided that the changes 
have not been saved with the OK button. When canceled, the color scheme will revert back to the original palette 
you started with. 
 
Monochrome Displays 
If you are using WINDAQ/Tach with a monochrome monitor, select the Monochrome color scheme from the 
Windows  Control Panel. Selecting a color scheme other than monochrome may cause display conflicts. For 
example, with other color schemes, the cursor may seem to disappear when positioned coincident with a dark 
vertical gridline. The same result can happen with a waveform that rides the window baseline (the signal seems to 
disappear, but it is merely the same shade as the baseline). Selecting the monochrome color scheme ensures that 
your monitor will show every shade it is capable of showing without any conflicts. 
 
Color Selection Conflicts 
When selecting color combinations, it is important to note that the cursor color (not modifiable) will always be the 
inverse of the color chosen for the background. For example, if the background color is black the cursor color will 
be white, or if the background color is red the cursor color will be dark cyan. For this reason, do not pick the inverse 
color of the background for grid lines and user annotation. If you do, the cursor will seem to disappear when 
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coincident with a vertical grid line. As a general rule, do not assign the inverse color of the background to any other 
parameter (grid lines and user annotation, 1st waveform, or 2nd waveform) and do not make both waveforms the 
same color. 
 
EXAMPLE  
Accelerator key version 
(assumes an initial palette state of 0) 
 
KEYSTROKE COMMENTS 
ALT+P Move to palette number 1 
 
ALT+P Move to palette number 2 
 
ALT+SHIFT+P Move back to palette number 1 
 
ALT+SHIFT+P Move back to palette number 0 
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PREFERENCES 
 
FUNCTION 
Selecting this command displays a submenu of rarely-changed configuration items. When selected, these items 
allow you to adjust WINDAQ/Tach configuration parameters such as update interval, scroll limit, skip factor, buffer 
size, beep on gap, frame rate, maximum sample rate, event mark capacity, open new file on full, record next file on 
full, and thermocouple type to better suit your computer hardware or otherwise influence operation. Each preference 
item is described as follows: 
 
ACTIVATING PROCEDURE 
Update Interval - Allows you to specify the minimum time (in milliseconds) between screen updates. By setting a 
minimum time interval between screen updates, you prevent WINDAQ/Tach from using too much CPU time at the 
expense of other tasks. 
 
It should be noted that this preference item is simply a “graphics adjuster” that only affects how the display looks on 
your screen. Data acquired to disk is independent of this function. 
 
Valid update interval entries range from 0 to 32,767. The default interval is 0. At an interval of 0 (no time between 
screen updates) the display is optimized, it will update as fast as your display controller hardware will allow. 
However at this setting, WINDAQ/Tach burdens the CPU with constant screen update requests. The CPU spends 
most of its time providing this optimized display, thus leaving little time to process other tasks. At an interval of 
32,767 (approximately 33 seconds between screen updates) the display is at the opposite end of the performance 
spectrum, updating very slowly. Because of these infrequent screen update requests, the CPU has a lot of free time 
to handle other tasks, but the real time display suffers.  
 
With this preference item, you can trade display performance for system time availability (experimentation is 
encouraged). Decide which is more important; visually pleasing display performance or multitasking capability, and 
adjust the update interval accordingly. To specify a minimum screen update time: 
 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Update Interval… 
 

 Choose Edit Preferences Update Interval… (ALT, E, P, I).  
 
This displays the Minimum Milliseconds Between Updates dialog box:  
 

 
 
Enter in the text box the desired interval in milliseconds. When the desired interval is entered, close the dialog box 
by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key.  
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Scroll Limit  - Allows you to specify the maximum width (in pixels) of discontinuity from the right edge of the 
screen. If you do not see any discontinuity in the display, the scroll limit is adjusted properly for your computer and 
your typical operating conditions. If you do see some display discontinuity, you can adjust the scroll limit to 
compensate for the discontinuity and improve the appearance of your display.  
 
It should be noted that this preference item is simply a “graphics adjuster” that only affects how the display looks on 
your screen. Data acquired to disk is independent of this function. 
 
Valid scroll limit entries range from 0 to 32,767. The default limit is 0. In most cases, the scroll limit should be set 
to zero and left there. At a scroll limit of 0, no discontinuity will exist. In other cases where special hardware has 
been installed in your computer to accelerate display performance, the scroll limit should be maximized to take 
advantage of your display adapters enhanced capability. In the rest of the cases, the scroll limit can be experimented 
with to provide the best looking display.  
 
If you have a computer with a slower processor and a standard VGA display adapter (or less), the scroll limit should 
be set to 0. On this type of personal computer, there is nothing to gain by increasing the scroll limit. If you wish to 
enhance the appearance or performance of your display, try other methods such as increasing compression, 
decreasing the window size, decreasing the sample rate, or selecting the Fast Scroll option from the Options menu.  
 
If you have a computer equipped with a co-processor based display adapter that is capable of scrolling (such as the 
IBM 8514 PS2, any XGA controller, or any Windows™ graphics accelerator), the scroll limit should be set to 
32,767. On this type of personal computer, the display discontinuity can be eliminated or minimized and the display 
performance can be optimized by maximizing the scroll limit.  
 
If neither of the above applies, or if you really want to tweak your real time display, you can experiment with the 
scroll limit to find the most visually pleasing display. Start with a scroll limit of 2 and keep doubling it (up to the 
horizontal resolution of your monitor) until the display appears and performs satisfactorily. While it causes no harm, 
there is nothing to gain by setting the scroll limit higher than the horizontal resolution of your monitor.  
 
To specify a scroll limit: 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Scroll Limit… 
 

 Choose Edit Preferences Scroll Limit… (ALT, E, P, L).  
 
This displays the Max Points to Scroll Instead of Repaint dialog box:  
 

 
 
Enter in the text box the desired scroll limit in pixels. When the desired scroll limit is entered, close the dialog box 
by: 
 

 Clicking the OK command button. 
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 Pressing the ENTER key.  
 
 
Skip Factor (nonfunctional when used with serial port instrumentation) - Allows you to specify the ratio of the 
total number of data points to the number used for screen display at the maximum sample rate. For example, 
specifying a skip factor of 20 means that for every 20 acquired data points, only 1 will be used for screen display 
purposes (ratio of 20:1). Similarly, a skip factor of 1 means every data point acquired will be used for screen display 
purposes (a 1:1 relationship).  
 
It should be noted that this preference item is simply a “graphics adjuster” that only affects how the display looks 
and performs on your screen. Data acquired to disk is independent of this function. 
 
Real time display performance degrades when attempting to plot too many data points in a given period of time. 
Specifying a skip factor improves real time display performance by lessening the plotting workload. With a skip 
factor, you improve display performance by instructing WINDAQ/Tach to plot every nth data point and ignore the 
rest of the incoming data. However since the rest of the data is ignored, the result is a potentially inaccurate screen 
representation of the acquired data. Therefore, the skip factor should be considered a last resort for improving 
display performance if screen accuracy of the waveform data is desired. 
 
Valid entries range from 1 to 100. At a factor of 1 (no sample skipping) the screen display is the most accurate, 
detailed representation of the acquired data. However at this setting, the CPU is burdened with constant plotting 
operations. At a factor of 100 (plot every 100th data point on the screen and ignore the rest), CPU operations for the 
real time display are minimal (the “workload” is lightened) but the displayed waveform is at best only a 
compromised representation of the acquired data. 
 
To specify a skip factor: 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Skip Factor… 
 

 Choose Edit Preferences Skip Factor… (ALT, E, P, S).  
 
This displays the skip factor dialog box:  
 

 
 
Enter in the text box the desired skip factor. When the desired skip factor is entered, close the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key.  
 
 
Buffer Size (nonfunctional when used with serial port instrumentation) - Allows you to specify the size of input 
buffer needed for gap-free data recording at the maximum sample rate. By setting buffer size, you can specify the 
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correct amount of memory for acquiring data gap-free at your computer’s maximum sample rate while 
simultaneously running your usual applications. 
 
The input buffer is where the acquired data is temporarily stored. If the ratio of sample rate to buffer size is too 
small, the sample rate in the status bar is shown in reverse video. This is a warning that you may not be able to 
reliably store data to disk. To find the correct input buffer size, refer to the Streaming Data to Disk flow chart in 
Appendix A.  
 
The current size of the buffer can be seen in the Edit Sample Rate dialog box.  
 
The amount of buffer space allocated is automatic, proportional to the sample rate, and generally not in need of 
manual adjustment. Manual allocation of buffer size is generally only needed when the sample rate is displayed in 
reverse video (refer to Appendix A), when multitasking with many applications, or when you wish to allocate a 
large input buffer at a low sample rate (to accommodate slow computers). 
 
To specify a buffer size: 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Buffer Size… 
 

 Choose Edit Preferences Buffer Size… (ALT, E, P, B).  
 
This displays the buffer size dialog box:  
 

 
 
Enter in the text box the desired buffer size. When the desired buffer size is entered, close the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key.  
 
 
Beep on Gap - Allows you to enable/disable a short audible beep that sounds when the system is too busy to store 
gap-free data. To enable the audible beep (if disabled) or disable it (if enabled): 
 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Beep on Gap. 
 

 Choose Edit Preferences Beep on Gap (ALT, E, P, G).  
 
When the beep on gap option is enabled, a check mark (√) is displayed on the Edit Preferences submenu 
immediately preceding the Beep on Gap command. 
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Frame Rate - Allows you to enable/disable the display of screen updates (in frames/sec). When enabled, the 
number of screen updates per second (how many times per second the display is redrawn or updated) is displayed in 
the right end of the status bar. To enable the frame rate (if disabled) or disable it (if enabled): 
 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Frame Rate. 
 

 Choose Edit Preferences Frame Rate (ALT, E, P, F).  
 
When the frame rate option is enabled, a checkmark (√) is displayed on the Edit Preferences submenu immediately 
preceding the Frame Rate command. 
 
 
Maximum Sample Rate (nonfunctional when used with serial port instrumentation) - Allows you to set the 
maximum burst rate, which ultimately determines the sample rate. On some computers, a burst rate near 80KHz can 
result in channel swapping (i.e., the data from one channel is displayed on a different channel) on the screen and in 
the data file when DOS programs are run simultaneously with WINDAQ/Tach, or can even halt the system with a 
memory parity error.  
 
To specify maximum sample rate: 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Maximum Sample Rate… 
 

 Choose Edit Preferences Maximum Sample Rate… (ALT, E, P, M).  
 
This displays the maximum sample rate dialog box:  
 

 
 
Enter in the text box the desired maximum sample rate. When the desired maximum sample rate is entered, close the 
dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key.  
 
 
Event Mark Capacity - Allows you to set the maximum number of event mark entries available for a given data 
acquisition session (from when recording is selected to when stop is selected). If a large number of event mark 
entries are made, setting the capacity higher will make more memory available to WINDAQ/Tach for the next start 
up. 
 
Valid entries range from 1024 to 16,384. The default value of 1024 is generally sufficient for most users. Each event 
marker and each comment require one entry apiece, while two entries are required each time acquisition is started 
(either manually or remotely).  
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To specify the maximum number of event marks: 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Event Mark Capacity… 
 

 Choose Edit Preferences Event Mark Capacity… (ALT, E, P, E). 
 
This displays the following dialog box:  
 

 
 
Enter in the text box the desired maximum number of event mark entries. When the desired number is entered, close 
the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key.  
 
Open New File on Full - Enables/disables the ability to close a full file and display the dialog box required to open 
another new file. For example, say you are acquiring data and the file becomes full much sooner than you 
anticipated, yet you still need more data. If this preference is disabled, you would have to close this full file and then 
select the Open command from the File menu to name and open a new file, thus continuing the acquisition session. 
If this preference is enabled, you bypass the need to close the full file and select File Open. The File Open dialog 
box is automatically displayed for you, conveniently allowing you to enter a new file name.  
 
If this preference is enabled and if the old or full filename (excluding file extension) consists of just alpha characters 
(e.g., WEASEL.WDQ), the File Name text box of the Open dialog box is highlighted, enabling you to immediately 
enter a new file name. 
 
If the old filename (excluding extension) ended in numeric digits (e.g., WEASEL1.WDQ), the numeric portion is 
automatically incremented (e.g., WEASEL2.WDQ) and highlighted in the File Name text box of the Open dialog 
box suggesting the default new name. This feature allows you to acquire data to a series of sequentially-named files. 
If the numeric suffix of the old name is all nines (e.g., WEAS9999.WDQ), no specific next name is suggested. 
 
To enable this preference (if disabled) or disable it (if enabled): 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Open New File on Full. 
 

 Choose Edit Preferences Open New File on Full (ALT, E, P, O). 
 
When enabled, a check mark (√) is displayed on the Edit Preferences submenu immediately preceding the Open 
New File on Full command. 
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Next File on Full - Enables/disables the ability to automatically close a full file, enter a new file name, and start 
recording another new file. For example, say you are acquiring data and the file becomes full much sooner than you 
anticipated, yet you still need more data. If this preference is disabled, you would have to close this full file and then 
select the Open command from the File menu to name and open a new file, thus continuing the acquisition session 
but losing data while doing all of the file manipulating. If this preference is enabled, the last character of the old 
filename is automatically incremented when full and recording is started automatically to this new filename. If this 
new file is allowed to become full, the last character of this new filename is decremented (effectively getting you 
back to the file you started with) and recording automatically continues (thus overwriting the old data file). 
Recording continues alternately between this pair of files until it is stopped by the user. 
 
For example suppose this preference is enabled, you are acquiring data to a file called RAT.WDQ, and it is 
approaching full size. When full, recording will automatically continue but to a different file called RAU.WDQ. 
Similarly, recording will automatically continue but to file RAT.WDQ when RAU.WDQ reaches full size. 
 
The last character of the filename (excluding the file extension, if any) is the character that is 
incremented/decremented.  
 

RAT.WDQ (full or old filename) 
RAU.WDQ (new filename)

Last character of filename 
(excluding extension) gets 
incremented

 
 
If a file with the new name already exists, the file is automatically deleted before the new one is opened. 
 
There is a discontinuity between the data at the end of one file and the start of the next, but it is short if your 
computer system is not busy with other tasks such as reading disk drives or printing. 
 
If the Open New File on Full preference is also selected and the old filename (excluding extension) ended in 
numeric digits (e.g., WEASEL1.WDQ), the numeric portion is automatically incremented (e.g., WEASEL2.WDQ). 
If the numeric suffix of the old name is all nines (e.g., WEAS9999.WDQ), the new name will wrap back to all 
zeroes without incrementing the preceding character (e.g., WEAS0000.WDQ). 
 
To enable this preference (if disabled) or disable it (if enabled): 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Record Next File on Full. 
 

 Choose Edit Preferences Record Next File on Full (ALT, E, P, R). 
 
When enabled, a checkmark (√) is displayed on the Edit Preferences submenu immediately preceding the Record 
Next File on Full command. 
 
Thermocouple: Not applicable to WINDAQ/Tach software. 
 
SPECIAL CONSIDERATIONS 
None. 
 
EXAMPLE  
Accelerator key version 
No accelerator keystrokes for Preferences items. 
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QUIT 
 
FUNCTION 
When issued, the Exit command quits WINDAQ/Tach. 
 
ACTIVATING PROCEDURE 

 Point to the File menu and drag down to Exit.  
 

 Choose File Exit (ALT, F, X).   
 
When in the SET-UP operating mode and the Exit command is chosen, the following dialog box is displayed. You 
are required to select one of the options prior to exiting. 
 

 
 
OK Command Button - Activating the OK button forces the acquisition program to exit to the Program Manager 
window without saving anything (i.e., calibration or set-up parameters). If calibration or set-up parameters were 
previously provided and saved (by using the SAVE DEFAULT SETUP command), they will be unaffected by this 
command.  
 
Cancel command button - Activating the Cancel button returns you to the acquisition display (cancels your exit 
request). 
 
 
SPECIAL CONSIDERATIONS 
When in either the RECORD or STBY operating mode and an exit is requested, the prompt in the exit dialog box 
indicates that the data file will first be closed if the OK button is selected: 
 

 
 
In this case, the command buttons function exactly the same as described above. However, the calibration or set-up 
parameters can be saved by first selecting the Cancel button followed by SAVE DEFAULT SETUP (from the File 
menu) then selecting the OK button. 
 
 
EXAMPLE 
 
KEYSTROKE COMMENTS 
ALT, F, X Exit WINDAQ/Tach. 
 
OK or Cancel As required. 
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RANGE OF CHANNELS FEATURE 
 
FUNCTION 
This feature consists of three separate functions that allow you to conveniently monitor and manipulate all the 
channels you have enabled when they can’t be displayed on the monitor all at once. These functions are most useful 
when many channels are enabled (such as with a slave expansion instrument or with an EXP Series channel 
multiplexer) and the size of your monitor or the amount of screen space devoted to the WINDAQ/Tach window 
prevents you from seeing them all. 
 
These functions are similar to the VARIABLE WAVEFORM ASSIGNMENTS function in that they allow you to 
assign any enabled channel to a specific display window, however these functions allow you to assign or manipulate 
a block of channels while the VARIABLE WAVEFORM ASSIGNMENTS function only allows one channel 
assignment at a time. Each item is described as follows: 
 
ACTIVATING PROCEDURE 
Assign Range - This function is similar to the VARIABLE WAVEFORM ASSIGNMENTS function in that it 
allows channel assignment to a specific display window, however this function allows you to assign a block of any 
enabled consecutive ADC channels rather than just a single channel. To assign a range of channels, you must first 
select the window in which you would like the block of channels to begin. This is done by: 

 Clicking the left mouse button in the unselected channels annotation margin. 

 Typing the number or letter of the display window that contains the waveform to be adjusted. 
 
The focal point for selecting the desired window is the variable waveform assignment indicator of each channel. 
This is the two-element equality (X=Y) displayed for every enabled ADC channel. Element “X” is the waveform 
window number or letter and element “Y” is the ADC channel number assigned to that window. Element “X” (the 
waveform window) is always the element specified to enable the waveform contained in that window for 
adjustment. When a waveform window is selected, a highlighted box surrounds the X=Y annotation, indicating that 
the window is enabled for adjustment: 
 

 

 
When the desired window is selected, the channel range can be assigned as follows: 

 Point to the View menu and drag down to Assign Range…. 

 Choose View Assign Range… (ALT, V, R). 
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This causes the channel number (element “Y”) in the highlighted box surrounding the X=Y annotation to blink. 
Enter the new or desired channel number here. If the box is still blinking after typing fewer than the maximum 
number of digits, press a non-numeric key to stop it from blinking.  
 
Display windows appearing on the monitor below the selected one are now assigned consecutively higher numbered 
channels while the display windows appearing on the monitor above the selected one are now assigned 
consecutively lower numbered channels. 
 
For example, say you have 16 channels of data enabled for acquisition but for some reason can only display 8 at a 
time on your monitor. You can use the Assign Range… command to conveniently see the remaining eight channels 
of data. Just select waveform window 1, select Assign Range… from the View menu, and enter 8 in the blinking 
box. Instead of channels 0 through 7, waveform windows 1 through 8 now show channels 8 through 15. 
 
Forward Range - This function allows you to conveniently scroll through, in a forward direction, all the 
consecutive channels you have enabled when they can’t be displayed on the monitor all at once. This function is 
most useful when many channels are enabled (such as with a slave expansion instrument or with an EXP Series 
multiplexer) and the size of your monitor or the amount of screen space devoted to WINDAQ/Tach prevents you 
from seeing them all.  
 
To display consecutive channels that are higher-numbered than the one at the bottom of your monitor: 

 Point to the View menu and drag down to Forward Range. 

 Choose View Forward Range (ALT, V, F). 
 
For example, say you have 32 channels of data enabled for acquisition but for ease of viewing and to keep a high 
degree of detail, you want only 8 displayed at a time on your monitor. You can use the Forward Range command to 
conveniently scroll forward through the remaining channels of data. Just select Forward Range from the View menu 
(or use the CTRL+DOWN ARROW accelerator keystroke). The next higher-numbered 8 channels will be 
displayed.  
 
Backward Range - This function allows you to conveniently scroll through, in a backward direction, all the 
consecutive channels you have enabled when they can’t be displayed on the monitor all at once. This function is 
most useful when many channels are enabled (such as with a slave expansion instrument or with an EXP Series 
multiplexer) and the size of your monitor or the amount of screen space devoted to WINDAQ/Tach prevents you 
from seeing them all.  
 
To display consecutive channels that are lower-numbered than the one at the top of your monitor: 

 Point to the View menu and drag down to Backward Range. 

 Choose View Backward Range (ALT, V, B). 
 
For example, say you have 32 channels of data enabled for acquisition but for ease of viewing and to keep a high 
degree of detail, you want only 8 displayed at a time on your monitor. You can use the Backward Range command 
to conveniently scroll backward through the remaining channels of data. Just select Backward Range from the View 
menu (or use the CTRL+UP ARROW accelerator keystroke). The next lower-numbered 8 channels will be 
displayed.  
 
SPECIAL CONSIDERATIONS 
These functions are most useful with slave expansion instruments or with an EXP Series multiplexer. 
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SAMPLE RATE SELECTION 
 
FUNCTION 
Use the Sample Rate Selection Dialog Box to define the rate at which the tachometer signal is sampled.  Sample 
Rate should be chosen to be proportional  to the pulse width of the active part of the tachometer signal as follows: 
 

 
t = pulse width of tachometer 
n = number of channels 

2n
t

1
••=(Hz) Rate Sample

 

For example, a tachometer signal with an active pulse width of 1 millisecond requires a sample rate of 4 kHz when 
applied to a data acquisition application that acquires two channels. 
 
Win software has been tested to a maximum sample rate of 40,000 samples per second, which we believe to be 
amply sufficient for most applications, however, it’s very possible that the software is capable of faster sample rates 
by at least a factor of 2. 
 
ACTIVATING PROCEDURE 
To specify a sample throughput rate: 
 

 Click the Sample Rate button in the ToolBox. 
 

 Point to the Edit menu and drag down to Sample Rate… 
OR 

 Double-click on the S/s (F3): field in the status bar. 
 

 Choose Edit Sample Rate… (ALT, E, R). 
 
This displays the sample rate dialog box as follows: 
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The minimum sample rate you can specify is equal to the number entered in the Maximum Sample Rate dialog box 
(Edit, Preferences, Maximum Sample Rate) divided by 32, 767. 
 
In order to enter a sample rate of less than 1 in the Sample Rate text box (effectively sampling about once per 
minute) you must also lower the maximum burst rate. This is done as follows: 
 

 1. Point to the Edit menu, drag down to Preferences, and release the left mouse button. 
 2. In the Edit Preferences submenu, click Maximum Sample Rate… 
 

 Choose Edit Preferences Maximum Sample Rate… (ALT, E, P, M).  
 
This displays the maximum sample rate dialog box:  
 

 
 
Enter in the text box the minimum value for maximum burst rate. Just as before, minimum and maximum burst rate 
values vary by instrument, but a value that will work for most all instruments is 500 (you can find the absolute 
lowest maximum burst rate by entering an obviously low number in the text box, such as 10. The software will 
reject 10 and respond with a dialog box that states the minimum and maximum values for your particular hardware).  
 
When the desired maximum sample rate is entered, close the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key.  
 
The following diagram illustrates the relationship of maximum burst rate to sample rate.  
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As can be seen from the illustration, the maximum burst rate must be set to the low end of its range to get a sample 
rate less than 1. The maximum burst rate can be restored to its previous value if desired. 
 
The Input Buffer Size in KiloBytes value is displayed for informational purposes only in this text box, it can not be 
directly adjusted by the user. It indicates the size of the input buffer, which is where the acquired data will be 
temporarily stored (in “valuable” or scarce, contiguous Global DOS memory). The amount of memory allocated for 
this buffer is a function of three factors: the current sample rate, how much memory is currently being used by your 
computer, and the input buffer size limit (maximum amount of your computer’s memory you have dedicated to this 
buffer, specified from the Preferences command on the Edit menu). The Disk Buffer Size in KiloBytes value is 
also displayed for informational purposes only and can not be directly adjusted by the user. It indicates the size of 
the disk buffer, which is a temporary storage place (in “cheap” or easily-attainable, non-contiguous memory) for the 
acquired data before being written to disk. 
 
However, with WINDAQ/Tach you can directly adjust or modify buffer size and sample rate, two factors that govern 
gap-free data acquisition.  
 
The Preferences command on the Edit menu allows you to specify a buffer size ranging from 16kB to 128kB. The 
larger the buffer size, the greater the chance of acquiring gap-free data at the maximum sample rate your computer 
can achieve. However, the larger the buffer size, the more memory it uses, thus leaving less (perhaps not enough) 
for running other programs. If you never run other programs simultaneously with WINDAQ/Tach, then conserving 
memory is not an issue. However, if you like to run WINDAQ/Tach simultaneously with a spreadsheet program or a 
data analysis program, then you must limit the amount of memory allocated to the input buffer so the other 
applications have enough memory to run. 
 
The dialog box shown above allows you to specify sample rate. The sample rate used to determine buffer size is the 
old or previous sample rate value (before any changes were made with this dialog box). The amount of buffer space 
allocated is proportional to the sample rate. WINDAQ/Tach automatically and transparently allocates the correct 
amount of buffer space when you input a sample rate. However if you have increased the buffer size (via Edit 
Preferences), there is a chance that the sample rate you enter is too high for the amount of buffer space you have 
allocated. If this is the case, the S/s (F3): value in the status bar will be displayed in reverse video as follows: 
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Reverse video
 

 
This serves as a warning that you might not be able to reliably store data to disk with the current combination of 
sample rate and buffer size. Refer to Appendix A; Different Ways of Allocating Memory for complete details if a 
reverse video condition is achieved. If none of the steps in Appendix A helps, you have two options: lower the 
sample rate or increase the buffer size.  
 
When the desired sample throughput rate is entered, close the dialog box by: 
 

 Clicking the OK command button. 

 Pressing the ENTER key. 
 
 
SPECIAL CONSIDERATIONS 
The sample rate shown is a throughput rate. The sample rate per channel (obtained by dividing the selected sample 
throughput rate by the number of channels enabled) is displayed in the bottom annotation line as S/s/CHAN:. 
 
Although there are thousands of different sample rates that may be configured, some discrete rates are not 
achievable. This limitation is due to the inability to divide the master clock in a manner that results in a quotient that 
is an even number. For example, this is the reason why you get a sample rate of 2999.63 when you entered 3000. 
 
EXAMPLE 
 
Accelerator key version 
 
KEYSTROKE COMMENTS 
F3 Displays the Sample Rate dialog box. 
 
Enter the desired sample rate. 
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SCREEN ANNOTATION CONTROL FUNCTION 
  
FUNCTION 
Allows you to configure the on-screen waveform annotation many different ways. Options such as current data, data 
display, limit display, and user annotation can be enabled or disabled, in any combination, to customize the 
waveform display. Each annotation option is described as follows: 
 
ACTIVATING PROCEDURE 
Current Data - This option allows you to enable/disable the display of the current waveform data value in the left 
or right annotation margin. The Data Display option must be enabled to display current waveform data.  
 
When this option is enabled in the oscilloscope mode, the current waveform data value at the cursor position is 
displayed in the annotation margin. The cursor or “erase bar” does not have to be enabled.  
 
When enabled in the scroll mode, the current waveform data value at the real time point (far right screen edge) is 
displayed in the annotation margin.  
 
When this option is disabled (in either mode), the base line value is displayed in the left/right annotation margin (if 
Data Display is enabled). To enable current waveform data (if disabled, or disable it if enabled): 
 

 Point to the Options menu and drag down to Current Data. 

 Choose Options Current Data (ALT, O, C). 
 
When the current data option is enabled, the annotation margin will have the following appearance and a check 
mark (√) will be displayed on the Options menu immediately preceding the Current Data command: 
 

 
Data Display - This option allows you to enable/disable the display of data or base line values in the annotation 
margin. If Limit Display  is not enabled, the engineering units will toggle on and off along with the value. To enable 
the data display (if disabled, or disable it if enabled): 
 

 Point to the Options menu and drag down to Data Display. 

 Choose Options Data Display (ALT, O, D). 
 
When the data display option is enabled, the annotation margin will have the following appearance and a check 
mark (√) will be displayed on the Options menu immediately preceding the Data Display command: 
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Data display enabled

 
 
Limit Display  - This option allows you to enable/disable the display of upper and lower chart-edge limits in the 
left/right annotation margin. If Data Display is disabled, engineering units toggle on and off along with the limits. 
To enable the upper and lower chart-edge limit display (if disabled, or disable them if enabled): 
 

 Point to the Options menu and drag down to Limit Display. 

 Choose Options Limit Display (ALT, O, L). 
 
When the limit display option is enabled, the annotation margin will have the following appearance and a check 
mark (√) will be displayed on the Options menu immediately preceding the Limit Display command: 
 

Limit display enabled

 
 
User Annotation - This option allows you to enable/disable (toggle) the display of user annotation (entered from 
the Edit menu, User Annotation… command) in the waveform strip. To enable user annotation (if disabled, or 
disable it if enabled): 
 

 Point to the Options menu and drag down to User Annotation. 

 Choose Options User Annotation (ALT, O, U). 
 
When user annotation is enabled, the waveform strip will display the specified channel’s annotation (entered with 
Edit User Annotation…) and a checkmark (√) will be displayed on the Options menu immediately preceding the 
User Annotation command: 
 

User annotation enabled

 
 
SPECIAL CONSIDERATIONS 
Screen annotation options can be enabled in virtually any combination to provide the desired result. However, in 
some instances one option will override another. For example, if Data Display is disabled, it is not possible to enable 
Current Data. Similarly, if Limit Display is disabled, it is not possible to enable Current Data. 
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EXAMPLE 
 
Accelerator key version 
(assumes an initial condition of no annotation displayed) 
 
KEYSTROKE COMMENT 
ALT+L Enable limit display. 
F2 Enable data display. 
ALT+F2 Enable current data.  
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SCREEN GRID PATTERN CONTROL FUNCTION 
  
FUNCTION 
Used to enable or disable the real time waveform display grid pattern. 
 
ACTIVATING PROCEDURE 
 

 Click the Show/Hide Grid button in the ToolBox. This enables the grid if it was disabled, or disables the 
grid if it was enabled. 

 Point to the Options menu and drag down to Grids. This enables the grid if it was disabled, or disables the 
grid if it was enabled. 

 Choose Options Grids (ALT, O, G). This also enables the grid if disabled, or disables it if enabled. 
 
When the grid pattern is enabled, a checkmark (√) is displayed on the Options menu immediately preceding the 
Grids command. When the grid pattern is disabled, the checkmark is not displayed. 
 
SPECIAL CONSIDERATIONS 
None. 
 
EXAMPLE 
 
Accelerator key version 
(Assumes that the grid pattern is initially disabled) 
 
KEYSTROKE COMMENT 
ALT+G Enable grid pattern. 
 
ALT+G Disable grid pattern. 
 
ALT+G Enable grid pattern. 
 
Etc. Etc. 
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SHOW DYNAMIC RANGE 
 
FUNCTION 
Allows you to see the waveform file with respect to the entire dynamic range of the A/D converter. Activating this 
function modifies the vertical scale (and automatically adjusts the waveform) so the + and - full scale counts are 
placed at the top and bottom of the waveform strip.  
 
An A/D converter operates in terms of counts. If X represents the bit resolution of the A/D converter, then the + full 

scale limit is [2(x-1)-1] counts and the - full scale limit is 2(x-1) counts. For example if you have a 12-bit A/D 
converter, the + full scale limit is 2047 counts and the - full scale limit is 2048 counts. 
 
By seeing the waveform with respect to the entire dynamic range of the A/D converter, you see how much of this 
range you are using. Ideally, the waveform should use the entire dynamic range of the A/D converter in order to 
take full advantage of its resolution. 
 
ACTIVATING PROCEDURE 

 Point to the Scaling menu and drag down to Show Dynamic Range. 
 

 Choose Scaling Show Dynamic Range (ALT, C, R). 
 
This modifies the vertical scale (and automatically adjusts the waveform) to place the + and - full scale A/D 
converter counts at the top and bottom of the waveform strip, thus showing you the waveform file with respect to 
the entire dynamic range of the A/D converter. 
 
SPECIAL CONSIDERATIONS 
Subsequent activations of the Show Dynamic Range command does nothing, the function does not toggle. To get 
back to the display you had prior to activating the Show Dynamic Range function, use the Undo command on the 
Edit menu. 
 
EXAMPLE 
 
Keystroke Comment 
ALT+R Show dynamic range of waveform. 
 
CTRL+Z Undo the Show Dynamic Range function. 
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TACHOMETER 
 
FUNCTION 
Allows the tachometer scaling factor to be entered in millimeters (10.0 by default), with check boxes to allow 
specifying positive-going instead of negative-going pulses or a direction signal where negative-going means 
forward 
 
ACTIVATING PROCEDURE 

 Point to the Edit menu and drag down to Tachometer. 
 

 Choose Edit Tachometer (ALT, E, T). 
 
SPECIAL CONSIDERATIONS 
Edit Tachometer will be disabled once recording to a file has begun, and may not be changed thereafter for that file. 
 
EXAMPLE 
 
Keystroke Comment 
Alt + T Edit distance between tachometer pulses. 
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DISTANCE PER DIVISION FUNCTION 
 
FUNCTION 
Displays the distance per major division at the bottom of the real time screen as M / DIV: or KM / DIV:. The 
displayed value is a function of the tachometer scaling factor (Edit-Tachometer) and the selected waveform 
compression factor. 
 

 
 
 
ACTIVATING PROCEDURE 
None. Distance per major division is displayed at all times in all operating modes. 
 
SPECIAL CONSIDERATIONS 
None. 
 
EXAMPLE 
None. 
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TOOLBOX FUNCTION 
 
FUNCTION 
When enabled, a floating “toolbox” of buttons is displayed on your screen. The toolbox buttons provide quick 
access to commonly used commands. 
 
ACTIVATING PROCEDURE 
When you first start WINDAQ/Tach, the toolbox is hidden (disabled). To display the toolbox: 

 Point to the View menu and drag down to ToolBox.  

 Choose View ToolBox (ALT, V, T).  
 
This displays the ToolBox: 
 

 
 
Each button on the ToolBox provides quick access (a shortcut) to a commonly used WINDAQ/Tach function as 
follows: 

Commented Event Marker

Waveform Compression

Sample Rate

Calibration

Channel Setup

Enable Channels

Start/Stop Recording

Open/Close File

Open Reference File

Trigger Mode

Oscilloscope Mode

Scroll Mode

Shift Waveform Down

Shift Waveform Up

Shrink Waveform 2x

Expand Waveform 2x

Change Palette

Show/Hide Grid
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Open Reference File — Allows you to use the parameters in an existing data file as a “set up” for a new data 
acquisition file. When this button is activated, the Open Reference File dialog box appears prompting you for the set 
up file name and path. This button is the same as choosing Open Reference File… from the File menu. Refer to the 
Open Reference File Function for complete details. 
 
Open /Close File — Allows you to open an existing file or to create a new file. When this button is activated, the 
Open dialog box appears prompting you to specify a file name (to create a new file) or to select an existing file (to 
append to it). When a file is open, a second activation of this button closes the file. Note that you are not yet 
recording data to disk, you have only opened (or assigned a name to) a data file. This button is the same as choosing 
Open… from the File menu. Refer to the Acquire Data To Disk Function for complete details. 
 
Start/Stop Recording — Allows you to start or stop recording to disk. When this button is activated without a data 
file open, the Open dialog box appears prompting you to specify a file name (to create a new file) or to select an 
existing file (to append to it). When the file name is specified, recording is started. When this button is activated 
with a data file already open, recording starts immediately. 
 
A second activation of this button stops recording to disk, but keeps the data file open. Subsequent activations of 
this button toggles between record and stop. Note that you can start and stop recording to disk as many times as you 
like. This button is the same as choosing Record from the File menu. Refer to the Acquire Data To Disk Function 
for complete details. 
 
Enable Channels — Allows you to enable channels for recording and to specify whether these channels are 
configured for single-ended, differential, or digital operation.  
 
When this button is activated on instruments with 16 channels or less, the flashing Ch:_ block cursor is displayed 
in the status bar following the Channels: field. A single-ended channel is enabled by entering the channel’s 
number and pressing the ENTER key. A differential channel is enabled by entering the channel number followed by 
the letter “D” (e.g., “3D”) and pressing the ENTER key. A digital channel is enabled by entering the channel 
number followed by the letter “I” (e.g., “4I”) and pressing the ENTER key. Pressing any key other than a number 
key, the D key, or the I key exits channel configuration. To remove a channel, activate the tool button, type a minus 
sign (-) followed by the channel number, and press ENTER (e.g., “-4” removes single-ended channel 4). 
 
When this button is activated on instruments with more than 16 channels, the channel selection grid is displayed. 
Refer to Appendix B or Appendix E for channel enabling details on these instruments. 
 
This button is the same as choosing Channels… from the Edit menu. Refer to the Configure ADC Channels 
Function for complete details. 
 
Channel Setup — Allows you to select gain and unipolar/bipolar measurement range on a channel-by-channel 
basis. Since these parameters can be set per channel, the desired channel must be selected. A channel is selected by 
clicking the left mouse button in the desired channel’s annotation margin (when selected, a highlighted box 
surrounds the X=Y annotation in the margin). When this button is activated, the Channel X Settings dialog box 
appears with the selectable gain factors and resulting + and - full scale voltages. To select a gain, simply click on it 
and choose the OK command button. To specify unipolar measurement range, click the Unipolar check box. To 
specify bipolar measurement range, leave the Unipolar check box unchecked. 
 
This button is the same as choosing Channel Settings… from the Edit menu. Refer to the Amplifier Gain Control 
Function for complete details. 
 
Calibration  — Allows you to calibrate the waveform in any significant engineering units, using the fixed 
calibration method. When this button is activated, the Fixed Calibration dialog box appears prompting you to enter 
calibration values. This button is the same as choosing Fixed Calibration… from the Edit menu. Refer to the 
Waveform Calibration—Fixed Method Function for complete details. 
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Sample Rate — Allows you to specify a sample throughput rate for data recording. When this button is activated, 
the Sample Rate dialog box appears prompting you to specify the desired throughput rate (or total scanning rate) in 
samples per second. For example, if you wanted to record two channels one at 40 Hz and the other at 90 Hz, you 
would enter a throughput rate of 130 in the text box. This button is the same as choosing Sample Rate… from the 
Edit menu. Refer to the Sample Rate Selection Function for complete details. 
 
Waveform Compression — Allows you to compress the waveform display on your monitor. This is done by 
varying the number of data points that are used to display the real time waveform on your monitor. Increasing the 
compression factor causes the display to plot less often, which results in a slower real time display (the waveform is 
being displayed at a fraction of the selected sample rate). This feature is only a “graphics adjuster” that only affects 
how the display looks on your monitor. Data acquired to disk is independent of these adjustments and is always 
recorded continuously to disk uncompressed. When this button is activated, the Compression dialog box appears 
prompting you to specify a compression factor (1 to 65,536). This button is the same as choosing Compression… 
from the Edit menu. Refer to the Waveform Compression Function for complete details. 
 
Commented Event Marker — Allows you to insert a commented event marker at any point in the data stream 
going to disk. You must be in the RECORD mode (recording waveform data to disk) to insert commented event 
markers. When this button is activated, the Event Marker Comment dialog box appears prompting you to specify a 
39-character comment that will be associated with the event marker. The event marker is anchored at its position in 
the data file the instant the button is activated. Data recording to disk continues while you enter your comment. This 
button is the same as choosing Insert Commented Mark from the Edit menu. Refer to the Event Marker Function for 
complete details. 
 
Show/Hide Grid — Enables/disables the display of the real time waveform grid. This button is the same as 
choosing Grids from the Options menu. Refer to the Screen Grid Pattern Control Function for complete details. 
 
Change Palette — Allows you to change the display color schemes. When this button is activated, the User Palette 
dialog box appears prompting you to select background, grid lines and user annotation, first waveform, and/or 
second waveform colors. This button is the same as choosing User Palette… from the View menu. Refer to the 
Palette Selection Function for complete details. 
 
Expand Waveform 2x — Allows you to scale (expand) the specified waveform two times its original size in 
amplitude. When this button is activated, the waveform is expanded two times its original size in amplitude. 
Subsequent activations of this button continue to expand the waveform 2x in amplitude. Note that the waveform 
limits and value change as well. This button is the same as choosing Grow 2X from the Scaling menu. Refer to the 
Waveform Display Scaling and Offset Function for complete details. 
 
Shrink Waveform 2x — Allows you to scale (contract) the specified waveform one-half its original size in 
amplitude. When this button is activated, the waveform is contracted one-half its original size in amplitude. 
Subsequent activations of this button continue to contract the waveform one-half in amplitude. Note that the 
waveform limits and value change as well. This button is the same as choosing Shrink 2X from the Scaling menu. 
Refer to the Waveform Display Scaling and Offset Function for complete details. 
 
Shift Waveform Up — Allows you to offset (shift) the specified waveform 10 pixels up in amplitude from its 
current position. When this button is activated, the waveform is shifted up 10 pixels in amplitude. Subsequent 
activations of this button continue to shift the waveform up by 10 pixels. Note that the waveform limits and value 
change as well. This button is the same as choosing Waveform Up 10 Pixels from the Scaling menu. Refer to the 
Waveform Display Scaling and Offset Function for complete details. 
 
Shift Waveform Down — Allows you to offset (shift) the specified waveform 10 pixels down in amplitude from its 
current position. When this button is activated, the waveform is shifted down 10 pixels in amplitude. Subsequent 
activations of this button continue to shift the waveform down by 10 pixels. Note that the waveform limits and value 
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change as well. This button is the same as choosing Waveform Down 10 Pixels from the Scaling menu. Refer to the 
Waveform Display Scaling and Offset Function for complete details. 
 
Scroll Mode — Allows you to display waveform information on your monitor in a continuous smooth scroll mode. 
When this button is activated, the waveform display switches to smooth scroll mode. This button does not toggle. 
Either display mode (scroll mode or oscilloscope mode) may be enabled at any time during data recording without 
affecting the information being stored to disk. This button only affects the way you view waveforms on your 
monitor. This button is the same as choosing Scroll Mode from the Options menu. Refer to the Display Mode 
Selection Function for complete details. 
 
Oscilloscope Mode — Allows you to display waveform information on your monitor in a triggered sweep 
oscilloscope mode. When this button is activated, the oscilloscope triggering dialog box is displayed, prompting you 
to choose between a triggered sweep oscilloscope display or a free-running oscilloscope display. Checking the Free 
Run check box selects free running oscilloscope display. Leaving the Free Run box blank selects triggered sweep 
oscilloscope display. This button does not toggle. Either display mode (scroll mode or oscilloscope mode) may be 
enabled at any time during data recording without affecting the information being stored to disk. This button only 
affects the way you view waveforms on your monitor. This button is the same as choosing Oscilloscope Mode… 
from the Options menu. Refer to the Display Mode Selection Function for complete details. 
 
Triggered Mode — Not applicable to WINDAQ/Tach software.  
 
SPECIAL CONSIDERATIONS 
In terms of end result, selecting a button from the ToolBox is no different than clicking on a menu and dragging 
down to the desired command, both methods accomplish the same result. Whether you should use the ToolBox or 
not is largely a matter of personal preference. Some may find the ToolBox invaluable for saving steps, while others 
won’t want it taking up valuable display space on their monitors. 
 
EXAMPLE: None. 
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UNDO FUNCTION 
 
FUNCTION 
Allows you to reverse the last screen scaling or offset operation performed on a selected channel. When “undone”, 
the waveform will revert back to the original values before the previous scaling or offset operation. Note that this 
feature only works on the same channel as the most recent scaling or offset operation. Subsequent undo operations 
toggles the waveform between the previous and most recent versions of screen scaling or offset. 
 
ACTIVATING PROCEDURE 
A scaling or offset operation must first be performed on a selected channel to make the Undo command selectable 
(undimmed). Once Undo becomes selectable, you can perform any other playback operation (except another scaling 
or offset operation) on any other channel and still have the capability to come back to the selected channel and undo 
the last screen scaling or offset operation.  
 
After scaling or offsetting a waveform, reverse the operation as follows: 
 

 1. Point to the Edit menu and drag down to Undo.  
 

 1. Choose Edit Undo (ALT, E, U).  
 
SPECIAL CONSIDERATIONS  
None. 
 
ACCELERATOR KEY EXAMPLE 
(Assumes a scaling or offset operation has been performed). 
 
KEYSTROKE COMMENTS 
CTRL+Z Undoes the last scaling or offsetting operation. 
 
CTRL+Z Undoes the last undo action (a “redo”). 
 
Etc. Etc. 
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USER CHANNEL ANNOTATION FUNCTION 
 
FUNCTION 
Allows you to custom annotate (up to 30 characters) each display channel. Used in tandem with the User Annotation 
function on the Options menu, you can display a different message on the baseline of each channel.  
 
ACTIVATING PROCEDURE 
The desired channel annotation must first be entered before it can be toggled on or off. To enter channel annotation: 

 Point to the Edit menu and drag down to User Annotation… 

 Choose Edit User Annotation… (ALT, E, U) 
 
This displays the Channel Annotation dialog box as follows: 
 

 
 
This dialog box prompts you to enter the desired channel annotation for the currently selected channel, or any other 
channel. If not the currently selected channel, enter the desired channel number for which you want to provide 
annotation in the Channel # = text box. In the Annotation = text box, enter the desired annotation (up to 30 
characters). 
 
The Next and Previous command buttons allow you to step through all of the enabled channels in order, entering 
the desired channel annotation for each channel, without closing this dialog box. When all annotation has been 
entered, click OK to assign the annotation to each channel. Clicking Cancel closes the Channel Annotation dialog 
box without assigning any annotation. 
 
Once the channel annotation is entered, the display of user annotation can be toggled on or off with the User 
Annotation command on the Options menu. 
 
SPECIAL CONSIDERATIONS 
As you assign various A-D channels to different waveform windows, the channel's annotation rides along with the 
channel.  User-supplied channel annotation is written to the data file along with the acquired waveform.  
 
Only enabled channels may be annotated. Refer to the CONFIGURE ADC CHANNELS FUNCTION section of this 
chapter. 
 
EXAMPLE 
 
KEYSTROKE COMMENTS 
F11 Select the User Annotation… function. 
1 Select channel one annotation. 
This is a test. Enter as channel one annotation “This is a test.”. 
ENTER Return to normal WINDAQ/Tach screen. 
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VARIABLE WAVEFORM ASSIGNMENTS 
 
FUNCTION 
Allows any enabled ADC channel (from 1 - 32) to be assigned to a specified display window. 
 
ACTIVATING PROCEDURE 
WINDAQ/Tach supports up to 32 waveform display windows (1 through 9, A, B, C, D, E, F, G, H, I, J, K, L, M, N, 
O, P, Q, R, S, T, U, V, W), in which any one of 32 channels may be displayed. In some cases, any two waveforms 
may be displayed in an overlapping format within the same window (refer to the DISPLAY FORMAT 
SELECTION section of this chapter). Waveform windows carry a designator number or letter as follows: 
 

Window Window  Window  Window 
Number Designation Number Designation 

1 1 17 H 
2 2 18 I  
3 3 19 J  
4 4 20 K  
5 5 21 L  
6 6 22 M  
7 7 23 N  
8 8 24 O  
9 9 25 P 
10 A 26 Q 
11 B 27 R 
12 C 28 S 
13 D 29 T 
14 E 30 U 
15 F 31 V 
16 G 32 W 

 
As the above table shows, the windows enabled for display are a function of the selected display format. By typing 
the following sequences*, you can assign any acquired waveform channel number to the specified display window: 
 

*The VARIABLE WAVEFORM ASSIGNMENTS function is best implemented from the keyboard. Note 
that it is possible to use the mouse for this procedure (first enable the desired window by clicking in the 
left/right annotation margin, then point to the View menu and drag down to Assign Channel…, and finally 
type the desired waveform channel number), but the keystroke approach is much more streamlined. 
Because of this, only the keyboard procedure will be documented here. 
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Keystroke Keystroke Keystroke Keystroke  
One (window) Two Three (channel) Four Comments 
1 = 2 not needed Displays ADC channel two in  
    waveform display window one. 
1 = 1 6 Displays ADC channel sixteen in  
    waveform display window one. 
1 = 1 ENTER Displays ADC channel one in  
    waveform display window one. 
2 = 1 2 Displays ADC channel twelve in  
    waveform display window two. 
A = 3 not needed Displays ADC channel three in  
    waveform display window ten. 
4 = 1 6 Displays ADC channel sixteen in  
    waveform display window four. 
4 = 1 ENTER Displays ADC channel one in  
    waveform display window four. 
G = 1 4 Displays ADC channel fourteen  
    in waveform display window sixteen. 
 
The above works for any enabled display format and allows you to examine the characteristics of any acquired 
channel within any display window.  
 
SPECIAL CONSIDERATIONS 
When performing any operation on a specific channel (i.e., up/down scale, offset, etc.), that channel is enabled by 
pressing the letter or number of the display window containing the waveform. When so specified, the X=Y 
annotation in the left/right annotation margin will be highlighted indicating that waveform channel Y contained in 
waveform window X is enabled for operation. 
 
Note that waveform window 1 will, in its default state, always display the lowest enabled channel number. Window 
2 will default to display the second lowest enabled channel number, and so on. 
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WAVEFORM CALIBRATION — FIXED METHOD 
 
FUNCTION 
WINDAQ/Tach offers two different ways to calibrate your waveform: the fixed calibration method and the high/low 
calibration method. Either method will produce the same results, however one method may be preferable or easier to 
use over the other because of the nature of the signals being acquired and/or what is known about the transducers 
used to acquire these signals.  
 
Without calibrating, waveform data is scaled, annotated, and displayed in volts, which in many cases is not very 
meaningful. Calibration is used to give meaning to the displayed data. Instead of volts, your data can be scaled, 
annotated, and displayed in significant engineering units (i.e., PSI, RPM, lbs, ft/s, etc.). Calibration is done primarily 
for display purposes, it makes the data more visually appealing and easier to understand on your monitor. However, 
when data is recorded (or acquired to disk), it is not completely independent of this calibration information you have 
provided. When data is recorded, it is stored to disk in a data file in the form of A/D converter counts. These A/D 
converter counts are stored in a data file regardless of whether you provided calibration information or not. 
However when you calibrate, the calibration information is saved in an accompanying header file while your data is 
being stored in the data file. This header file saves the calibration information, allowing it to be re-used when you 
review the data in WINDAQ Waveform Browser, or if you append data to the same acquisition file, thus eliminating 
the need for you to calibrate again. 
 
The fixed method allows waveform data (in the form of ADC counts) to be scaled and annotated in significant 
engineering units, using minus full scale, baseline, or plus full scale values, when a quantity per unit of measure 
(rather than two calibration levels) is known.  
 
The fixed calibration method allows you to calibrate a waveform when a known linear input to output relationship 
exists for two of these three points: +full scale, baseline, or -full scale. For example, suppose you were acquiring 
temperature signals and you were using a temperature-to-analog converter (TAC). With the two-calibration-level 
method, you could probably determine the low calibration level (such as zero or room temperature) but you could 
not easily determine the high calibration level (how hot is it going to get?). Since you have only one known 
calibration value, it is not possible to calibrate the waveform using this approach. However with the fixed method, 
the TAC device itself offers a solution. Say for instance the TAC you are using is a thermocouple to millivolt 
converter. According to its specifications, it accepts an input signal from a temperature sensor and outputs a linear 1 
millivolt per degree analog voltage signal. This 1mV/degree input to output ratio is the key. Since you know the 
relationship between voltage and the units you are measuring (in this case temperature), you can calibrate the 
waveform using this known quantity per unit of measure instead of using two calibration levels.  
 
ACTIVATING PROCEDURE 
Ensure that the window containing the waveform to be calibrated is enabled. When enabled, the X=Y annotation in 
the left or right annotation margin will be highlighted, indicating that window X is enabled for adjustments. 
Although not required, the current data and data display options can be enabled for more recognizable results (refer 
to the SCREEN ANNOTATION CONTROL FUNCTION section of this chapter for details on enabling these 
features). To calibrate a waveform using the fixed calibration function: 
 
 1. Select Fixed Calibration… as follows: 

 Click the Calibration button in the ToolBox. 

 Point to the Edit menu and drag down to Fixed Calibration…. 

 Choose Edit Fixed Calibration… (ALT, E, F) 
 
  When selected, the Fixed Calibration dialog box is displayed on the screen: 
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  The values displayed in the Engr. Value = text boxes are the upper and lower A/D converter ranges, 

which are preset according to the selected gain. When the dialog box is first displayed, a blinking 
vertical line (called the insertion point) appears behind the value in the High Calibrator Engr. Value 
= text box. This insertion point indicates the active area of the dialog box—the next action you 
perform will occur in this area. Type the desired engineering unit value for the high calibrator. 

 
 2. Press the TAB key twice to position the insertion point in the Low Calibrator Engr. Value = dialog 

box. Type the desired engineering unit value for the low calibrator. 
 
 3. Press the TAB key again to position the insertion point in the Engr. Units = dialog box. Type up to a 

four character optional engineering unit tag (i.e., PSI, f/s, rpm, etc.). 
 
There are also two option buttons for the High and Low Calibrator values:  
 

Option buttons

 
 
These option buttons allow you to calibrate negative only, positive only, or bipolar signals. For example, when you 
are acquiring a signal that is bipolar, you would select the +Full Scale (High Calibrator) and -Full Scale (Low 
Calibrator) options. When the signal you are acquiring is always negative, choose the Baseline (High Calibrator) 
and -Full Scale (Low Calibrator) options. When you are acquiring a signal that is always positive (such as RPM), 
choose the +Full Scale (High Calibrator) and Baseline (Low Calibrator) options. 
 
The Next and Previous command buttons allow you to step through all of the enabled channels in order, calibrating 
each enabled channel, without closing this dialog box. Note that when either the Next or Previous button is 
activated, the channel number in the title bar of the dialog box changes to indicate which channel you are currently 
calibrating.  
 
 4. Complete the fixed calibration entry as follows: 

 Click OK. 

 Press the TAB key until a bold border surrounds the OK command button (indicating  
 selection) and press ENTER. 
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The Fixed Calibration dialog box disappears and the waveform channel displays all waveform data values calibrated 
in the chosen engineering units. 
 
If desired, the upper and lower grid limit values may be specified (and the waveform automatically scaled to fit). 
This feature allows the channel's full scale display span to be shown in whole numbers rather than obscure fractional 
values, which sometimes result from calibrating. For example, a waveform scaled in mmHg can be automatically 
expanded or contracted to fit within grid limits of 0 to 100 mmHg, or -200 mmHg to +200 mmHg, or whatever is 
desired. Note that a channel spanning 0 - 200 mmHg is much easier to read and interpret on a per division basis than 
one that spans 10.372 - 189.628 mmHg.  
 
To specify convenient upper and lower chart edge values: 
 1. Select Scaling Limits… as follows: 

 Point to the Scaling menu and drag down to Limits…. 

 Choose Scaling Limits… (ALT, C, L). 
 
  When selected, the Display Limits dialog box is displayed on the screen as follows: 
 

 
 

 2. Using the same procedure as before, type convenient top and bottom chart-edge values in their 
respective text boxes. 

 
The Next and Previous command buttons allow you to step through all of the enabled channels in order, entering 
the desired display limits for each channel, without closing this dialog box. Note that when either the Next or 
Previous button is activated, the channel number in the title bar of the dialog box changes to indicate the channel 
for which you are currently setting display limits. 
 
 3. Complete the chart-edge value entry as follows: 

 Click OK. 

 Press the TAB key until a bold border surrounds the OK command button (indicating  
 selection) and press ENTER. 

 
Your specified values will now be displayed on the upper and lower chart-edges and the waveform will be 
automatically scaled to fit the new values. 
 
SPECIAL CONSIDERATIONS 
The value of engineering units may range from 1.0 E+32 to 1.0 E-32. 
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DI-720Series 

 
 
 

Gain 

Maximum 
Measurement 

Range 

1 ±10V 

2 ±5V 

4 ±2.5V 

8 ±1.25V 

 
 

DI-730 Series 
 

 
 

Gain 

Maximum 
Measurement 

Range 

1 ±800V 

10 ±100V 

100 ±10V 

1,000 ±1V 

10,000 ±100mV 

100,000 ±10mV 

 
Example - Suppose we are using a DI-730 to acquire pressure data and we are using a converter device that accepts 
an input signal from a pressure sensor and outputs a linear 1 millivolt per PSI analog voltage signal. We want to 
acquire pressure data in the 0 to 100 PSI range. (a) What gain range should we select? (b) What input configuration 
should we select? (c) What should our calibration values be? 
 
(a) Since the converter device that we are using has a 1 millivolt = 1 PSI relationship and we expect to measure 
pressure in the 0 to 100 PSI range, we can expect to measure from 0 to 100 millivolts (0.1 volts) with the converter 
device. Therefore, we should select a gain that delivers a +full scale value no less than 100 millivolts (or 0.1 volts). 
From the chart, we see a gain of 100 provides exactly this range (on the unipolar side of the DI-200 chart). So you 
would configure this channel (the channel you are using to acquire the pressure data) for a gain of 100 (you must be 
in the SETUP operating mode to configure gain. Refer to the AMPLIFIER GAIN CONTROL function in this 
chapter for complete details). 
 
(b) Because the converter device output is going to be 0 to 100 millivolts, we should select the unipolar input 
configuration since our signal will never be negative (below zero). Select the +Full Scale option button in the High 
Calibrator row and the -Full Scale option button in the Low Calibrator row as follows: 
 

Click here
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(c) From the chart, at a gain of 100, the -full scale value is 0 volts and the +full scale value is 100 millivolts. Since 
we will be measuring 0 to 100 millivolts, 0 is ideal for the low calibrator value (enter 0 in the Low Calibrator Engr. 
Value box) and 100 is ideal for the high calibrator value (enter 100 in the High Calibrator Engr. Value box). Then 
specify significant units (in this case PSI) in the Engr. Units box. All of the acquired data will be within this range 
and calibrated in PSI rather than volts. The following illustration depicts our calibrated screen display.  
 

 

+FS

BL

-FS

(+Full scale)

(Baseline)

(-Full scale)

Given: 1 mV/PSI Volts

0.1V (100 mV)

0.05V (50 mV)

0V

Units

100 PSI

50 PSI

0 PSI  
 
 
EXAMPLE 
 
Accelerator key Version 
 
KEYSTROKE COMMENTS 
1 Select the window to receive engineering unit data. 
F12 Prepare to enter high calibrator value. 
500 Enter high calibrator value. 
TAB Prepare to enter low calibrator value. 
-500 Enter low calibrator value. 
o F (degrees Fahrenheit) Enter engineering unit tag. 
ENTER Complete the fixed calibration entries. 
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WAVEFORM CALIBRATION — HIGH/LOW METHOD 
 
FUNCTION 
WINDAQ/Tach offers two different ways to calibrate your waveform: the fixed calibration method and the high/low 
calibration method. Either method will produce the same results, however one method may be preferable or easier to 
use over the other because of the nature of the signals being acquired and/or what is known about the transducers 
used to acquire these signals.  
 
Without calibrating, waveform data is scaled, annotated, and displayed in volts, which in many cases is not very 
meaningful. Calibration is used to give meaning to the displayed data. Instead of volts, your data can be scaled, 
annotated, and displayed in significant engineering units (i.e., PSI, RPM, lbs, ft/s, etc.). Calibration is done primarily 
for display purposes, it makes the data more visually appealing and easier to understand on your monitor. However, 
when data is recorded (or acquired to disk), it is not completely independent of this calibration information you have 
provided. When data is recorded, it is stored to disk in a data file in the form of A/D converter counts. These A/D 
converter counts are stored in a data file regardless of whether you provided calibration information or not. 
However when you calibrate, the calibration information is saved in an accompanying header file while your data is 
being stored in the data file. This header file saves the calibration information, allowing it to be re-used when you 
review the data in WINDAQ Waveform Browser, or if you append data to the same acquisition file, thus eliminating 
the need for you to calibrate again. 
 
The high/low method allows waveform data (in the form of ADC counts) to be scaled and annotated in significant 
engineering units using any known or verified transducer output values.  
 
The high/low method is the easiest and most flexible method of calibrating data. For example, suppose you were 
acquiring pressure data with a transducer that had a known output of -1 volt at 0 PSI and 4.5 volts at 100 PSI. 
Whether these output levels were read from the manufacturers specifications or verified through use, they can be 
used as calibration values. There is no need to determine + or - full scale or baseline values with this method, any 
known transducer output relationship can be used.  
 
With this method, you can even calibrate the data without knowing the transducer output relationship. Simply let 
WINDAQ/Tach establish these output voltage values for you. For example, suppose you were acquiring pressure data 
and you had no idea what kind of output voltages to expect from the transducer you’re using. You could vent the 
pressure apparatus to quiesence or atmospheric pressure and observe what voltage the transducer is outputting at 
quiesence from the Input Level text box in the Low Calibration dialog box (select Low Calibration… from the Edit 
menu). In this same dialog box, enter what you would like this quiesent state to be, such as “0”, in the Low Cal Value 
text box, and enter “PSI” in the Engr. Units text box. Now activate the OK command button to close the dialog box 
and increase the pressure until the manometer reads a convenient value, say 100 PSI. In a similar manner, observe 
what voltage the transducer is outputting at this 100 PSI level from the Input Level text box in the High Calibration 
dialog box (select High Calibration… from the Edit menu). Enter “100” in the High Cal Value text box, enter “PSI” 
in the Engr. Units text box, activate the OK command button, and you’re done. 
 
ACTIVATING PROCEDURE 
Ensure that the window containing the waveform to be scaled is enabled. When enabled, the X=Y annotation in the 
left or right annotation margin will be highlighted, indicating that window X is enabled for adjustments. Although 
not required, the current data and data display options can be enabled for more recognizable results (refer to the 
SCREEN ANNOTATION CONTROL FUNCTION section of this chapter for details on enabling these features). 
To calibrate a waveform using the high/low calibration method: 
 
 1. Select Low Calibration… as follows: 

 Point to the Edit menu and drag down to Low Calibration…. 

 Choose Edit Low Calibration… (ALT, E, L) 
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  When selected, the Low Calibration dialog box is displayed on the screen: 
 

 
 
  When the dialog box is first displayed, a blinking vertical line (called the insertion point) appears 

behind the value in the Low Cal Value text box. This insertion point indicates the active area of the 
dialog box—the next action you perform will occur in this area. This is where you enter the low 
calibration data value that is to be assigned to the input voltage level. For instance, referring back to 
our previous examples: 

 
  a) For the case where the transducer output is known, 
 

Input Level

-1 V
4.5 V

at
at

0
100

PSI
PSI

Cal Value
Engr. Units

 
 
  we would enter “0” in the Low Cal Value text box, “-1” in the Input Level text box, and “PSI” in the 

Engr. Units text box. 
 
  b) For the case where the transducer output is unknown, we would also enter “0” in the Low Cal Value 

text box, ignore the Input Level text box (WINDAQ/Tach has established the input voltage level for 
you), and enter “PSI” in the Engr. Units text box.  

 
  Press the TAB key to position the insertion point in the various text boxes. 
 
  Type up to a four character optional engineering unit tag (i.e., PSI, f/s, rpm, etc.). 
 
 2. Complete the low calibration entry as follows: 

 Click OK. 

 Press the TAB key until a bold border surrounds the OK command button (indicating  
 selection) and press ENTER. 

 
The Low Calibration dialog box disappears and if no high calibration has been done yet, an offset is applied to the 
waveform to achieve the entered value. But you are only half done, it takes two points to define a line and so the 
high calibration must be done.  
 
 1. Select High Calibration… as follows: 

 Point to the Edit menu and drag down to High Calibration…. 

 Choose Edit High Calibration… (ALT, E, H) 
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  When selected, the High Calibration dialog box is displayed on the screen: 
 

 
 
  Again the insertion point appears behind the value in the High Cal Value text box. This insertion point 

indicates the active area of the dialog box—the next action you perform will occur in this area. This is 
where you enter the high calibration data value that is to be assigned to the input voltage level. For 
instance, referring back to our previous examples: 

 
  a) For the case where the transducer output is known, we would enter “100” in the High Cal Value text 

box, “4.5” in the Input Level text box, and “PSI” in the Engr. Units text box. 
 
  b) For the case where the transducer output is unknown, we would also enter “100” in the High Cal 

Value text box, ignore the Input Level text box (WINDAQ/Tach has established the input voltage level 
for you), and enter “PSI” in the Engr. Units text box.  

 
  Again you use the TAB key to position the insertion point in the various text boxes. 
 
  Type up to a four character optional engineering unit tag (i.e., PSI, f/s, rpm, etc.). 
 
 2. Complete the high calibration entry as follows: 

 Click OK. 

 Press the TAB key until a bold border surrounds the OK command button (indicating  
 selection) and press ENTER. 

 
The High Calibration dialog box disappears and the waveform channel displays all waveform data values calibrated 
in the chosen engineering units.  
 
If desired, the upper and lower grid limit values may be specified (and the waveform automatically scaled to fit). 
This feature allows the channel's full scale display span to be shown in whole numbers rather than obscure fractional 
values, which sometimes result from calibrating. For example, a waveform scaled in mmHg can be automatically 
expanded or contracted to fit within grid limits of 0 to 100 mmHg, or -200 mmHg to +200 mmHg, or whatever is 
desired. Note that a channel spanning 0 - 200 mmHg is much easier to read and interpret on a per division basis than 
one that spans 10.372 - 189.628 mmHg.  
 
To specify convenient upper and lower chart edge values: 
 1. Select Scaling Limits… as follows: 

 Point to the Scaling menu and drag down to Limits…. 

 Choose Scaling Limits… (ALT, C, L). 
 
  When selected, the Display Limits dialog box is displayed on the screen as follows: 
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 2. Using the same procedure as before, type convenient top and bottom chart-edge values in their 
respective text boxes. 

 
The Next and Previous command buttons allow you to step through all of the enabled channels in order, entering 
the desired display limits for each channel, without closing this dialog box. Note that when either the Next or 
Previous button is activated, the channel number in the title bar of the dialog box changes to indicate the channel 
for which you are currently setting display limits. 
 
 3. Complete the chart-edge value entry as follows: 

 Click OK. 

 Press the TAB key until a bold border surrounds the OK command button (indicating  
 selection) and press ENTER. 

 
Your specified values will now be displayed on the upper and lower chart-edges and the waveform will be 
automatically scaled to fit the new values. 
 
SPECIAL CONSIDERATIONS 
The value of engineering units may range from 1.0 E+32 to 1.0 E-32. 
 
EXAMPLE 
 
Accelerator key Version 
 
KEYSTROKE COMMENTS 
1 Select the window to receive engineering unit data. 
F11 Prepare to enter high calibrator value. 
500 Enter high calibrator value. 
F9 Prepare to enter low calibrator value. 
-500 Enter low calibrator value. 
o F (degrees Fahrenheit) Enter engineering unit tag. 
ENTER Complete the high/low calibration entries. 
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WAVEFORM COMPRESSION FUNCTION 
 
FUNCTION 
Allows you to vary the number of data points that are used to display the real time waveform on your computers 
screen. Increasing the compression factor causes the display to plot less often, which results in a slower real time 
display (the waveform is being displayed at a fraction of the selected sample rate).  
 
It should be noted that this function is simply a “graphics adjuster” that only affects how the display looks on your 
screen. Data acquired to disk is independent of this function and is always acquired continuous (gap-free) at a 
compression factor of 1 (meaning no compression applied). 
 
Plotting or displaying the waveform data on your computer’s monitor is the most time consuming task 
WINDAQ/Tach is burdened with. The plotted waveform you see on your monitor is a compilation of many vertical 
line segments drawn adjacent to each other. The length and position of each vertical line segment drawn on the 
screen is a function of the data points or A-D readings being acquired. During the plotting process (in a much 
simplified overview) previous and current A-D readings are evaluated. These evaluations eventually define the end-
points of what will be a vertical line segment. Once the end-points are defined, a vertical line is drawn to connect 
them. It is this line segment (and many more just like it drawn adjacent to each other on the screen) that eventually 
produces a real time waveform display.  
 
When compression equals 1 (no compression applied to the waveform), every single A-D reading is plotted. The 
majority of CPU time is devoted to the display of data on your screen. As you might have guessed, that can be an 
overwhelming task for your computer when a high sample rate (i.e., 50,000 samples per second) is selected. This is 
the disadvantage of an uncompressed waveform; at higher sample rates, the real time display cannot plot the A-D 
evaluations as fast as the CPU is supplying them, resulting in a fast, jerky display, showing only choppy, 
intermittent waveform information. 
 
When compression is applied to the waveform, multiple A-D readings (equal to the compression factor) are 
evaluated to define the end-points of a line segment. In this instance, less CPU time is required for the display. For 
example, if compression equals 100, then 100 consecutive A-D readings are evaluated to define the end-points of a 
line segment. The advantage of compression is that you are essentially plotting less often, resulting in a slower real 
time display, which smooths the display and allows you to see the characteristics of the waveform making it more 
visually pleasing.  
 
When compression is selected, a true min/max is performed on the waveform to ensure that transient information is 
always displayed. 
 
 
ACTIVATING PROCEDURE 
The degree of waveform compression is controlled as follows: 
 

 Click the Waveform Compression button in the ToolBox. 
 

 Point to the Edit menu and drag down to Compression… 
OR 

 Double-click on the Compress(F7): field in the status bar. 
 

 Choose Edit Compression… (ALT, E, R). 
 
This displays the Compression dialog box as follows: 
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When the Compression dialog box is first displayed, a blinking vertical line (called the insertion point) appears 
behind the number in the Desired Compression text box. This insertion point indicates the active area of the dialog 
box—the next action you perform will occur in this area. To specify a degree of waveform compression: 
 

 Enter the desired compression factor (from 1 to 65,536) and click OK.  

 Enter the desired compression factor (from 1 to 65,536) and press ENTER.  
 
The amount of compression you choose will depend on many factors and will probably include some trial and error 
to arrive at the compression factor that satisfies all of your conditions. As a starting point, select a compression 
factor that delivers the most pleasing waveform display. Refer to Appendix A for more information about how 
compression affects multitasking. 
 
A fast and convenient way to experiment with many different compression factors is with the Compression x2 and 
Compression /2 commands. These commands respectively multiply or divide the current compression factor by 2.  
 
To multiply the current compression factor by 2: 

 Point to the Edit menu and drag down to Compression x2.  

 Choose Edit Compression x2 (ALT, E, S).  
 
Similarly, to divide the current compression factor by 2: 

 Point to the Edit menu and drag down to Compression /2.  

 Choose Edit Compression /2 (ALT, E, E).  
 
Perhaps these two functions are most useful when the accelerator keys (PGUP for Compression x2 and PGDN for 
Compression /2) are used. This allows you to press one key several times in succession to find just the right amount 
of compression for a smooth scrolling, visually pleasing display. 
 
SPECIAL CONSIDERATIONS 
A compression factor represents the number of waveform values for each enabled channel that are evaluated for 
minimum and maximum line segment end points before plotting. For example, if the compression factor is set to 
100, one vertical line is plotted every 100 acquired data points (for each channel). 
 
Waveform compression affects the real time waveform display only. Data streamed to disk is unaffected and is 
always stored at a compression factor of 1. 
 
As the waveform compression factor is changed, the time base field (ms /DIV: or sec /DIV:) displayed in the bottom 
annotation line is automatically adjusted to reflect the proper time scaling of displayed waveforms. 
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KEYSTROKE EXAMPLES 
Assumes an initial compression of 1 (uncompressed). 
 
KEYSTROKE COMMENTS 
F7 Display the compression dialog box. 
 
2 Specify a compression factor of 2. 
 
ENTER Apply the specified compression factor to the display. 
 
PGUP Multiply the current compression factor by 2. 
 
PGDN Divide the current compression factor by 2. 
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WAVEFORM DISPLAY SCALING AND OFFSET 
 
FUNCTION 
Used to dynamically scale or offset a specified channel's waveform on the real time display. 
 
ACTIVATING PROCEDURE 
A channel must first be selected for scale and offset operations. When selected, the X=Y annotation in the right or 
left annotation margin will be highlighted, indicating window X is enabled for scale and offset adjustments. 
 
Expanding the Specified Waveform 

 Click the Expand Waveform 2x button in the toolbox. 
 

 Point to the Scaling menu and drag down to Grow 2X. This expands the specified waveform two times its 
original size in the amplitude direction. 

 
OR 

 
 Point to the right or left annotation margin and click the left mouse button. This also expands the specified 

waveform two times its original size in the amplitude direction. 
 

OR 
 

 1. Drag in the waveform strip area to draw a selection rectangle. The selection rectangle is used to 
expand the waveform to a specific size in the amplitude direction (within the limits defined by the A/D 
converter). The top and bottom edges (or the “vertical limits”) of the selection rectangle will dictate 
the amount of waveform expansion. 

 
 2. Click the left mouse button in the right or left annotation margin. The waveform will be expanded to 

full strip size with the “vertical selection rectangle limits” now defining the ±full scale values for the 
waveform. 

 

 Choose Scaling Grow 2X (ALT, C, G). This expands the specified waveform two times its original size in 
the amplitude direction.  

 
Contracting the specified waveform 

 Click the Shrink Waveform 2x button in the ToolBox. 
 

 Point to the Scaling menu and drag down to Shrink 2X. This contracts the specified waveform one-half its 
original size in the amplitude direction. 

 
OR 

 
 Point to the right or left annotation margin and click the right mouse button. This also contracts the 

specified waveform one-half its original size in the amplitude direction. 
 

OR 
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 1. Drag in the waveform strip area to draw a selection rectangle. The selection rectangle is used to 
contract the waveform to a specific size in the amplitude direction (within the limits defined by the 
A/D converter). The top and bottom edges (or the “vertical limits”) of the selection rectangle will 
dictate the amount of waveform contraction. 

 
 2. Click the right mouse button in the right or left annotation margin. The waveform in the strip will be 

shrunk to fit within the “vertical limits” of the selection rectangle.  
 

 Choose Scaling Shrink 2X (ALT, C, S). This contracts the specified waveform one-half its original size in 
the amplitude direction.  

 
Moving the specified waveform down in the strip 

 Click the Shift Waveform Down button in the ToolBox. 
 

 Point to the Scaling menu and drag down to Waveform Down 1 Pixel or Waveform Down 10 Pixels. 
Waveform Down 1 Pixel moves the specified waveform down a single pixel in the strip and Waveform 
Down 10 Pixels moves the specified waveform down 10 pixels in the strip. 

 
OR 

 
 1. Drag in the waveform strip area to draw a selection rectangle around a portion of the waveform. The 

size of the selection rectangle does not matter, it is merely used to represent the current horizontal 
position of the waveform on the screen. 

 
 2. With the mouse pointer positioned inside the selection rectangle, drag the selection rectangle “down” 

to move the specified waveform down in the strip to the desired position (within the limits defined by 
the A/D converter).  

 

 Choose Scaling Waveform Down 1 Pixel or Scaling Waveform Down 10 Pixels (ALT, C, O, or ALT, C, D, 
respectively). Waveform Down 1 Pixel moves the specified waveform down a single pixel in the strip and 
Waveform Down 10 Pixels moves the specified waveform down 10 pixels in the strip.  

 
Moving the specified waveform up in the strip 

 Click the Shift Waveform Up button in the ToolBox. 
 

 Point to the Scaling menu and drag down to Waveform Up 1 Pixel or Waveform Up 10 Pixels. Waveform 
Up 1 Pixel moves the specified waveform up a single pixel in the strip and Waveform Up 10 Pixels moves 
the specified waveform up 10 pixels in the strip. 

 
OR 

 
 1. Drag in the waveform strip area to draw a selection rectangle around a portion of the waveform. The 

size of the selection rectangle does not matter, it is merely used to represent the current horizontal 
position of the waveform on the screen. 

 
 2. With the mouse pointer positioned inside the selection rectangle, drag the selection rectangle “up” to 

move the specified waveform up in the strip to the desired position (within the limits defined by the 
A/D converter).  
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 Choose Scaling Waveform Up 1 Pixel or Scaling Waveform Up 10 Pixels (ALT, C, P, or ALT, C, U, 
respectively). Waveform Up 1 Pixel moves the specified waveform up a single pixel in the strip and 
Waveform Up 10 Pixels moves the specified waveform up 10 pixels in the strip.  

 
SPECIAL CONSIDERATIONS 
As a scaling or offset operation is performed on any given channel, the channel’s annotated ± full and base line 
values will automatically adjust to reflect the operation. 
 
Scaling and offsetting data does not, in any way, affect the information stored to disk. These operations are only 
provided to configure the real time display. 
 
EXAMPLE 
Accelerator key Version (Assumes eight waveform channels are available) 
KEYSTROKE ONE KEYSTROKE TWO COMMENT 
1 ↑  Expand window one's waveform 2X original size. 
 
 ↓ Contract window one's waveform by a factor of 2. 
 
 CTRL+Gray- Move the waveform in window one down 10 pixels. 
 
 Gray+ Move the waveform in window one up 1 pixel. 
 
4 Gray- Move the waveform in window four down 1 pixel. 
 
5 ↓  Contract window five's waveform by a factor of 2. 
 
8 CTRL+Gray+ Move the waveform in window eight up 10 pixels. 
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