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WAVEFORM PLAYBACK AND ANALYSIS
USING WWB/Tach
GENERAL
The WINDAQ Waveform Browser for Tachometer Applications allows you to review, examine, and otherwise
analyze waveform data previously recorded to disk with WINDAQ/Tach waveform recording software, or any
hardware/software package capable of storing data in the CODAS data storage format.
Using the WINDAQ Waveform Browser for Tachometer Applications (WWB/Tach), you will be able to perform the
following functions:
• Retrieve a data file and examine its contents by moving the waveforms in either a positive or negative time
direction (i.e., right-to-left, or left-to-right). Waveforms may be smooth scrolled (panned) across the screen to
achieve maximum waveform continuity, or paged in a manner that allows the entire screen to be updated one
screen width at a time.
• Enable a cursor allowing you to measure the value at any point on the waveform.
• Measure time differences between two points on the same or different waveforms.
• Copy and paste (export) waveforms from the original data file to a separate data file for more detailed analysis.
• Select a specific file conversion format that will allow other software-based analysis packages such as Lotus 1-2-3,
ASYSTANT and ASYST to read the data.
• And much, much more.
This manual covers WWB/Tach software for Windows™ and is intended for users of all proficiency levels. The
reference information at the beginning describes how to start the WWB/Tach, what you will see when in
WWB/Tach, and how to navigate within WWB/Tach. After the reference information, each command or function is
described in detail.
To help you find the information you want, the reference information contains a menu hierarchy with page
references. Also included is a chart showing which command is located on what menu.
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REFERENCE INFORMATION
CONVENTIONS USED IN THE DOCUMENTATION
Before you start using WWB/Tach, it’s important to understand the terms and notational conventions used in this
documentation.
General Conventions
• Commands you choose are given with the menu name preceding the command name. For example, the phrase
“Choose File Open” tells you to choose the Open command from the File menu. This naming convention
describes the sequence you follow in choosing a command — first you select the menu, then you choose the
command.
• Whenever possible, WWB/Tach functions are presented with both mouse and keyboard procedures. When
separate mouse and keyboard procedures are listed for a function, you can identify each procedure by the
mouse or keyboard icon. The mouse icon represents procedures that are accomplished using the mouse and
the keyboard icon represents procedures that are accomplished using the keyboard.

Mouse icon

Keyboard icon

Mouse Conventions
In general, most WWB/Tach mouse actions require only the left mouse button. For example, selecting a command
from a menu or working in a dialog box requires only the left mouse button. However, the right mouse button is not
totally neglected. Among other things, the right mouse button is used for waveform scaling, selecting a waveform
channel, centering the cursor on the screen, and moving the horizontal crosshair on a spectrum plot (when using
FFT analysis).
Since the majority of mouse procedures are done with the left mouse button, we will not specify which mouse
button to click, drag, or double-click with in the procedures unless it is the right mouse button. When the right
mouse button is required, it will be specified as such. For example, “Double-click the right mouse button anywhere
in the bottom annotation line to move the cursor to the lowest displayed waveform valley.” When not specified, the
left mouse button is assumed for the procedure.
•

“Point” means to position the mouse pointer until the tip of the pointer rests on what you want to point to on
the screen. For example, “Point to the View menu.”

•

“Click” means to press and immediately release the mouse button without moving the mouse. For example,
“To display the menu that contains the command you want, click the menu name in the menu bar.”

•

“Double-click” means to click the mouse button twice in rapid succession. For example, “Double-click the
WWB/Tach icon to start the WWB/Tach package.”

•

“Drag” means to press the mouse button and hold it down while you move the mouse; then release the
button. For example, “Drag down to Data Cursor to enabled the cursor for on-screen display.”

Keyboard Conventions
• Key names match the names shown on most keyboards and appear in capital letters. For example, the Shift
key appears as SHIFT.
•

A plus sign (+) used between two key names indicates that you must press both keys at the same time. For
example, “Press SHIFT + F1” means that you press the SHIFT key and hold it down while you press the F1
key.
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•

A comma (,) between two key names indicates that those keys must be pressed sequentially. For example,
“Press ALT, F, O” means that you press the ALT key and release it, press F and release it, and then press O and
release it.

•

The keys that you use to move around in WWB/Tach are referred to as cursor control keys; they include the
↑, ↓, ←, and → keys, HOME, END, PG UP, and PG DN.

CONVERTING FOREIGN DATA FILE FORMATS
WWB/Tach contains a file conversion utility that allows you to convert other data files to the CODAS data format.
This enables data files from other sources such as ASYSTANT, DADiSP, IOtech, or any spreadsheet program to be
viewed and/or otherwise analyzed in WWB/Tach.
The convert program (hereafter referred to as CONVERT) is a DOS utility that can be executed from within the
WWB/Tach by choosing File Open and entering the input file (or non-CODAS file you wish to convert) in the
Filename: text box. Make sure the proper input file format is selected from the list on the right side of the dialog
box and choose SAVE.
When an input file is entered, the Convert Output Open dialog box is displayed, prompting you to select the proper
input file format and specify an output file name. We recommend using the same file name as the input but with a
different extension, like .WDQ to indicate that the original file has been converted to a WWB/Tach file. When an
output file name has been specified and the proper input file format is selected, choose SAVE.
After some initial file identification, CONVERT prompts you for details about the file you are converting. These
details consist of: the number of channels in the file, the sample rate, the ± full scale channel values, and the units
specified per channel. Not all conversions will require that you input every one of these parameters. For example, if
you are converting a DADiSP floating point file, you will not have to enter any of these parameters since this
information is already contained in the DADiSP file header and therefore readily available for CONVERT to use.
You will be prompted for these parameters only when they are not available in the original file. The following table
shows the parameters for which CONVERT will prompt, depending on the type of file you are converting:
# of Channels in File
No
No
No
Yes
No
No
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

Sample Rate
*
*
*
Yes
No
No
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

Yes

Yes

±Full Scale Values
No
Yes
No
No
No
Yes
Yes
Yes
Yes
Yes
No
No
Yes
Yes
Yes
Yes

Units
Yes
Yes
Yes
Yes
No
#
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

No

Yes

*prompts if no sample rate has been entered in the original file.
#prompts if no units have been entered in DADiSP.
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File Type
ASYST(ANT) or EASYEST LX/AG real
ASYST(ANT) or EASYEST LX/AG integer
SPREADSHEET print file
ASCII single line
DADiSP float
DADiSP integer
IOtech binary (without header)
Raw binary integer 14 msb and event marks
Raw binary single precision integer - 2 bytes
Raw binary double precision integer - 4 bytes
Raw binary single precision real - 4 bytes
Raw binary double precision real - 8 bytes
Raw binary signed byte - 1 byte
Raw binary unsigned byte - 1 byte
Raw binary unsigned word - 2 bytes
LabVIEW binary single precision integer - 2
bytes
LabVIEW binary single precision real - 4
bytes
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Instructions for entering values and moving between fields are displayed onscreen. It is important to enter the same
values from the original file to ensure an accurate conversion. When the necessary parameters have been entered,
press ENTER to accept and convert the data file. When the file has been successfully converted, it will be displayed
on your screen in WWB/Tach ready for review.
STARTING THE WWB/Tach PACKAGE
To start WWB/Tach, you must first start Windows. From Windows, use the mouse to double-click on the
WWB/Tach icon, or use the cursor keys to highlight the WWB/Tach icon and then press ENTER. This displays the
following window:

The Open window prompts you for the file name of the data file you wish to review. Data file names may assume
any type that is compatible with PC- or MS-DOS including paths. When a valid file name is selected from the list
box or input in the Filename: text box, WWB/Tach will present the file in its own window, with the initial default
settings enabled (assuming the default settings have not been changed from the data acquisition package). When
the file is initially opened, the default settings are as follows:
1.

Display format 1 enabled.

2.

Acquired logical channel 1 displayed.

3.

Waveform data annotation off.

4.

Waveform cursor disabled.

5.

Distance to Beginning of File (DBF:) annotation off.

6.

Distance to Marker (DM:) annotation off.

7.

Distance to End Of File (% EOF:) annotation off.
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THE WWB/Tach WINDOW
The typical WWB/Tach window consists of six fundamental components: the title bar, menu bar, left/right
annotation margin, waveform strip, bottom annotation line, and the horizontal scroll bar. These components are
shown in the following illustration.

Before we examine each component of the WWB/Tach window in detail, we will describe some basic skills that will
help you navigate within or otherwise work with windows. WWB/Tach works exactly like those of most Windows
applications. If you’ve worked with Windows applications before, much of this material will already be familiar
to you.
As you can in any Windows application, you can open several WWB/Tach windows, or you can open other
applications in separate windows outside of the WWB/Tach window. However, you can work in only one window at
a time. The window in which you are currently working is called the active window—the very next command or
action you perform occurs in this window. You use either the mouse or the keyboard to scroll through, switch
between, size, move, or close windows.

Title bar:

The title bar has two purposes: it identifies a file through the file name and it serves as a visual cue
that the window may be moved or manipulated. The title bar consists of three parts: the system menu
icon, the window title, and the window sizing icons.
System menu icon

Window title

Window sizing icons

System menu icon: The system menu icon can be selected to display a pull-down containing
commands for moving, sizing, and closing windows on the screen. You can use either the mouse or
the keyboard to size and move a window, but because of the many mouse shortcuts built into the
WWB/Tach program, the mouse is faster and easier. For example, moving the window by dragging
with the mouse is a much faster alternative to selecting the Move command from the system menu,
repositioning with the arrow keys, and then pressing the ENTER key. Whenever applicable, the
mouse shortcuts are included in the system menu command descriptions that follow. The commands
are: Restore, Move, Size, Minimize, Maximize, Close, Switch To…, and Always on Top (Windows
version 3.1 only).
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•

Restore returns the window to the size it was and the position it was in prior to a Maximize or
Minimize action. Clicking the Restore window sizing icon also accomplishes a Restore
action.

•

Move allows you to move or reposition the window to any location you want on the screen.
Dragging with the mouse positioned anywhere in the title bar also accomplishes a Move
action.

•

Size allows you to change the size and shape of the window by moving each of the window
borders. Dragging with the mouse positioned anywhere along the window edge (including
corners) also accomplishes a Size action.

•

Minimize removes from the screen all windows associated with the active window and shrinks
the active window to an icon. This command is useful when you’re using two or more
windows at the same time. You are now free to move this minimized icon if desired. To restore
the minimized icon, simply double-click the icon or choose Restore from the system menu.
Clicking the Minimize window sizing icon also accomplishes a Minimize action.

•

Maximize enlarges the window to the largest possible size, the size of the screen. Clicking the
Maximize window sizing icon or double-clicking anywhere in the title bar also accomplishes
a Maximize action.

•

Close removes the window and all associated windows from the screen. Closing has the
potential to lose unsaved changes, therefore, the Close action also displays several save
options. Double-clicking the system menu icon also accomplishes a Close action.

•

Switch To… forces the appearance of a task list that contains a list of all active applications
and several options for these applications.

•

Always on Top (available with Windows version 3.1 only) allows the WWB/Tach window
to remain displayed on top of the Windows working environment even though a different
window is active. When this feature is enabled, the WWB/Tach window is always in sight
even though you may be working in a different window. A checkmark (√) appears before this
command on the system menu when enabled.

Window title: The window title contains the WWB/Tach utility name and the currently active data file
name.
Window sizing icons: The window sizing icons provide a fast, convenient way to use the mouse to
select three of the system menu actions: Minimize, Maximize, and Restore. Selecting one of these
icons with the mouse performs that action, which is identical to selecting it from the system menu.

Minimize
Menu bar:

Maximize

Restore

Like other Windows applications, WWB/Tach contains a menu bar. The commands available in
WWB/Tach are grouped on menus. These menus appear in the bar across the top of the window and
represent the heart of the package.

With these menus you can apply the powerful waveform review and editing capabilities of
WWB/Tach. To choose a command from a menu, you can either point to the desired menu and click,
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or press the ALT key and then the underlined letter of the desired menu. This causes the commands
available on that menu to be “pulled down” or displayed. Once displayed, the commands on the pulldown menu can be chosen (and thus performed) by clicking on the desired command or by pressing
the underlined letter in the desired command. Also provided on the pull-down menus are keyboard
shortcuts or accelerators. Accelerators are function keys or combinations of keys displayed next to
the menu item that when pressed, immediately invokes the desired action. This lets you bypass the
pull-down menus and carry out commands directly from the keyboard, a time-saving feature when
processing repetitive tasks. Refer to the WWB/Tach Menu Hierarchy for a listing of accelerators.
Refer to the WWB/Tach Pull-Down Menus chart for a “roadmap” of command locations.
When you choose a command that is followed by an ellipsis (…), WWB/Tach displays a dialog box
indicating that more information must be entered or an option must be selected before the command
can be carried out.
Some command names occasionally appear dimmed. This indicates that the command does not apply
to the current situation or that you may need to make a selection or complete an action before
choosing the command.
Left/Right
annotation
margin

The left and/or right annotation margin has three purposes: it can be used for waveform strip
selection, it can be used with the mouse to scale the displayed waveform, and it displays the
numerical values of the waveform.
When more than one waveform is displayed on the screen, clicking the left mouse button in the
unselected strip’s annotation margin selects that strip.
Clicking the left mouse button in the annotation margin of a selected strip doubles the vertical size
of the waveform. Conversely, clicking the right mouse button in the annotation margin of a selected
strip reduces the vertical size of the waveform by one half.
Clicking the right mouse button in the annotation margin of an unselected strip starts a graphic
selection rectangle, which is used by the Edit Copy or File Print commands.
A selection rectangle can also be used with the annotation margins to scale the waveform. For
example, if you wanted to examine a small section of waveform in greater detail, it is possible to fill
the entire strip with the small section of waveform. This is done by drawing a selection rectangle and
then clicking the left mouse button in the annotation margin. A selection rectangle is drawn by
dragging anywhere in the strip until the area of interest is enclosed in the rectangle. When the left
mouse button is released, the rectangle remains on the display framing the area of interest. Now click
the left mouse button in the annotation margin to enlarge the contents of the selection rectangle to
full strip size. Conversely, the entire waveform can be shrunk to fit inside a similarly drawn rectangle
using the right mouse button.
The left annotation margin is displayed whenever a non-overlapped screen format is selected, and
both the right and left annotation margins are displayed when an overlapped screen format is
selected. The information displayed in either margin is identical in format and consists of three parts:
the variable waveform assignment indicator, the value of waveform at cursor/baseline intersection,
and the ±full scale values for the waveform strip.
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Value of waveform at cursor/baseline
intersection

±Full scale values for
waveform strip
Variable waveform
assignment indicator
Non-overlapped screen format

Overlapped screen format

Variable waveform assignment indicator: The variable waveform assignment indicator allows any
valid waveform channel to be assigned to a specific strip. The highlighted box surrounding the X=Y
annotation indicates that the strip is selected, and the waveform contained in the strip can be scaled,
offset, or otherwise adjusted.
Value of waveform at cursor/baseline intersection: When the data cursor is enabled for display, the
waveform value at the point of waveform/cursor intersection is displayed. When the data cursor is not
displayed, the waveform value at the point of waveform/baseline intersection is displayed.
±Full scale values for the waveform strip: These values indicate the ±full scale values of the
waveform strip. If desired, these values may be specified and the waveform will be automatically
scaled to fit the new values. This is useful for displaying the waveform strip in whole numbers (e.g., 0
- 200 mmHg instead of 10.372 - 189.628 mmHg).
Waveform
strip:

Bottom
annotation
line:

The waveform strip area is where the recorded waveform information is replayed. Waveform
information recorded during data acquisition is streamed from disk and displayed on the monitor in
graphical form for review. In this area, you can expand or contract the amplitude of the selected strip,
make cursor-oriented distance and amplitude measurements, compress the waveform so it can be
displayed in its entirety on the screen, overlap waveforms to examine how they correlate, perform
event mark searches, display up to 29 waveforms at once, and much more.

The bottom annotation line serves two purposes: it contains the waveform measurement displays, and
when used with the mouse, controls cursor motion and peak/valley searches.
Clicking the left mouse button anywhere in the bottom annotation line moves the data cursor to the
position of the mouse pointer. If the data cursor is not enabled for display, clicking the left mouse
button anywhere in the bottom annotation line displays the data cursor.
Dragging with the mouse positioned anywhere in the bottom annotation line moves the cursor to the
desired position, simultaneously updating the data display.
Double-clicking the left mouse button anywhere in the bottom annotation line moves the data cursor
to the highest peak of the waveform displayed on the screen or to the highest peak within the limits
of a selection rectangle, if drawn.
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Clicking the right mouse button anywhere in the bottom annotation line automatically centers the
data cursor on the screen.
Double-clicking the right mouse button anywhere in the bottom annotation line moves the data
cursor to the lowest valley of the waveform displayed on the screen or to the lowest valley within the
limits of a selection rectangle, if drawn.
The bottom annotation line consists of five elements: the cursor mode indicator, the live display
field, the marker display field, the distance-to-end-of-file function, and the distance reference
function.

Cursor mode indicator: The cursor mode indicator displays the mode of the waveform value
annotation. When baseline-oriented waveform data is enabled (accomplished by disabling the data
cursor from the Options menu), the cursor mode indicator displays BASE. When cursor-oriented
waveform data is enabled, the cursor mode indicator displays DATA (assuming the waveform
compression factor is 1). If the waveform is compressed, the mode indicator will display MID, MIN,
MAX, or MxMn, depending on the chosen method of line segment reporting. Refer to the
WAVEFORM COMPRESSION - FILE or WAVEFORM COMPRESSION - SIGNAL functions in this
chapter for more details.
Live display field: The live display field reports waveform information in one of four selectable data
display formats. As the waveform is panned across the screen (or as the cursor is moved), the selected
display format is constantly updated to provide a “live” readout. The display formats are as follows:
• Distance from beginning of file (DBF): Shows the elapsed distance (in millimeters) from the current
cursor position to the beginning of the data file.
• Difference from distance marker point (DATA-DM): Shows the difference in waveform values
between the distance marker position and the current cursor position.
• Percent change from distance marker point (%CHANGE): Shows the percent change in waveform
values between the distance marker position and the current cursor position.
• Slope of line to distance marker point (SLOPEDM): Shows the slope of an imaginary line formed
by connecting the waveform value at the distance marker position with the waveform value at the
current cursor position.
Marker display field: The marker display field reports the data lying between the distance marker and
current cursor position in one of four selectable distance-related formats:
•

Distance from marker (DM): Displays the distance (in millimeters) from the cursor position to the
distance marker.

•

Samples from marker (SMP): Displays the number of samples (or data points) in the section of
waveform defined by the positions of the distance marker and cursor.

•

Cycles/M for Cycle to Marker: Displays a frequency (in cycles per meter) for the section of
waveform defined by the distance marker and cursor.
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•

Cycles/KM for Cycle to Marker: Displays a frequency (in cycles per kilometer) for the section of
waveform defined by the distance marker and cursor.

Distance-to-end-of-file function (%EOF): The distance-to-end-of-file function indicates your current
position in the data file (expressed as a percentage) with respect to the end of the file.
Distance reference function: The distance reference function provides a distance reference for the
waveform in one of four selectable formats:

Horizontal
scroll bar

•

Start time (S): Displays the date and time the file was opened, thus beginning acquisition.

•

End time (E): Displays the date and time the file was closed, ending acquisition.

•

Distance/division (T): Displays the distance (in meters) per screen grid division.

•

Cursor distance (C): Displays the date and distance for the cursor position.

The horizontal scroll bar controls horizontal waveform motion. With it, you can move from one part of
the waveform file to another.
Click this area to scroll one screen width at a time.
Drag slider box to scroll long distances.

Click scroll arrows to scroll 16 pixels at a time.

Smooth scrolling (panning) or paging of waveforms in either a right-to-left (positive time) or left-toright (negative time) direction are possible in WWB/Tach.
For optimum scrolling speed, ensure that the window WWB/Tach software occupies is positioned
entirely on the screen. If a portion of the currently active window is hidden offscreen, scrolling speed
is dramatically reduced. For best scrolling speed results, position (or resize) the active window so it is
contained entirely onscreen.
The keyboard’s number lock (NUM LOCK) function must not be enabled when waveform scrolling is
activated.
Using a floppy disk-based data file as opposed to a hard disk-based file will adversely affect the
maximum speed of waveform travel in either direction.
To achieve maximum waveform scrolling speed for your particular computer, copy the file to hard
disk. If you do not have a hard disk, copy the data file to virtual disk and specify the virtual disk’s
“drive” letter when invoking the WWB/Tach. Refer to the VDISK command of your computer’s DOS
manual (version 3.0 or greater) for full VDISK details.
The position of the slider box within the scroll bar serves as a rough guide to the position of the
window relative to the rest of the waveform file. If the window is revealing a section of waveform
one-third of the way from the beginning of the waveform file, the slider box will be about a third of
the way from the left end of the scroll bar.
Dragging the slider box selects the desired position in the file, simultaneously updating the DBF,
DM, and %EOF functions (if enabled). This action is useful for scrolling long distances.
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Clicking the left or right scroll bar arrow scrolls the waveform 16 pixels. Clicking and holding (but
not dragging) in either scroll arrow repeats the scrolling action until the beginning or end of the file
is reached. Pressing ALT + left or right scroll arrow activates the automatic scrolling mode. The
waveform file will automatically scroll in the chosen direction, without any user intervention, until
the end (or beginning) of the data file is reached or any other key is pressed. For optimum scrolling
speed, ensure that the window is positioned entirely on the screen. Note that if a portion of the
currently active window is hidden offscreen, scrolling speed is dramatically reduced. For best
scrolling speed results, position (or resize) the active window so it is contained entirely onscreen.
To scroll by less than 16 pixels, drag the cursor (by positioning the mouse in the bottom annotation
line) to the desired point. If desired, this new position can be centered on the screen by pressing the
gray star key (*) on the numeric keypad with the SCROLL LOCK feature enabled.
Clicking anywhere in the horizontal scroll bar on either side of the slider box scrolls the waveform
one screen width toward the beginning or end of the data file. The mouse button can be held down to
scroll rapidly until the slider box reaches the mouse pointer.
The split bar appears at the left end of the horizontal scroll bar. The split bar allows you to adjust the
size of the split between the top and bottom screen sections or panes. These panes are used with the
Transform function and allow you to adjust the amount of screen space devoted to the Fourier
Transform. When the mouse pointer is positioned anywhere inside the split bar, the mouse pointer
takes on a different shape, indicating you can drag with the left mouse button to adjust the size of the
horizontal panes.
Split bar
(point here)
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WORKING IN A DIALOG BOX
When you choose a command that has options, WWB/Tach displays a dialog box. A dialog box may include areas
in which you enter text or numbers and view or change settings for options related to the command. Or it may
simply display additional information or a request for confirmation.
A command name followed by an ellipsis (…) on a menu indicates a dialog box will be displayed after you choose
that command. For example, the following illustration shows the Save As dialog box that appears when you choose
the File Save As… command. This dialog box contains most of the elements found in dialog boxes.
A dotted box around a dialog box item is called the selection cursor; it indicates the active area of the dialog
box—the next action you perform occurs in this area. When you move to an area in which you enter text or
numbers, the active area is shown by a blinking line called the insertion point.
Some dialog box options occasionally appear dimmed. This indicates that the option does not apply to the current
situation or that you may need to make a selection or complete an action before selecting the option.

•

List box - A list of available choices for the command. You can scroll through the list to see additional
choices. You can scroll quickly to the item you want by pressing the key for its first letter when the list box
is active. The list box scrolls to the first item starting with that letter. If there is more than one item
beginning with that letter, you can press the letter key again to see each of those items.

•

Text box - A box in which you type information (text or numbers) needed to carry out the command.

•

Option button - One of a group of related options; you can select only one option in a group at a time.
When an option is selected, a black dot appears in the small round button.

•

Check box - An option that can be turned on or off. Unlike option buttons, you can turn on as many check
boxes as you want. When a check box is turned on, an X appears in the box.

•

Command button - A rectangular button labeled with the action it carries out. A bold border indicates that
the command button is the default and will be chosen automatically if you press ENTER.
You choose a command button to carry out the command, cancel the command, or display more options. In
most cases, OK is the default button and choosing OK closes the dialog box and carries out the command.
Choosing Cancel closes the dialog box and cancels the command; WWB/Tach ignores any changes you
made in the dialog box.
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MOVING AND SELECTING IN A DIALOG BOX
The following illustration shows how to use the mouse to move around and select options in a dialog box:

You can also use the following mouse techniques to move and select in a dialog box:
•

Double-click a list item to select the option and carry out the command.

•

Click the check box label to turn it on or off, or click the option button label to select it.

The following illustration shows how to use the keyboard to move around and select options in a dialog
box:
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You can also use the following keys to move around and select options in a dialog box:
To

Press

Move to the next or previous list box,
text box, check box, command button,
or group of option buttons…

TAB

Select among an active
group of option buttons…

↑, ↓, ←, → keys

Turn an active check box on or off, or
choose the active command button…

SPACEBAR

Move directly to the first item in an active
list box starting with a specific letter and
select that item…

The key for the first
letter of an item.

EDITING IN A TEXT BOX
Some dialog boxes have text boxes in which you type text or numbers needed to carry out the command. What you
type appears to the left of the insertion point, which shifts existing text to the right as you type.
When you want to edit an existing entry in a text box, you must first select the text box. The entire entry in the text
box is highlighted and the insertion point appears at the end of the highlighted text. When you start typing, the
highlighted text is deleted and replaced with what you type.

Use the mouse techniques in the following table to select in a text box. To edit in a text box, use the
techniques shown in the keyboard procedure.
To

Do this

Move insertion point within text box
entry…

Click where you want insertion point

Select or extend selection…

Drag to extend selection
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Use the techniques in the following table to edit in a text box with the keyboard.
To

Press

Move one character left or right; scroll
through text that extends beyond
border of text box…

← or →

Select text as the insertion point moves
to the left or right…

SHIFT+← or SHIFT+ →

Move to beginning of text line…

HOME

Extend selection to beginning of text line… SHIFT+HOME
Move to end of text line…

END

Extend selection to end of text line…

SHIFT+END

Clear character to left of insertion point…

BACKSPACE

Clear character or selection to right of
insertion point…

DEL

DRAWING A SELECTION RECTANGLE
In WWB/Tach, you can draw a graphic selection rectangle and just a plain selection rectangle. A graphic selection
rectangle is used to print a portion of waveform graphics (bounded by the rectangle) or to copy a portion of
graphics onto the clipboard. A selection rectangle is used in conjunction with the mouse to offset and/or scale a
waveform.
Both rectangles are drawn the same way, only the graphic selection rectangle is created with the right mouse button
while the selection rectangle is created with the left.
A graphic selection rectangle is drawn by positioning the mouse pointer anywhere in the waveform strip area and
dragging with the right mouse button until the rectangle encloses the area you wish to print or copy to the
clipboard. When the mouse button is released, the rectangle remains fixed in size. You can now choose Print from
the File menu and select the Graphic Selection Rectangle method from the Print dialog box to print, or choose
Copy from the Edit menu to load the image onto the clipboard.
A selection rectangle is drawn by positioning the mouse pointer anywhere in the waveform strip area and dragging
with the left mouse button until the rectangle reaches the desired size. When the mouse button is released, the
rectangle remains fixed in size. Once a selection rectangle is drawn, several operations become functional,
depending upon where the mouse pointer is positioned (i.e., the left/right annotation line, or the bottom annotation
line) and which mouse button is clicked. The following examples illustrate how the selection rectangle can be used
in typical offsetting and scaling operations.
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Offsetting a Specified Channel’s Waveform

1.

The original waveform. The object is to offset the waveform from its current position to a position centered
on the baseline. Note that the “1=1” annotation in the left annotation margin is highlighted, indicating
window 1 is enabled for adjustments.

2.

Drag the left mouse button to draw a selection rectangle. The size (and placement) of the rectangle is
immaterial. In this example, it was drawn to approximate the vertical limits of the waveform so it could be
accurately centered on the baseline. Note that the rectangle remains fixed in size when the left mouse
button is released.
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3.

With the mouse pointer positioned inside the selection rectangle, drag the rectangle to achieve the desired
offset (in this example, vertically centered on the baseline).

4.

The offset waveform. When the left mouse button was released, the waveform was vertically offset by the
amount the rectangle was dragged (within the limits of the A/D converter). Note the waveform’s numerical
values in the left annotation margin reflect the new position.
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Scaling a Specified Channel’s Waveform

1.

The original waveform. The object is to scale a small section of waveform so it fills the entire strip area,
thus allowing the small section to be examined in greater detail. Again note that the “1=1” annotation in
the left annotation margin is highlighted, indicating window 1 is enabled for adjustments.

2.

Drag the left mouse button to draw a selection rectangle. Once again, the size of the rectangle is
immaterial. In this example, it was drawn on the very tip of the waveform because this is the area of interest
that we would like to examine in greater detail. Note that the rectangle remains fixed in size when the left
mouse button is released.
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3.

The scaled waveform, accomplished by clicking the left mouse button in the left annotation margin. The
contents of the selection rectangle have been scaled to fill the entire waveform strip area.
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WWB/Tach SCREEN COMPONENTS
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WWB/Tach Pull-Down Menus
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WWB/Tach COMMAND HIERARCHY
Menu
File

Command

Command Options

Open…

Accelerator key(s)

Reference

CTRL+O

80

CTRL+S

90
50, 55
n/a
30

CTRL+N
ALT+N
CTRL+P

78
78
83

Save All…
Save Calibration…
Proceed with no save…
Cancel
Save
Save As…
Acquire…†
Calculate…
Save All…
Save Calibration…
Proceed with no save…
Cancel
Note
Commented Note…
Print…
Print Setup…
Exit…

49, 61
Save All…
Save Calibration…
Exit with no save…
Cancel

Edit
Undo
Copy
Low Calibration…
High Calibration…
Fixed Calibration…
Delete Mark
Insert Mark
Clear Marks to DM
Compression…

CTRL+Z
CTRL+C
F9
F11
F12
Delete
Insert
CTRL+SHIFT+E
F7

100
38
34
35
31
48
48
48
36, 65

Assign Channel…
Assign Range…
Forward Range
Backward Range
Format Screen
Statistics…
Channel Settings…
Event Markers…
Next Palette
Previous Palette
User Palette…
Split
Exit

=
:
CTRL+↓
CTRL+↑

29, 65
89
88
88
74
97
36
48
83
83
83
98
63, 67, 98

View

CTRL+T
F10
F8
ALT+P
ALT+SHIFT+P
CTRL+U
CTRL+Y
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Accelerator key(s)

Reference

Y
ALT+Y
ALT+F1
CTRL+F1
F6
SHIFT+F5

98
98
98
98
98
92

Next Mark
Previous Mark
Peak on Screen
Valley on Screen
Go to DM Position
Center Cursor
Go to Range…
Go to Distance…
Autoscroll Right
Autoscroll Left

CTRL+→
CTRL+←
CTRL+K
ALT+K
Gray /
Gray *
CTRL+R
CTRL+SHIFT+T
ALT+→
ALT+←

50
50
43
43
77
43
77
77
29
29

Limits…
Autoscale
Show Dynamic Range
Grow 2X
Shrink 2X
Invert
Waveform Down 1 Pixel
Waveform Down 10 Pixels
Waveform Up 1 Pixel
Waveform Up 10 Pixels
Analog Plot
Digital Plot…

ALT+F9
ALT+A
ALT+R
Up
Down
CTRL+I
Gray CTRL+Gray Gray +
CTRL+Gray +
ALT+SHIFT+N
ALT+SHIFT+T

32, 36
92
98
92
92
80
92
92
92
92
45
45

DFT
Windowed FFT…
Mag Engr Units
Scale DB
Compress FRQ…
Erase Frequency
High-pass Filter
Low-pass Filter
Inverse Transform
Average Power…
Output FRQ Data…

CTRL+F
58, 68
72
71
70
CTRL+E
CTRL+H
CTRL+L
ALT+I
CTRL+A
72

64

Menu
Command
View (Continued)
More Bottom Y
Less Bottom Y
Left Limit
Right Limit
Toggle Pane
Refresh

Command Options

Search

Scaling

Transform
CTRL+W
CTRL+M
SHIFT+F4
CTRL+F3

ALT+D

74
74
74
74
69

XY
Exit/Enter XY
Deltas
Slopes
Area
Adjust Area
Clear Areas

CTRL+X

104
ALT+SHIFT+D
CTRL+SHIFT+S
ALT+F3
SHIFT+F3
CTRL+SHIFT+C
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Menu
Options

Command

Command Options

Accelerator key(s)

Data Cursor
ALT+F2
Data Display
F2
Limit & Frequency Display
ALT+L
Acquisition Assignments
CTRL+SHIFT+A
Enable Live Display
F3
Select Live Display
Distance from Beginning of File
Difference from DM pt
% Change from DM pt
Slope of line to DM pt
Enable Distance Marker
F4
Select Marker Display
Distance from Marker
Samples from Marker
Cycles/M for Cycle to Marker
Cycles/KM for Cycle to Marker
%EOF
F5
Cursor Location
CTRL+SHIFT+R
Start Time
CTRL+B
End Time
CTRL+SHIFT+B
Distance/Division
CTRL+D
Event Marks
ALT+F8
Grids
ALT+G
User Annotation
ALT+U

†Nonfunctional.
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Reviewing Recorded
Waveforms
After waveforms have been recorded, WWB/Tach functions are used to make timing and amplitude measurements,
review event markers, overlap waveforms to examine interdependencies, cut and paste portions of the waveform,
and do all forms of interpretive analysis.
These functions are listed alphabetically to make them easy to find. In addition, you can use the WWB/Tach Menu
Hierarchy as a table of contents to find a specific command or menu item and the page number where it is
described.

%EOF (Distance to End of File)
Displays the distance from the current cursor position to the end of the data file, expressed as a percentage.

This distance is displayed at the bottom of the screen where 0% EOF indicates that the cursor position is at the
beginning of the data file, and 99.9% EOF indicates that the cursor position is at the end of the data file.
Point to the Options menu and drag down to %EOF. This will enable the distance-to-end-of-file function in
the bottom annotation line if disabled, or disable it if enabled.
When enabled, a checkmark (√) is displayed on the Options menu immediately preceding the %EOF command.
When the distance-to-end-of-file function is disabled, the checkmark is removed.

Assign Channel
Allows any enabled channel to be assigned to any display window.
WWB/Tach software supports up to 29 waveform display windows, in which any one of 240 channels may be
displayed. In some cases, any two waveforms may be displayed in an overlapping format within the same window.
The two-element equality (X=Y) displayed for every enabled channel is called the variable waveform assignment
indicator. This indicator shows which channel is assigned to which window. The first element is the window
number. The second element is the analog channel assigned to that window.
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By default, WWB/Tach software always displays channel 0 in window 1, channel 1 in window 2, channel 2 in
window 3, etc. However, you can display any channel in any window.
To display a channel in a window other than its default assignment:
1.

Select the window to receive the channel by clicking the left mouse button in the unselected window’s
annotation margin.

2.

Point to the View menu and drag down to Assign Channel… The channel portion of the variable
waveform assignment indicator flashes.

3.

Enter the desired channel number and press the ENTER key if required.

Autoscroll
Used to automatically (hands off) scroll the data file. When enabled, the file will scroll in either the backward or
forward time direction (left or right) until the end of the file is reached or any other key on the keyboard is pressed.
To autoscroll the data file:
Point to the Search menu and drag down to Autoscroll Right or Autoscroll Left.
Choose Search Autoscroll Right (ALT, S, A) or Search Autoscroll Left (ALT, S, L).
The file can also be autoscrolled using the accelerator keystrokes:
Keystrokes
Comment
ALT + →
Automatically scrolls the data file to the right (positive time direction).
Automatically scrolls the data file to the left (negative time direction).
ALT + ←
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CALC (Advanced CODAS)
Used to exit WWB/Tach and enter the Advanced CODAS analysis and calculation package (hereafter referred to as
“CALC”). When CALC is entered, the entire file that is active at the time CALC is invoked becomes the input.
Note that Advanced CODAS is an optional, extra-cost waveform analysis package that is not included with the
purchase of WWB/Tach.
In WWB/Tach, Advanced CODAS will compute meter-based derivatives and integrals, but still display units such
as 1/s or 2*s for a channel 1 derivative or channel 2 integral. Its report generator will still label its periods or
frequencies as based on seconds or Hz, although they will be computer based on meters or reciprocal meters.
To enter the Advanced CODAS analysis and calculation package (CALC):
Point to the File menu and drag down to Calculate…
This displays the following dialog box. You are required to select one of these options prior to entering CALC.

This dialog box merely serves as a confirmation for the CALC function. It’s purpose is to allow you to continue
with CALC without saving any prior work done on the file, continue but first save all work done, continue but first
save only the calibration work done on the file, or exit back to WWB/Tach.
After selecting an option, CALC’s first level menu is displayed. Refer to the Invoking CALC Using the Waveform
Playback Utility’s CALC Function section of the Advanced CODAS user’s manual for more details.
When CALC is exited, WWB/Tach is automatically reinitialized with the original waveform data file as the default.
At this point, the CALC-generated waveforms may be examined.

Calibration—Fixed Method
WWB/Tach offers two different ways to calibrate your waveform: the fixed calibration method and the high/low
calibration method. Either method will produce the same results, however one method may be preferable or easier
to use over the other because of the nature of the signals that were acquired and/or what was known about the
transducers used to acquire the signals.
Without calibrating, waveform data is scaled, annotated, and displayed in volts, which in many cases is not very
meaningful. Calibration is used to give meaning to the displayed data. Instead of volts, your data can be scaled,
annotated, and displayed in significant engineering units (i.e., PSI, RPM, lbs, ft/s, etc.). Calibration is done
primarily for display purposes, it makes the data more visually appealing and easier to understand on your monitor.
However when you calibrate, the calibration information is saved in an accompanying header file along with the
data file. This header file stores the calibration information, allowing it to be re-used and thus eliminating the need
to calibrate again.
The fixed method allows waveform data (in the form of ADC counts) to be scaled and annotated in significant
engineering units (using minus full scale, baseline, or plus full scale values) when a quantity per unit of measure is
known.
The fixed calibration function allows you to calibrate a waveform when a known linear input to output relationship
exists for two of these three points: +full scale, baseline, or -full scale. For example, suppose you were acquiring
temperature signals and you were using a temperature-to-analog converter (TAC). With the two-calibration-level
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method, you could probably determine the low calibration level (such as zero or room temperature) but you could
not easily determine the high calibration level (how hot is it going to get?). Since you have only one known
calibration value, it is not possible to calibrate the waveform using this approach. However with the fixed method,
the TAC device itself offers a solution. Say for instance the TAC you are using is a thermocouple to millivolt
converter. According to its specifications, it accepts an input signal from a temperature sensor and outputs a linear 1
millivolt per degree analog voltage signal. This 1mV/degree input to output ratio is the key. Since you know the
relationship between voltage and the units you are measuring (in this case temperature), you can calibrate the
waveform using this known quantity per unit of measure instead of using two calibration levels.
Ensure that the window containing the waveform to be calibrated is enabled. When enabled, the X=Y annotation in
the left or right annotation margin will be highlighted, indicating that window X is enabled for adjustments.
Although not required, the current data and data display options can be enabled for more recognizable results
(choose Options, Data Cursor and/or Options, Data Display). To calibrate a waveform using the fixed calibration
method:
1.

Point to the Edit menu and drag down to Fixed Calibration….
When selected, the Fixed Calibration dialog box is displayed on the screen:

The values displayed in the Engr. Value = text boxes are the upper and lower A/D converter ranges,
which are preset according to the selected gain. When the dialog box is first displayed, a blinking
vertical line (called the insertion point) appears behind the value in the High Calibrator Engr. Value
= text box. This insertion point indicates the active area of the dialog box—the next action you
perform will occur in this area. Type the desired engineering unit value for the high calibrator.
2.

Press the TAB key twice to position the insertion point in the Low Calibrator Engr. Value = dialog
box. Type the desired engineering unit value for the low calibrator.

3.

Press the TAB key again to position the insertion point in the Engr. Units = dialog box. Type up to a
four character optional engineering unit tag (i.e., PSI, f/s, rpm, etc.).

There are also two option buttons for the High and Low Calibrator values:
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Option buttons

These option buttons allow you to calibrate negative only, positive only, or bipolar signals. For example, when you
are acquiring a signal that is bipolar, you would select the +Full Scale (High Calibrator) and -Full Scale (Low
Calibrator) options. When the signal you are acquiring is always negative, choose the Baseline (High Calibrator)
and -Full Scale (Low Calibrator) options. When you are acquiring a signal that is always positive, such as RPM,
choose the +Full Scale (High Calibrator) and Baseline (Low Calibrator) options.
The Next and Previous command buttons allow you to step through all of the enabled channels in order,
calibrating each enabled channel, without closing this dialog box. Note that when either the Next or Previous
button is activated, the channel number in the title bar of the dialog box changes to indicate which channel you are
currently calibrating.
4.

Complete the fixed calibration entry as follows:
Click OK.

The Fixed Calibration dialog box disappears and the waveform channel displays all waveform data values
calibrated in the chosen engineering units.
If desired, the upper and lower grid limit values may be specified (and the waveform automatically scaled to fit).
This feature allows the channel's full scale display span to be shown in whole numbers rather than obscure
fractional values, which sometimes result from calibrating. For example, a waveform scaled in mmHg can be
automatically expanded or contracted to fit within grid limits of 0 to 100 mmHg, or -200 mmHg to +200 mmHg, or
whatever is desired. Note that a channel spanning 0 - 200 mmHg is much easier to read and interpret on a per
division basis than one that spans 10.372 - 189.628 mmHg.
To specify convenient upper and lower chart edge values:
1. Select Scaling Limits… as follows:
Point to the Scaling menu and drag down to Limits….
When selected, the Display Limits dialog box is displayed on the screen as follows:

2.

Using the same procedure as before, type convenient top and bottom chart-edge values in their
respective text boxes.

The Next and Previous command buttons allow you to step through all of the enabled channels in order, entering
the desired display limits for each channel, without closing this dialog box. Note that when either the Next or
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Previous button is activated, the channel number in the title bar of the dialog box changes to indicate the channel
for which you are currently setting display limits.
3.

Complete the chart-edge value entry as follows:
Click OK.

Your specified values will now be displayed on the upper and lower chart-edges and the waveform will be
automatically scaled to fit the new values.
The value of engineering units may range from 1.0 E+32 to 1.0 E-32.
The following charts can be consulted when selecting the proper calibration values, gain range, and input
configuration. To use the charts, simply read across. For example, with a DI-200 configured for a unipolar signal we
know that the full scale measurement range is +10V at a gain of 1. But what is it if we select a gain of 8? From the
chart we see it is +1.25V. The example that follows illustrates how the charts are used in a typical waveform
calibration.
DI-720 Series

Gain

Maximum
Measurement
Range

1

±10V

2

±5V

4

±2.5V

8

±1.25V

DI-730 Series

Gain

Maximum
Measurement
Range

1

±800V

10

±100V

100

±10V

1,000

±1V

10,000

±100mV

100,000

±10mV

Example - Suppose we are using a DI-200 board to acquire pressure data and we are using a converter device that
accepts an input signal from a pressure sensor and outputs a linear 1 millivolt per PSI analog voltage signal. We
want to acquire pressure data in the 0 to 100 PSI range. (a) What input configuration should we select? (b) What
should our calibration values be?
(b) Because the converter device output is going to be 0 to 100 millivolts, we should select the unipolar input
configuration since our signal will never be negative (below zero). Select the +Full Scale option button in the High
Calibrator row and the -Full Scale option button in the Low Calibrator row as follows:
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Click here

(b) From the chart, the -full scale value is 0 volts and the +full scale value is 100 millivolts. Since we will be
measuring 0 to 100 millivolts, 0 is ideal for the low calibrator value (enter 0 in the Low Calibrator Engr. Value box)
and 100 is ideal for the high calibrator value (enter 100 in the High Calibrator Engr. Value box). Then specify
significant units (in this case PSI) in the Engr. Units box. All of the acquired data will be within this range and
calibrated in PSI rather than volts. The following illustration depicts our calibrated screen display.

Units

Given: 1 mV/PSI

Volts

100 PSI

+FS (+Full scale)

0.1V (100 mV)

50 PSI

BL (Baseline)

0.05V (50 mV)

0 PSI

-FS (-Full scale)

0V

Calibration—High/Low Method
The high/low method allows waveform data to be scaled and annotated in significant engineering units by
choosing two known, individual, clearly-defined waveform points as calibration values. Using this approach, you
must use two known waveform points as reliable calibration levels. For example, suppose it is known that 0 psi
occurs when the waveform is on the baseline (ideal for the low calibration level) and 50 psi occurs when the
waveform registers 2.5 volts (ideal for the high calibration level).
Ensure that the window containing the waveform to be scaled is enabled. When enabled, the X=Y annotation in the
left or right annotation margin will be highlighted, indicating that window X is enabled for adjustments. Although
not required, the data cursor and data display options can be enabled for more recognizable results (choose Options,
Data Cursor and/or Options, Data Display). To calibrate a waveform using the high/low calibration method, you
must use the cursor to choose calibration levels:
1.

Position the cursor over the desired lower calibration value of the waveform.

2.

Select Low Calibration… as follows:
Point to the Edit menu and drag down to Low Calibration….
When selected, the Low Calibration dialog box is displayed on the screen:
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When the dialog box is first displayed, a blinking vertical line (called the insertion point) appears
behind the value in the Low Cal Value text box. This insertion point indicates the active area of the
dialog box—the next action you perform will occur in this area. This is where you enter the low
calibration data value that is to be assigned to the input voltage level.
Press the TAB key to position the insertion point in the other text boxes. Type up to a four character
optional engineering unit tag (i.e., PSI, f/s, rpm, etc.).
3.

Complete the low calibration entry as follows:
Click OK.

The Low Calibration dialog box disappears and if no high calibration has been done yet, an offset is applied to the
waveform to achieve the entered value. But you are only half done, it takes two points to define a line and so the
high calibration must be done.
1.

Now position the cursor over the desired high calibration value of the waveform.

2.

Select High Calibration… as follows:
Point to the Edit menu and drag down to High Calibration….
When selected, the High Calibration dialog box is displayed on the screen:

Again the insertion point appears behind the value in the High Cal Value text box. This insertion point
indicates the active area of the dialog box—the next action you perform will occur in this area. This is
where you enter the high calibration data value that is to be assigned to the input voltage level.
Again you use the TAB key to position the insertion point in the various text boxes.
Type up to a four character optional engineering unit tag (i.e., PSI, f/s, rpm, etc.).
3.

Complete the high calibration entry as follows:
Click OK.
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The High Calibration dialog box disappears and the waveform channel displays all waveform data values
calibrated in the chosen engineering units.
If desired, the upper and lower grid limit values may be specified (and the waveform automatically scaled to fit).
This feature allows the channel's full scale display span to be shown in whole numbers rather than obscure
fractional values, which sometimes result from calibrating. For example, a waveform scaled in mmHg can be
automatically expanded or contracted to fit within grid limits of 0 to 100 mmHg, or -200 mmHg to +200 mmHg, or
whatever is desired. A channel spanning 0 - 200 mmHg is much easier to read and interpret per division than one
that spans 10.372 - 189.628 mmHg.
To specify convenient upper and lower chart edge values:
1. Select Scaling Limits… as follows:
Point to the Scaling menu and drag down to Limits….
When selected, the Display Limits dialog box is displayed on the screen as follows:

2.

Using the same procedure as before, type convenient top and bottom chart-edge values in their
respective text boxes.

The Next and Previous command buttons allow you to step through all of the enabled channels in order, entering
the desired display limits for each channel, without closing this dialog box. Note that when either the Next or
Previous button is activated, the channel number in the title bar of the dialog box changes to indicate the channel
for which you are currently setting display limits.
3.

Complete the chart-edge value entry as follows:
Click OK.

Your specified values will now be displayed on the upper and lower chart-edges and the waveform will be
automatically scaled to fit the new values.
The value of engineering units may range from 1.0 E+32 to 1.0 E-32.

Channel Settings…
Provides channel settings information about the selected channel. This information tells you what the sample rate,
gain, acquisition method, input type, dynamic range, etc. settings were when the channel was recorded.
Since most of the settings this fuction displays can be assigned on a per-channel basis in WWB/Tach, the desired
channel must first be selected.
1.

Select the desired channel:
Click the left mouse button in the desired channel’s annotation margin.
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2.

With the desired channel selected, select Channel Settings…
Point to the View menu and drag down to Channel Settings…

This displays the Channel Settings dialog box as follows:

The Next and Previous command buttons allow you to step through all of the enabled channels in order, viewing
the channel settings for each enabled channel without closing this dialog box.
The To Clipboard command button allows you to send all of the information in this dialog box to the clipboard in
text format, ideal for pasting into a word processor or spreadsheet. Since the information pasted from the clipboard
is in text format (not a bitmap), the values are separated from the settings labels by tabs and can easily be edited
with your word processor or spreadsheet program.
The following describes each item in the Channel Settings dialog box (these items are originally set from within
WINDAQ/Pro or WINDAQ/Pro+ waveform recording software by choosing Channel Settings… from the Edit menu.
Complete details on these items can be found in the WINDAQ/Pro and WINDAQ/Pro+ User’s Manual):
Playback channel - Displays the channel you are currently viewing the settings for.
Acquisition channel - Displays the physical channel number that was used during recording. If None is displayed,
it means this channel was never recorded but instead is a “calculated” channel, created by Advanced CODAS
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Analysis Software (available as an extra-cost option).
Samples Per Meter – Indicates the number of samples acquired per meter of traversed distance in meters.
Sample rate divisor – Does not apply to WINDAQ/Tach and will always be displayed at a value of one.
Effective samples per meter (/M) – Will always be equal to Sample Per Meter for WINDAQ/Tach software.
Acquisition method - Displays the method chosen for displaying data on your monitor and recording it to disk.
Valid displays are Average, Last Point, Maximum, or Minimum. Complete definitions of each method can be found
in the WINDAQ/Tach Data Acquisition section.
Input type – Will always be Linear WINDAQ/Tach software.
Gain - Displays the gain chosen for this channel prior to recording. Gain factors vary by instrument.
Input level top - Displays the input level at the top of the A/D converter’s range. This value will be a voltage (either
+5.00 or +10.00 volts) if the channel was truly used for recording, or it will be expressed as a percentage of full
scale (+100.00%) if this is a “calculated” channel created by Advanced CODAS Analysis Software.
Input units - Displays volts if the channel was used for recording, or displays %FS (percent full scale) if the channel
is a “calculated” channel created by Advanced CODAS Analysis Software.
Input level bottom - Displays the input level at the bottom of the A/D converter’s range. This value is a voltage
(either -5.00 or -10.00 volts) if the channel was truly used for recording, or it will be expressed as a percentage of
full scale (-100.00%) if this is a “calculated” channel created by Advanced CODAS Analysis Software.
Dynamic range top - Displays the engineering unit value at the top of the A/D converter’s range. This value will be
an engineering unit value if the channel was calibrated during acquisition, or it will be expressed as a percentage of
full scale (+100.00%) if the channel was not calibrated.
Engineering units - Displays the units used to calibrate the waveform in WINDAQ/Pro or WINDAQ/Pro+, or it
displays %FS (percent full scale) if the channel was not calibrated.
Dynamic range bottom - Displays the engineering unit value at the bottom of the A/D converter’s range. This value
will be an engineering unit value if the channel was calibrated during acquisition, or it will be expressed as a
percentage of full scale (-100.00%) if the channel was not calibrated.
User annotation - Displays any channel specific user annotation that may have been entered during recording.
File - Displays the name and path of the file you’re working with.

Compression
Allows the waveform data file to be compressed: a). entirely onto one screen width or b). to any given ratio.
To enable waveform compression:
1. Point to the Edit menu and drag down to Compression….
When enabled, the waveform compression dialog box is displayed on the screen:
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Compression Onto One Screen Width
To achieve waveform data file compression so that the entire file is compressed onto one screen width:
Click the Maximum command button.
Conversely, distance compression can be disabled (causing the data file to be “uncompressed”) just as easily. To
disable distance compression:
Click the 1 command button.
When the entire waveform data file is compressed, the following features are also activated:
1.

The entire waveform data file fits within one screen width.

2.

The cursor will not automatically be displayed, it must be manually enabled.

3.

The ← and → cursor control keys are active, allowing the cursor to be moved in a left or right direction across
the waveform(s).

4.

The cursor position at any given location on the screen will define the center of the screen when the screen is
expanded by entering a lower compression factor.

5.

The fully compressed file display is saved in memory to allow fast reentry when moving between lower (or
uncompressed), and the full file compressed formats.

When distance compression is disabled, the compression ratio displayed in the Compression text box reverts to a
value of 1.
Compression to Any Given Ratio
The value displayed in the Compression = text box is the selected waveform compression ratio. This ratio can
range from 1 (distance compression disabled) to whatever value is required to compress the entire file on the screen.
When the compression dialog box is first displayed, a blinking vertical line (called the insertion point) appears
behind the compression factor in the Compression = text box. This insertion point indicates the active area of the
dialog box—the next action you perform will occur in this area. To increase or decrease the compression ratio,
make sure the insertion point is in the Compression = text box, then simply enter the new compression ratio. If you
choose a compression value that is too large, an “Invalid Compression” message box will appear. Click OK or press
ENTER to clear the message box and try a smaller compression value.
Entering a compression ratio of 1 disables distance compression, resulting in an “uncompressed” data file.
The Compression ratio (displayed in the Compression = dialog box) is the number of data points for each enabled
channel that are evaluated for a min/max value. For example, if the compression ratio equals twenty, then twenty
data points are evaluated to plot a min/max line.
Cursor Mode Control (Mid, Min, Max, or MxMn) for compressed displays - The waveform compression function
operates by accumulating n number of waveform samples (where n equals the compression ratio). From these
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samples, a line is then displayed, where the end points of this line equal the absolute minimum and maximum
values detected for the sample group. When both the cursor and compression are enabled, a dilemma exists
regarding the appropriate value to report since multiple waveform segments have been compressed into one. To a
degree, the cursor mode control solves this problem by allowing you to specify the value of a compressed line
segment at cursor intersection as either its minimum, maximum, mid point, or minimum/maximum quantity. Mid
reports the compressed line segments mid point value. Min reports the minimum value of the compressed line
segment. Max reports the maximum value of the compressed line segment. MxMn reports both the maximum and
the minimum compressed line segment values in a blood pressure like format (i.e., separated by a slash, such as
120/80).
Compression allows you to choose between MID, MIN, MAX, and MxMn line segment reporting. To select the
desired line segment reporting method:
1. Click the desired option button (either MID, MIN, MAX, or MxMn).
2. Click OK.
The currently active cursor mode is automatically reported at the bottom of the screen where the normal DATA
annotation is replaced by MIN, MAX, MID, or MxMn. The default state is MID.

Copy
Copies the graphics in the graphic selection rectangle to the clipboard.
The Copy command on the Edit menu is dimmed until a graphic selection rectangle is drawn to enclose the desired
graphics.
To copy graphics to the clipboard:
1. Position the mouse pointer anywhere in the graphics area.
2.

Drag with the RIGHT mouse button until the desired graphics have been enclosed

With the graphics selection rectangle drawn, the Copy command on the File menu is enabled and the enclosed
graphics can be copied to the clipboard as follows:
Point to the Edit menu and drag down to Copy.
The graphic is copied to the clipboard in both bitmap and device-independent bitmap (DIB) formats.

Data Cursor/Cursor Movement (Data Cursor, Peak on Screen,
Valley on Screen, Center Cursor)
Used to turn the waveform data cursor on or off and to control cursor movement on the screen. Including moving
the cursor to the highest peak displayed onscreen for the selected channel, moving the cursor to the lowest valley
displayed onscreen for the selected channel, and moving the cursor to the center of the screen.
Turning the Data Cursor On/Off
Point to the Options menu and drag down to Data Cursor. This will turn the data cursor on if it is off, or
off if it is on.
OR
Click the left mouse button anywhere in the bottom annotation line.
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In addition to turning the data cursor on and off, this action also toggles the waveform value display
between waveform/cursor intersection point values and waveform/base line intersection point values
when the data display option is enabled. These values are displayed in the left/right annotation margin
next to the variable waveform assignment indicator. The data display option (choose Options, Data
Display) must be enabled before waveform/cursor or waveform/base line values can be toggled. As the
following illustrations show, when cursor oriented waveform data is enabled, the cursor mode
designator at the bottom of the screen indicates DATA and when base line oriented waveform data is
enabled, the cursor mode designator indicates BASE.

The annotated waveform value will be either the raw waveform voltage, or the waveform voltage
converted into engineering units if calibrated.
If the data cursor is off, clicking the left mouse button anywhere in the bottom annotation line will turn
it on at the point coincident with the mouse pointer. If the data cursor is on, a deliberate click of the left
mouse button in the bottom annotation line at the point horizontally coincident with the data cursor
turns it off. Note when attempting to toggle the cursor on and off quickly, clicking the left mouse
button twice in rapid succession (double-clicking) produces a much different result than turning the
cursor on and off. See the following function for more details on double-clicking in the bottom
annotation line.
Moving the Cursor to the Highest Peak
Point to the Search menu and drag down to Peak on Screen. This moves the cursor to the highest
waveform peak displayed on the screen in a selected channel.
OR
Double-click the left mouse button anywhere in the bottom annotation line. This will also move the
cursor to the highest peak displayed on the screen in a selected channel.
Moving the Cursor to the Lowest Valley
Point to the Search menu and drag down to Valley on Screen. This moves the cursor to the lowest
waveform valley displayed on the screen in a selected channel.
OR
Double-click the right mouse button anywhere in the bottom annotation line. This will also move the
cursor to the lowest valley displayed on the screen in a selected channel.
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Moving the Cursor to the Center of the Screen
Point to the Search menu and drag down to Center Cursor. This moves the cursor to the center of the
screen in a selected channel. If your computer’s SCROLL LOCK function is enabled, the waveform will
move to center screen along with the cursor.
OR
Click the right mouse button anywhere in the bottom annotation line. This will also move the cursor to
the center of the screen in a selected channel. If your computer’s SCROLL LOCK function is enabled,
the waveform will move to center screen along with the cursor.
When the data cursor is turned on, a checkmark (√) is displayed on the Options menu immediately preceding the
Data Cursor command. This checkmark indicates that the cursor is enabled, even though it might not be
immediately obvious on the screen because of its position at the far right or left margin of the display or because it
is otherwise obscured. When the cursor is turned off, the checkmark is not displayed.
Note that highest peak and lowest valley searches can also be done within the limits of a selection rectangle.

Digital Inputs (Analog Plot, Digital Plot)
Two separate functions on the Scaling menu allow you to review digital input channel information. The Analog
Plot function toggles the digital input channel display between a bipolar analog plot and a digital individual bit
plot. The Digital Plot function displays the digital input channel as a digital subchannel featuring each individual
bit. Both of these functions are normally dimmed on the Scaling menu unless the file being reviewed is a digital file
(specified as such prior to acquisition).
A digital input channel displays either a high signal or a low signal, nothing more or less. These two functions offer
two different ways of displaying the same high or low digital signal information. The Analog Plot function allows
you to toggle the display of these high or low signals between an analog plot of a digital channel (with a display
similar to the output of a D/A converter) and a digital plot that shows the state per bit. The Digital Plot allows you
to display the high or low state per bit (0 to 7), with a display option for normally open or normally closed
conditions.
Both of these functions are normally dimmed on the Scaling menu unless the file being reviewed was specified as a
digital input channel prior to acquisition. When the file being reviewed contains digital information, both of these
functions are selectable.
Analog Plot — This function has two purposes. It displays a bipolar analog plot of a digital input channel and it
also serves as a toggle switch between an analog plot and a digital plot of the selected digital input channel. The
analog plot displays the digital input channel in a way similar to the output of a D/A converter.
When this function is enabled, the digital input channel information is displayed as an analog plot and a
checkmark is displayed on the Scaling menu immediately preceding the Analog Plot command. When this function
is disabled (or enabled again), the selected digital input channel information is displayed as a digital plot and the
check mark is removed from the Scaling menu in front of the Analog Plot command.
To enable an analog plot of a digital input channel:
Point to the Scaling menu and drag down to Analog Plot.
Digital Plot… — This function displays the digital input channel as a digital subchannel featuring each individual
bit. When enabled, the display is divided into eight equally spaced horizontal bars or bits (one for each digital
input). Digital input bit 0 is positioned at the top of your screen, digital input bit 7 is at the bottom, and the others
are equally spaced in between. Note that this is true regardless of the size of the window in which WWB/Tach is
running, the horizontal bars or bits are still equally spaced, they are just proportioned with the screen size. The
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default display shows a vertical line for each data point that contains at least one high signal. Many of these
vertical lines adjacent to each other make up a horizontal bar that you see displayed on your screen. If the signal
you wish to monitor is usually high, the vertical line can be inverted so it is displayed for each data point that
contains at least one low signal.
When this function is enabled, the selected digital input channel is displayed as a digital plot with each individual
bit (digital inputs 0 through 7) displayed as a vertical line, and a check mark is displayed on the Scaling menu
immediately preceding the Digital Plot… command.
For example, display window 1 of the following illustration shows a digital plot of a digital input channel. The
vertical line indicates a high condition on bits 2 and 6. The absence of the vertical line on bits 2 and 6 indicate a
low condition. Display window 2 shows an analog plot of the same two input bits.

Digital input bit 2
Digital input bit 6

To enable a digital plot of a digital input channel:
Point to the Scaling menu and drag down to Digital Plot…
This displays the “Channel X Digital Input Inversions” dialog box (where X represents the digital channel, in this
example it is channel 0):

It is here that you can invert the digital input bit line display to accommodate your preference. The default
configuration, shown by an X in the desired digital input box, is a dark line on a light background for a high signal
condition and no line for a low signal condition. Clicking in the digital input box removes the X and inverts the
line display (a light line on a dark background for a high signal condition and no line for a low signal condition).
Multiple combinations are possible.

Enable Live Display
Displays the Distance-To-Beginning-Of-File (DBF) format (or one of the other three time marker-related data
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formats) in the live display field.

When enabled and the waveform is panned across the screen (or the cursor is moved), this display field is constantly
updated to provide a “live” readout.
Point to the Options menu and drag down to Enable Live Display. This enables the live display field in the
bottom annotation line if disabled, or disables it if enabled.
When the live display field is enabled, a checkmark (√) is displayed on the Options menu immediately preceding
the Enable Live Display command. When the live display field is disabled, the checkmark is removed.
When the live display field is enabled, the data displayed in this field is determined by the Select Live Display
setting. Refer to the SELECT LIVE DISPLAY function for more details.
When the live display field is disabled, off is displayed in the field with the last selected format.

Enable Distance Marker
The distance marker is used to define one end of a range of waveform information (the data cursor is used as the
other end). When a range of waveform is defined, the data lying between the distance marker and cursor can be
reported in one of four selectable, distance-related formats.
To set a distance marker:
1. Position the cursor (by using the mouse in the bottom annotation line, or by using the left- and right-arrow keys)
at a point on the waveform in window 1 where the distance marker is to be placed.

2. Enable the distance marker by:
Pointing to the Options menu and dragging down to Enable Distance Marker. Note that you can also enable
a time marker by pressing the F4 key or with ALT, O, M keystrokes.
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When enabled, a checkmark (√) is displayed on the Options menu immediately preceding the Enable Distance
Marker command and zeroes fill the distance marker display field. The checkmark indicates that the distance
marker function is enabled, even though it might not be immediately obvious on the screen for various reasons.
When the distance marker function is disabled, the checkmark is removed and the display field shows off.
3. Move the cursor away from the distance marker, (in either direction) to the other end of the desired range (again,
by using the mouse or the arrow keys).

As the cursor is moved, the distance difference between the cursor and distance marker will be displayed in the
bottom annotation margin in one of four selectable formats (refer to the SELECT MARKER DISPLAY function for
more details on distance marker display formats). Distance differences are annotated as both positive and negative
numbers. When the cursor is to the right of the distance marker, the distance difference will be displayed as a
positive value. When the cursor is to the left of the distance marker, the distance difference will be displayed as a
negative value.
A distance marker can be set with or without the cursor enabled, however it is much easier to see what is transpiring
with the data cursor on.
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Since cursors for all channels align perfectly in time, the distance difference for events on channels other than that
in window one may be measured even though the distance marker itself is displayed only on window one's
waveform. You can display any waveform channel in window one, allowing distance measurements to be made on
any channel.
When a distance marker is placed directly over an event mark, the distance marker has priority and the event mark
disappears.
Selecting Options Enable Distance Marker a second time turns the time marker. function off.

Event Markers…
Allows you to: automatically locate event markers that were enabled during data acquisition; display the date and
time at the current cursor position; quickly vector to any part of the data file; and enable or disable the display of
event markers.
Point to the View menu and drag down to Event Markers….
This displays the Event Markers window as follows:

While the Event Markers window is displayed, you may scroll through the list of all enabled event markers as
follows:
Click the up- or down-scroll arrow on the right side of the window to scroll one line at a time.
Click in the scroll bar above or below the slider box to scroll 12 lines at a time.
Drag the slider box to go to a specific part of the list.
When a specific event number is highlighted, activating the OK command button (or double-clicking on the
highlight bar) repaints the WWB/Tach screen with the segment of waveform that contains the specified event
45

PLAYBACK AND ANALYSIS USING WWB/TACH

number. If the data cursor is enabled for display, the cursor will appear positioned directly over the specified event
number. If no event markers were enabled during data acquisition, the file will contain 256 equally spaced
transparent event markers. These markers will not appear on the screen, but they will allow you to quickly vector
to any part of the data file.
Activating the Cancel command button will abort the SEARCH-FOR-EVENT function without vectoring the
display to the indicated event number.
Activating the To Clipboard command button copies all event marker columnar information to the clipboard in text
format. Since the data is copied to the clipboard in text format (as opposed to bitmapped format), it can be pasted
into a word processing document or a spread sheet and edited. The information can be viewed with the Clipboard
Viewer feature of Windows™ (to maintain the vertical alignment of the data, select the OEM Text display option
from the Clipboard Viewer).
The current position of the cursor relative to distance is displayed at the top of the screen as Cursor Location.
The EVENT # column indicates a unique number applied to the event marker at the location it was enabled during
data acquisition. Event marker numbers are always assigned sequentially (i.e., starting with 1 and incrementing
until the last event marker enabled is reached, or until the maximum number of event markers is achieved). Event
marker numbers are followed by special markers, which indicate:
* manual start in the forward direction (same as previous direction)
> manual start in the forward direction (opposite previous direction)
+ tachometer reversal to forward direction
= manual start in the reverse direction (same as previous direction)
< manual start in the reverse direction (opposite previous direction)
- tachometer reversal to reverse direction
The DBF column indicates the event marker's position in distance relative to the beginning of the data acquisition
file. All values are annotated in meters.
The DM column displays the event marker's position in meters relative to the distance marker if the distance marker
is enabled.
The %EOF column indicates the position of the event marker relative to the end of the data file as a percentage.
The LOCATION (KM) column indicates the distance in kilometers of the event marker relative to the beginning of
the data file.
The COMMENT column displays the comment that was provided (if any) at the distance the event marker was
enabled during data acquisition. Assuming a full 39-character comment was provided for the event marker when it
was enabled, the comment will appear truncated if the distance marker function is enabled. Characters consumed by
the distance marker column are freed for comment display when the distance marker is disabled.
When you scroll the event list to an event number greater than the total enabled during acquisition, all columns
(except EVENT #) will display **.
The DM column is active only if the distance marker was enabled before Event Markers… was chosen from the
View menu. If the distance marker was not enabled, ** will be displayed in the DM column.
If no event markers were enabled during data acquisition, WWB/Tach will pad the data file with 256 equally spaced
event markers, allowing you to quickly vector to any area of the data file.

Event Marks (Next Mark, Previous Mark, Insert Mark, Delete
Mark, Clear Marks to DM)
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Next Mark and Previous Mark provide a convenient method for moving from one event mark location to the next
on a selected channel. Insert Mark and Delete Mark allow a positive or negative-going event mark to be placed on
or deleted from any enabled window's waveform except waveform channel 1.
After a channel has been selected, you must enable event marks for display. This is done by:
Pointing to the Options menu and dragging down to Event Marks
When event marks are enabled for display, a checkmark (√) is displayed on the Options menu immediately
preceding the Event Marks command. When event marks are disabled, the checkmark is removed.
With event marks enabled for display, use the following procedures to move among event marks:
Search for Next Event Mark
Point to the Search menu and drag down to Next Mark…. This moves the window in the positive
distance direction to the next event mark.
Search for Previous Event Mark
Point to the Search menu and drag down to Previous Mark…. This moves the window in the negative
time direction to the previous event mark.
Insert an Event Mark
Point to the Edit menu and drag down to Insert Mark. This inserts a positive-going event mark on the
selected window’s waveform at the point of waveform-cursor intersection. Repeating this action toggles
the event mark from positive-going to negative-going. Note that this procedure will work on any
channel except channel 1. Note also that the waveform must be uncompressed (waveform compression
must equal 1) to insert an event mark.
Delete an Event Mark
Point to the Edit menu and drag down to Delete Mark. This deletes an event mark (from the selected
window’s waveform) that is coincident with the waveform cursor. Note that this procedure will work on
any channel except channel 1. Note also that the waveform must be uncompressed (waveform
compression must equal 1) to delete an event mark.
Clear all event marks between cursor and distance marker (from selected channel)
Point to the Edit menu and drag down to Clear Marks to DM. This deletes all event marks (from the
selected channel) in the range between the cursor and distance marker. The range can be defined by
positioning the cursor at one desired limit, enabling the distance marker (by pointing to the Options
menu and dragging down to Enable Distance Marker), then moving the cursor over to the other desired
range limit. If this function is used on the lowest-numbered acquired channel, no event marks will be
deleted. This is because this channel contains event marker information enabled by the data recording
program.
When attempting to seek an event mark in either direction where one does not exist, an audible beep will sound,
the display will fail to move, and an error message will be displayed. Click on the OK box or press the ENTER key
to clear the error message.

Exit…
Quits the WWB/Tach program and returns you to the Program Manager window (Windows 3.1) or to the desktop
(Windows 95).
To quit WWB/Tach:
Point to the File menu and drag down to Exit…
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When the Exit… command is chosen, the following dialog box is displayed. You are required to select one of the
following options prior to exiting:

Save All… command button - Saves the entire state of WWB/Tach data (including display format, scales, offsets,
compressions, calibration constants, etc.) before returning to the Program Manager or desktop.
Save Calibration… command button - Saves the calibration data only. The next time the data file is reviewed, all
waveforms will appear calibrated without needing to repeat the calibration process.
Exit with no save… command button - Exits to the Program Manager or desktop without saving calibration or
state. If calibration data was previously provided and saved, the constants provided are unaffected by this
command. They remain intact for future file review.
Cancel command button - Returns to WWB/Tach without saving anything (cancels your exit request).

Export
Allows you to select a range of waveform information from an existing data file and export it into a new data file in
a variety of different storage formats.
This function operates on all channels in the data file lying between the specified range. If you wish to export only
certain channels in a data file, refer to the EXTRACT CHANNELS function.
The range of data to be exported is user-definable. Created data files may be read by user-generated, or standard
(i.e., ASYST, Lotus 1-2-3, Excel, Quatro Pro, etc.) software analysis packages, or by Advanced CODAS' CALC
package.
Before data may be exported to a disk file, the copy range must be selected. The copy range is defined as all data for
each waveform lying between the distance marker and cursor.
To select the copy range:
1. Position the cursor at one end of the desired range (drag the left mouse button in the bottom annotation margin
to position the cursor).
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2.

Enable the distance marker (by pressing the F4 key; by pointing to the Options menu and dragging down to
Enable Distance Marker; or by choosing Options Enable Distance Marker with ALT, O, M keystrokes).

3.

Move the cursor (in either direction) to the other end of the desired range (by dragging the left mouse button in
the bottom annotation margin).
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When the copy range is selected as described above, the waveforms are exported as follows:
Point to the File menu and drag down to Save As….
This displays the Save As dialog box. Before you enter a file name, select a file storage format. The file storage
format selections are displayed by:
Clicking the Format>> command button.
The file storage format selections appear on the right side of the dialog box as follows:

Select the storage format by:
Clicking the desired format option button.
With the desired format selected, enter in the text box the name of the data file (including desired path names) to
which WWB/Tach is to write the copied data.
When a file name is entered, export the waveforms by:
Clicking the Save command button.
The data within your selected range and from every channel in the file will be exported to the specified data file.
Note the Visible channels only check box at the top of the Save As dialog box. This option must remain
unselected (no X appears in the check box) for the export function to work on all channels in the data file. If this
option is selected (an X appears in the check box), only the visible channels (those that are displayed on your
monitor) in the data file will be copied and pasted. Refer to the EXTRACT CHANNELS function in this chapter for
complete details on the Visible channels only check box.
A description of each data storage format follows:
SEQUENTIAL ASCII - This data storage format is one of three (Binary without CODAS header, and Lotus 1-2-3
are the others) that may be used to create a data file readable from a user-generated applications program (e.g.,
BASIC, FORTRAN, C, etc.). Data is stored as ASCII strings with a “,” (comma) delimiter. Each data value field
consists of eleven characters (excluding the comma). The data format is scientific notation, and is scaled into
engineering units as follows:
SX.XXXXESXX
Where:

S is the sign of either the exponent or mantissa.
E flags the value of the exponent.

The order of data storage is sequential with waveform channel one always being the first data value written. For
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example, if four waveform channels exist, the first data value written is channel one, the fourth is channel 4.
The sequential ASCII data storage format is perhaps the easiest to use from the applications program level, but you
will pay a price in terms of data file length since it takes 10 characters (bytes) to represent one data value.
BINARY WITH CODAS HEADER - Use this data storage format to review the created data file with WWB/Tach
software. This utility is useful when you need to break up a larger CODAS data file into smaller, easily manageable
units for review by WWB/Tach software.
BINARY WITHOUT CODAS HEADER - This data storage format, like Sequential ASCII, is used when you need
to access the created data file through your own BASIC, FORTRAN, C, etc., applications program. But, unlike
Sequential ASCII, the Binary-without-CODAS-header format requires only two bytes of storage to represent one
data value, thus yielding much smaller data file lengths.
ASYST - When this data storage format is selected, WWB/Tach software stores channel data in a fashion that is
directly compatible with the ASYST data storage convention. The storage format allows ASYST to input data as a
two-dimensional array (channel number, channel data).
When the ASYST format is invoked, you are prompted to select the storage format as either (R)eal or (I)nteger.
Select (I)nteger if you do not need to have waveform data scaled into engineering units. This format allows more
data to be ported into ASYST(ANT) arrays. Select (R)eal if you need the waveform data ported to ASYST(ANT) to
be scaled in engineering units. You can also enter up to two optional comment lines that you may use to describe
your particular test. The aggregate sample rate is automatically entered as a comment. The sample rate, as well as
any additional comments you provide, will be printed on your monitor (by using the ASYST "?FILE" command)
when you retrieve the data file into ASYST.
ASYSTANT - Although the data storage format for ASYSTANT (including [R]eal and [I]nteger conversions) is
identical to ASYST, data files are imported slightly differently. An ASYSTANT/ASYST-formatted file is imported to
ASYSTANT by using the FILE I/O option and specifying a FILE/VAR TRANSFER. Enter the data file name and the
ASYSTANT variable that will be assigned the data (for this example we will assume variable T was specified), and
select the READ option at the bottom of ASYSTANT's FILE INPUT/OUTPUT menu. Quit the FILE I/O menu and
return to the upper-most ASYSTANT menu. Notice that variable T indicates the size of the data array. You may now
operate on the data contained in variable T using all of ASYSTANT's powerful routines.
A NOTE TO ASYST AND ASYSTANT USERS - When waveform data are pasted in the ASYST/ASYSTANT
storage format using the (I)nteger conversion, waveform channel values are equivalent to A-D converter counts
(integers). To translate A-D converter counts into a voltage, perform the following operation from the ASYST or
ASYSTANT level:
VOLTAGE = (Counts / 8192) * Volts full scale
SPREADSHEET PRINT - Allows you to paste waveform data to files that may be read directly by Lotus 1-2-3,
Excel, Quatro Pro, or any spreadsheet program that uses the comma-separated-value (CSV) data format. Even if your
spreadsheet program uses something other than a comma to separate data values, it is still possible to use this
format. Contact DATAQ INSTRUMENTS for details on changing the delimiter from a comma to whatever your
program requires.
Selecting the Spreadsheet option from the format option list creates a data file that, when read by Lotus 1-2-3 using
their IMPORT command (do not use Retrieve), will present the data in spreadsheet fashion where each waveform
channel fills one column (i.e., column A contains waveform channel one's data, column B waveform channel two's,
etc.). When the Spreadsheet format is invoked, you are prompted to enter up to two optional comment lines that you
may use to describe your particular test. The aggregate sample rate is automatically entered as a comment. The
sample rate, as well as any additional comments you provide, will be printed on your spreadsheet when you import
the data file to your spreadsheet program.
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Some spreadsheet programs (i.e., Excel) require the newly created CSV file to contain a .CSV extension in the file
name.
DEFERRED HARD COPY - Use this data storage format to create a print file (or several print files) that can be
invoked and printed (even batch processed) at a later time from DOS with the AT-CODAS hard copy utility
(HCU.EXE). The target printer and port are those specified during CODAS configuration.
WWB/Tach users can also use the hard copy utility (HCU) provided they have a Laserjet, Thinkjet, or IBMcompatible, dot-matrix graphics printer that CODAS supports. In this case, the hard copy utility (HCU.EXE) will be
automatically installed at the time of WWB/Tach installation (contact DATAQ Instruments technical support for
details).
After selecting this data storage format, you will be prompted to enter a comment. You may enter a line of
comments (up to 70 characters) that will be passed to the hard copy record.
DADiSP - Selecting the DADiSP file format will create a data file that may be directly imported into the DADiSP
waveform analysis program. The file format is that defined by DSP Systems where a data file header describing the
format of the data is first created, and the data format is floating point binary.
CALC - When the CALC option in the format selection menu is selected, the following events automatically take
place:
1. A new data file is created on disk carrying the file name you supplied when the waveforms were exported.
2. The specified range of waveform information is extracted (copied) from the currently active waveform data file,
then pasted into the newly created file using the CODAS (with data file header) format along with any
calibration information.
3. CALC is run and initialized with the default file name of that containing the pasted waveforms. At this point,
the CALC first-level menu will be displayed and you may execute your required CALC function(s) on the data
file containing the pasted waveforms, or even change the default file name to operate on another file. When
CALC is exited, control returns to WWB/Tach software in the state that existed just before the waveforms were
exported. The waveform data file from which waveforms were copied remains as the active WWB/Tach file.
4. DO NOT PASTE DATA IN A COMPRESSED FORMAT WHEN USING THE ADVANCED CODAS CALC
OPTION.
Note that Advanced CODAS is a separately-purchased software utility for waveform analysis.
EASYEST LX or AG - When this data storage format is selected, data is stored in a fashion that is directly
compatible with the “light” versions of ASYST software (called EASYEST LX or EASYEST AG). These two flavors
of EASYEST are smaller, simpler, less complex versions of ASYST software.
nSoft DAC - When this data storage format is selected, data is stored in a fashion that is directly compatible with the
“nSoft” DAC package from nCode International Inc. This format stores one file per channel, and the last two digits
of the filename indicate the channel number (i.e., 01 is channel one, 02 is channel two, 10 is channel 10, etc.). If
you are using WWB/Tach software, statistical information is also included in the data file when this storage format
is selected.
PASTING DATA IN COMPRESSED FORMAT
Since the waveforms displayed by WWB/Tach software may be compressed at the time of export, it is possible to
paste compressed data. If waveform compression was enabled at the time of export, and the SPREADSHEET or
ASYST(ANT) storage format is selected, the sample rate figure automatically added to the comment lines will be
divided by the compression ratio that was active at the time the export function was selected. If the DADiSP storage
format is selected, the distance axis of DADiSP windows will be automatically adjusted.
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Extract Channels
Allows you to select a range of waveform information, only from selected channels in an existing data file, and
export it into a new data file in a variety of different storage formats.
This function operates only on selected channels (only the channels that you select to be visible onscreen) in the
data file lying between the distance marker and cursor. If you wish to export all of the channels in a data file, refer
to the EXPORT function.
The newly created file may contain any subset of channels from the existing data file. The range of data is user
definable. Before data may be extracted and placed in a disk file, the range of data must be selected. The range of
data is defined as all data lying between the distance marker and cursor.
To select the range of data:
1. Position the cursor at one end of the desired range (drag the left mouse button in the bottom annotation margin
to position the cursor).

2.

Enable the distance marker (by pressing the F4 key; by pointing to the Options menu and dragging down to
Enable Distance Marker; or by choosing Options Enable Distance Marker with ALT, O, M keystrokes)

3.

Move the cursor (in either direction) to the other end of the desired range (by dragging the left mouse button in
the bottom annotation margin).
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Although the range is specified only on display window one, when extracted, data in all visible windows lying
between the limits are extracted to your specified file name.
When the data range is selected as described above, the extract utility can be invoked as follows:
Point to the File menu and drag down to Save As….
This displays the Save As dialog box. Before you enter a file name, select a file storage format. The file storage
format selections are displayed by:
Clicking the Format>> command button.
The file storage format selections appear on the right side of the dialog box as follows:

Select the storage format by:
Clicking the desired format option button.
With the desired format selected, enter in the text box the name of the data file (including desired path names) to
which WWB/Tach is to write the extracted channel data.
When a file name is entered, extract the selected channel(s) by:
Clicking the Save command button.
The data within your selected range and from the visible channels only will be extracted from the active file and
placed in the specified data file.
Note the Visible channels only check box at the top of the Save As dialog box. This option must be selected (an X
appears in the check box) for the EXTRACT CHANNELS function to work as described above. If this option is
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unselected (no X appears in the check box) and the EXTRACT CHANNELS procedure is completed, all channels in
the original file will be extracted rather than just the desired (or visible) ones. Literally, whatever channels are
displayed on the screen (and the order in which they are displayed) become the channels that are ported to the
newly created file.

Fourier Transform Operations
The Fourier Transform converts information in the distance domain into the cycles per meter (~/M) domain. It is an
important analytical tool whenever it is necessary to determine the frequency components of a given distance series
waveform. The thumbnail theory is that any periodic waveform may be represented by a series of sine wave
functions at different amplitudes, frequencies, and phase shifts which when summed together for each distance
series increment will reproduce the original waveform. Given an appropriate multi-term sine function (Fourier
expansion) for a distance series waveform, the magnitude of each term of the expansion may be plotted versus its
frequency to yield a power spectrum that is representative of the frequency makeup of the distance series waveform.
WWB/Tach software contains three types of Fourier transforms; the fast Fourier transform (FFT), the discrete Fourier
transform (DFT), and the inverse Fourier transform (IFT).
The FFT is the most computationally efficient transform of the three but also the least versatile. The FFT function
automatically places some restrictions on the distance series to be evaluated. It requires that the range or length of
waveform to be evaluated contains a total number of data points precisely equal to a power of 2 (e.g., 256, 512,
1024, etc.). Therefore, with an FFT you can only evaluate a fixed length waveform containing 512 points, or 1024
points, or 2048 points, etc. For example, if your distance series contains 1096 data points, you would only be able
n
to evaluate 1024 of them at a time using an FFT since 1024 is the highest 2 that is less than 1096. Additionally, the
FFT also requires that the distance series to be evaluated is a commensurate periodic function, or in other words, the
distance series must contain a whole number of periods within the FFT bounds. Obviously, the chances of a section
n
of waveform containing a number of data points equal to a 2 number and having the last point match the first in
magnitude and slope are slim at best. Significant distortion in the resulting power spectrum can result if care is not
taken to ensure that end-points match as demonstrated by the following figure:

End-point mismatches over the FFT range can result in significant power spectrum distortion
Fortunately a number of solutions exist to minimize the effects of end-point mismatches. One solution is to window
the distance series waveform so that the distortion is greatly attenuated or reduced to zero depending upon the
window type. This approach multiplies the distance series waveform by a function resembling a bell-shaped curve
before applying the FFT. The section titled FFT GENERATION describes how windows may be applied to correct
the power spectrum of distance series waveforms generated over a number of points equal to a power of 2. Refer to
the subheading in this section titled WINDOW OPTIONS FOR FFTs for further information on FFT window
options.
Another solution abandons windowing in favor of allowing the user to precisely define the range over which the
n
transform is calculated. This approach nullifies the 2 limitation and is known as the DFT. Refer to the subheading
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in this section titled DFT GENERATION for further information on Fourier transform generation over variable, userdefined ranges.
The IFT allows you to reconstruct the original signal (as a function of distance) from the power spectrum (as a
function of frequency or cycles per meter). This capability makes power spectrum filtering possible. The IFT also
comes in handy when determining what a certain power spectrum represents. Suppose you open a file that was
saved and exited from the split screen Fourier transform utility. The screen will display the typical split screen
Fourier transform mode with a power spectrum that you know very little about at first glance. The quickest way to
find out what that power spectrum represents is to do an IFT and compare this result (displayed in window 2 of the
Y-T area) with the original waveform in window 1 of the Y-T area. The IFT will show you the portion of the original
waveform that was used to generate the power spectrum. Refer to the subheading in this section titled IFT
GENERATION for further information on editing in the frequency domain.
FAST FOURIER TRANSFORM (FFT)
FFT GENERATION
The FFT is ideally suited for homogeneous-type waveforms (waveforms that have the same structure throughout, or
have a similar cyclic repetition) but need not be limited to this type. Before an FFT can be generated, the channel
you wish to transform must be moved into display window one (e.g., type “1=5” if you wish to transform channel
5). After this is accomplished, scroll the display of the selected channel to center the area you wish to transform on
the screen. The FFT can now be generated directly from either the Y-T or the X-Y display modes as follows:
Point to the Transform menu and drag down to Windowed FFT…
This displays the FFT Window Type, Size, and Averaging dialog box as follows:

From this dialog box, you are able to select the type of FFT window that will be applied, the size of the FFT, and the
input averaging factor.
The FFT algorithm supports four different types of windows that may be applied to minimize the effects of endpoint distortion. These are Bartlett, hanning, Hamming, and Blackman windows. The characteristics of each
window are described by the following figure:
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Each window has different characteristics that make one window better than another at separating spectral
components near each other in frequency, or at isolating one spectral component that is much smaller than another,
or whatever the task. The window that you use depends on your skill at manipulating the tradeoffs between the
various windows and also on what you want to get out of the power spectrum or its inverse (for complete
information on the Fourier transform algorithm, request Dataq Instruments’ free Application Note number AN-11,
Waveform Analysis Using the Fourier Transform).
The FFT algorithm supports a number of different sized FFTs (size refers to the number of data points contained in
the FFT). Because the FFT function uses a base 2 logarithm by definition, the range or length of the distance series
n
to be evaluated must contain a number of data points equal to a 2 number. This is why the FFT selections you see
in the Number of Points list box are all a power of 2 (256, 512, 1024, etc.). The number of selections you see
displayed in this list box will vary for any one data file depending on the factors that affect this power-of-2
limitation. These factors include the size of the data file, the width of the window that WWB/Tach software is
running in on your monitor, the screen format (whether overlapped or non-overlapped), and whether or not the data
file is compressed. The overall size of the data file determines whether or not the larger FFT options (such as 8192
and 16384) are displayed in the list box, while the size of the window that WWB/Tach is running in and the screen
format determines whether or not the smaller FFT options (such as 32, 64, or 128 points) are displayed. The
minimum sized FFT that can be displayed in the list box is 32, and the maximum is 16384.
When the FFT algorithm is first initiated with an uncompressed waveform, the FFT selection highlighted in the
Number of Points list box is the maximum power of 2 that will fit on the screen. For example, with a video standard
of 1024 x 768, 1024 pixels of horizontal screen resolution are available for display. In this case, 1024 is a power of
2, so the 1024-point FFT selection will be highlighted in the Number of Points list box. When the OK command
button is activated and the 1024-point FFT is performed, the data to be transformed is taken from the center of the
screen in window 1. 512 data points in both directions from the center of the screen will be transformed. Similarly
with a 2048 point FFT, 1024 data points in both directions are included in the FFT calculation, and so on with the
other choices.
Note that you are not limited to only a 1024-point FFT. You can select a smaller or larger sized FFT from the list. So
which size FFT is right for your waveform? That depends on what you want to see in the power spectrum and how
much resolution you want. Beside calculation speed (which is negligible), the only difference between a 1024point transform and a 16384-point transform is resolution. A power spectrum always ranges from the dc level (0 Hz)
to one-half the sample rate of the waveform being transformed, so the number of points in the transform defines the
power spectrum resolution (a 512-point FFT would have 256 points in its power spectrum, a 1024-point FFT would
have 512 points in its power spectrum, and so on). Suppose you wanted to see separate 20 and 21 Hz frequency
components in the power spectrum of a complex waveform. A 512-point FFT might not show these individual
components clearly since its entire power spectrum is only divided into 256 equally spaced points and the desired
frequencies are so close together. However, if the transform contained more points, it would be able to devote more
points to the definition of closely spaced frequency components. The more the number of points in a transform, the
better the frequency resolution.
When you select an FFT from the list that is larger than the number of horizontal pixels your screen is capable of
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displaying, the waveform will automatically be compressed. This happens semi-transparently and requires no
additional user input. The compression becomes obvious when the split screen display is exited (with the View,
Exit/Enter Split command) and the normal Y-T waveform display is shown.
If you would like to perform a smaller FFT than what is shown on the list, you will have to reduce the amount of
pixels your screen has available for display (the less you see, the less you FFT). This can be done primarily by
horizontally shrinking or resizing the window that WWB/Tach software is running in, and to a lesser degree by
selecting an overlapped screen format. Refer to your Windows™ documentation for details on resizing the window
border. For example, with a VGA display and an uncompressed waveform, it is possible to display a 32-point FFT
option by reducing the window to its minimum horizontal size and selecting an overlapped screen format.
The FFT algorithm also supports input averaging. Input averaging allows you to perform FFTs on more data points
than the value selected in the Number of Points list box. For example, suppose you have a waveform file that
contains 82,000 data points and you want to perform an FFT on the entire file. The largest FFT selection available
in the Number of Points list box is 16384, which is nowhere close to 82,000. However, input averaging provides a
way for you to perform an FFT on the entire 82,000 point file. This is done by averaging the total number of data
points to be transformed. For every N points on the original waveform, input averaging develops a single point on
the transformed waveform. You have complete control over the number of data points that will be averaged to form
each FFT input point. The number you enter in the Input Averaging text box determines the number of data points
that will be averaged to form one FFT input point. In our example, an input averaging factor of 5 should be entered
since 82,000 ÷ 16384 equals approximately 5. This means that for every 5 data points in the original file, an
average value is computed. This value now forms a single point on a waveform that will be used as the input to the
FFT algorithm. It should be noted that because you are averaging data points, some distortion will occur in the
power spectrum. Averaging the input waveform values will not give you a true representation of the original signal
in the power spectrum but instead will give you a very close approximation.
There are also some limits on the number you can enter in the Input Averaging text box. First, it must be a whole
number, fractional values are ignored. Second, the maximum number (or input averaging factor) that can be input is
a function of the total number of samples in the channel to be transformed divided by the selection made in the
Number of Points list box.
After the data window type, number of points, and input averaging (optional) selections have been made, activate
the OK command button to calculate the FFT. When calculated, the following screen is displayed. This screen is
composed of three basic sections; the Y - T waveform area, the analysis reporting area, and the FFT plot area.

58

PLAYBACK AND ANALYSIS USING WWB/Tach

An example screen showing how the FFT screen is divided
The Y-T waveform area is divided into two windows (window 1 and window 2). Window 1 displays the waveform
from which the transform was derived. Window 2 initially displays the waveform it contained before the transform
was invoked, but is used as the target window for subsequent IFTs if this feature is activated. The waveforms
contained in both windows may be manipulated by using the same functions available in the Y-T mode of
WWB/Tach software while a power spectrum is displayed.
Following the transform, three cursors will appear in the Y-T waveform area to show the portion of the waveform
that was used to generate the power spectrum.

Window 1
Window 2

Left Limit Cursor

Center Cursor

Right Limit Cursor

The center cursor is automatically placed in the center of the screen to indicate the center of the FFT. The left cursor
indicates the left limit of the FFT range, which is 512 pixels away from the center on a 1024 x 768 display. The
right cursor indicates the right limit of the FFT range, which is 511 pixels to the right of the center cursor on a 1024
x 768 display. The actual data used in the FFT calculation is the raw data contained between the two limit cursors.
Assuming that a compression factor of one (1) was enabled at the time the FFT was activated, and a full screen (not
resized) display is used, a 1024 point FFT will be generated.
The analysis reporting area performs a dual role. When manipulating the waveforms in the Y-T area, the analysis
reporting area contains information about the waveforms in this area just as a typical WWB/Tach screen would.
When examining the power spectrum in the FFT plot area, the analysis reporting area changes to display
information about the setup conditions and the power spectrum data. This data is updated as the cross hair,
displayed on the power spectrum plot, is moved. A typical display with the cross hair placed over a frequency of
6.40 Hz with a relative magnitude of -99.34 dB is shown as follows:

The (X1) and (hn) descriptors define the zoom factor and window currently applied to the spectrum. Refer to the “Xaxis Scaling” and “Power Spectrum Windowing” headings below for further information related to these functions.
When the analysis reporting area is displaying power spectrum data, the display can be toggled to show normal
waveform information by clicking in the left/right annotation area of either waveform displayed in the Y-T area.
Similarly, when the analysis reporting area is displaying waveform information, the display can be toggled to show
power spectrum data by clicking anywhere in the FFT plot area.
The FFT plot area contains the actual plot of the power spectrum. Examining the power spectrum is possible
through use of a cross hair which may be moved anywhere on the plot. When the FFT is plotted, the origin of the
cross hair is placed at the strongest frequency component of the waveform by default. The position of this cross hair
is displayed in the analysis reporting area in terms of its frequency and magnitude as described above.
The vertical crosshair can be moved to display a specific frequency value in the analysis reporting area. Clicking
the left mouse button anywhere in the FFT plot area allows you to position the vertical cross hair at the mouse
pointer position. Dragging anywhere in the FFT plot area with the left mouse button held down allows you to drag
the vertical cross hair anywhere on the plot. When dragged the horizontal crosshair follows the plot, and the
analysis reporting area updates to reveal current values. After releasing the left button, SHIFT+F4 will rescale the
power spectrum plot to place the horizontal crosshair at the top of the FFT plot area and use it as the 0dB reference.
This rescale can be undone by dragging the left mouse button in the left magnitude scale margin to position the
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horizontal cross hair at the very bottom of the FFT plot area, then by pressing SHIFT+F4 again.
The horizontal crosshair can be moved to display a specific decibel or magnitude value in the analysis reporting
area. Clicking the left mouse button anywhere in the left magnitude scale margin allows you to position the
horizontal cross hair at the mouse pointer position. Dragging anywhere in the left magnitude scale margin with the
left mouse button held down allows you to drag the horizontal cross hair anywhere on the plot and simultaneously
update the decibel or magnitude value in the analysis reporting area. After releasing the left button, SHIFT+F4 will
rescale the power spectrum plot to place the horizontal crosshair at the top of the FFT plot area and use it as the 0dB
reference. This rescale can be undone by dragging the left mouse button in the left magnitude scale margin to
position the horizontal cross hair at the very bottom of the FFT plot area, then by pressing SHIFT+F4 again.
Grid lines and axis annotation are also available to aid waveform analysis. Grid lines can be toggled on and off in
the same manner as described in the Grids section. When displayed, the X-axis of the plot represents the frequency
axis of the power spectrum with the scale displayed at the bottom of the screen. The Y-axis represents the
magnitude axis of the power spectrum with the scale displayed at the left edge of the screen. The magnitude axis (Yaxis) is always displayed when a transform is performed, however the frequency axis (X-axis) can be toggled on and
off by selecting the Limit & Frequency Display command from the Options menu.

EXITING THE FFT MODE
To exit the split screen mode and return to the Y-T mode of operation:
Point to the View menu and drag down to Exit/Enter Split.
Exiting the split screen display in this way retains the power spectrum data in memory so the two modes can be
quickly toggled between if desired.
Alternatively, you may terminate WWB/Tach from the split screen mode by:
Pointing to the File menu and dragging down to Exit….
If you exit from the split screen mode with the option of saving the WWB/Tach state, the state that existed at the
time the program was terminated becomes the default condition the next time the file is reviewed. Elements of the
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saved state are marker positions, whether an FFT or DFT was activated, the input average factor, magnitude in
engineering units or db, the window type (Hamming, Blackman, etc.), and the frequency axis magnification factor.
Note that a significant relationship exists between the location of markers and the resulting power spectrum. To
ensure that the current screen display is reproduced when quitting with the save-state option, no marker
adjustments should be made following the generation of the last FFT.

DISCRETE FOURIER TRANSFORM (DFT)
DFT GENERAL INFORMATION
When it is necessary to select a portion of the waveform more accurately than an FFT will allow, or when a nonwindowed transform is desired, DFT generation may be used. All the functions available for FFT generation such as
scaling, averaging, and smoothing are also available for DFT generation with the exception of windowing. When
using DFT's, the need for a windowing function is replaced by the ability to adjust the end-points that define the
time series range as discussed earlier in the FOURIER TRANSFORM BASICS section above. With the DFT, there
are two ways to define the range of the time series to be transformed. One method allows you to adjust right and left
limit cursors so the desired length ofdistance series is enclosed within these limit cursors. This approach allows you
to see on window 1 in the Y-T display area precisely what you are transforming. The other method allows you to use
the distance marker and cursor to specify the DFT range. The location of the distance marker on a waveform
represents one limit of the transform, while the location of the waveform cursor represents the other limit. This
approach does not require that the full range of waveform information to be transformed be viewed on the screen at
once. When a DFT is performed, the analysis reporting area is changed to reflect the lack of windowing as shown
below:

The window designation is replaced by a C or E (which denotes the DFT approach that was applied) and by the
factors of 2 in the compression factor applied to the waveform being transformed. For example, in the middle
display shown above, the (C1) descriptor indicates a DFT generated by the distance marker and cursor approach
with 21 (or 2) as the highest power of 2 used in the DFT calculation. In some cases, an asterisk (C*) will appear in
this field. This indicates that the power of 2 used in the DFT calculation is 100 or greater (the field can only
accommodate a two digit number). For the same reason, when the power of 2 is greater than 9 but less than 100, the
C will be dropped from the display field and only the compression factor will be displayed (i.e., 12). Whichever
approach you take, the DFT provides a more accurate power spectrum plot than the FFT at the expense of added
time for set-up and calculation. The resulting power spectrum may then be examined in the same manner as the FFT.
GENERATING A DFT USING LIMIT CURSORS
To generate a DFT with the limit cursor approach, ensure that the distance marker is turned off (e.g., press F4 until
off is displayed in the marker display field of the bottom annotation line). With the distance marker disabled, the
transform algorithm assumes that the distance series is defined by the left and right limit cursors. Now move the
channel you wish to transform into display window one (e.g., type “1=5” if you wish to transform channel 5). After
this is accomplished, scroll the display of the selected channel to center the area you wish to transform on the
screen. The DFT can now be generated directly from either the Y-T or the X-Y display modes as follows:
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Point to the Transform menu and drag down to DFT.
If an FFT was not done prior to this DFT, the resulting calculation will consist of the points on the waveform
bounded by the Y-T window chart edges as shown below:

With the limit cursors at the extreme left and right chart edges of the Y-T window, you get a DFT of exactly what
you see in Y-T window 1. Of course, you can adjust the limit cursors to get any length of waveform you desire.
If an FFT was done prior to generating the DFT, the limit cursors will not be at the extreme left and right chart edges
but instead will be some power of 2 apart (i.e., 512 pixels apart). Which does not give you a DFT of exactly what
you see in window 1. The following illustration shows this subtle but important point:
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Since the transform algorithm assumes that the distance series is defined by the left and right limit cursors, a DFT
performed after an FFT will produce a power spectrum over the range defined by the position of the limit cursors as
shown above. A very different power spectrum will be obtained from this range compared to one obtained with the
limit cursors at extreme chart edge.
It is possible to reposition the limit cursors at the chart edges (or wherever desired) of window 1 and then perform
the DFT. Such a procedure is described as follows:
Defining the DFT Range Using Limit Cursors
Before generating a DFT, the right limit cursor and left limit cursor should be adjusted to enclose an integer or
whole number of cycles on the waveform to be transformed. This is best accomplished by picking a spot on the
waveform where the slope is steep and a single points value is well defined, like near the midpoint of a waveform.
Also keep in mind that the DFT is generated over the range including those points occupied by the limit cursors. So
position the limit cursors accordingly, taking care not to enclose one-too-many points when defining your cycle. To
adjust the limit cursors:
1.

Position the mouse pointer in the bottom annotation line underneath the desired limit cursor.

2.

Drag with the left mouse button to adjust the position of the limit cursor. Note that when the mouse
button is pressed, the limit cursor changes from a dotted line to a solid line in window 1. When the
mouse button is released, the limit cursor remains a solid line until a different limit cursor is adjusted.

Note that the cursors can be moved in either direction, but the right limit cursor cannot be moved to the left of the
center cursor and the left limit cursor may not be moved to the right of the center cursor. Note also that the center
cursor is ignored, except when it becomes necessary to adjust it to allow the desired placement of the left and right
limit cursors.
In cases where compression is enabled, the number of points contained in the resulting DFT is a function of both
the compression factor and the number of pixels laying between the right and left limit cursor (or in other words,
window size). The relationship of compression to the number of points in the power spectrum is described by the
following table. In this table, a random assumption was made about how many pixels were contained between the
right and left limit cursors. To demonstrate the math, we randomly assumed 607 pixels were contained between the
right and left limit cursors:
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To illustrate an example from the table above, suppose we need a compression factor of 10 to compress the
waveform enough so the area of interest can all be seen on the screen. So we enter 10 as our waveform compression
factor and then perform the DFT. The value from column B is derived by evaluating the expression 2x , where the
exponent x is the number that appears in the (EX) descriptor field of the analysis reporting area (a direct result of
the compression factor). In our example, a 1 appears in the (EX) descriptor field of the analysis reporting area when
a compression factor of 10 is used, so 21 = 2. The value in column B is then divided into the waveform compression
factor to get the value in column C, which is the number of data points averaged. In our example, 10 ÷ 2 = 5. This
means that for every 5 data points on the original waveform, one average value was used as the input to the DFT
algorithm. The value in column D is the number of data points contained in the transform, which is derived by
multiplying the number of pixels between the left and right limit cursors by the value from column B.
The limit cursor approach has the advantage of displaying all waveform information to be transformed on the
screen at once. By adjusting the waveform compression factor, virtually any range of waveform information may be
displayed on the screen, isolated by adjusting the limit cursors, then transformed. However, if a compression factor
is enabled to bring the desired range on screen, this approach suffers from the disadvantage that each point on a
waveform represents multiple acquired points. For example, each displayed point on the waveform represents a
combination of 15 acquired points if a compression factor of 15 is enabled, making precise end-point placement
difficult. For this reason, a second DFT placement approach is available. This approach defines end-points through
use of the time marker and cursor.
Defining the DFT Range Using the Distance Marker and Cursor
The distance marker approach to specifying a DFT range allows precise placement of end-point markers. Unlike the
previous method of power spectrum generation, the distance marker approach does not require the onscreen display
of the full range of waveform information to be transformed. The location of the distance marker on a waveform
represents one limit of the transform, and the location of the waveform cursor the other limit. Since the distance
marker need not be displayed on the screen to remain active, large transforms are possible at low compression
factors. Transforms up to 8192 points are possible at a compression factor of 1 allowing precise placement of endpoints without the indecision of marker placement at compression factors greater than 1. This approach, however,
does support compression factors greater than 1 adding more flexibility to its use.
Distance marker and cursor placement on the waveform to be transformed may occur from either the Y-T or DFT
modes of operation. Since the object of using the distance marker approach to end-point definition is precision, it is
recommended that the distance marker and cursor positions be defined from the Y-T mode, using display format 1
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to allow full screen resolution during the placement process. Just as with the limit cursor approach, the distance
marker and cursor should be adjusted to enclose an integer or whole number of cycles on the waveform to be
transformed. This is best accomplished by picking a spot on the waveform where the slope is steep and a single
points value is well defined, like near the midpoint of a waveform. Also keep in mind that the DFT is generated
over the range including those points occupied by the distance marker and cursor. So position the distance marker
and cursor accordingly, taking care not to enclose one-too-many points when defining your cycle. The
recommended procedure is as follows:
1.

Exit the DFT mode and enter the Y-T display mode by pointing to the View menu and dragging down
to Exit/Enter Split.

2.

Assign the waveform to be transformed to window 1 by pointing to the View menu and dragging down
to Assign Channel…, then entering the desired channel number.

3.

Enter your desired compression factor by pointing to the Edit menu and dragging down to
Compression…

Note that regardless of the range of waveform information to be transformed or the magnitude of the compression
factor, DFT software will always ensure that the number of points in the result does not exceed 8192 by multiplying
the compression factor by the smallest integer necessary. More on the effects of waveform compression follow
shortly. The selected compression factor, however, must be 1 to allow precise end-point placement.
4.

Scroll the window to your first desired end-point (using the ← or → cursor control keys).

5.

Place the distance marker at the desired location by pressing the F4 key. Make certain that the
waveform cursor is enabled to allow precise placement of the distance marker.

6.

Scroll the window until the waveform cursor is directly over the second desired end-point.

7.

Perform the DFT over the selected range by pointing to the Transform menu and dragging down to
DFT.

Waveform compression operates slightly differently when the distance marker approach is used as compared to the
other method. When the distance marker is used, the compression factor defines the number of consecutive Y-T
points averaged before transforming the waveform. For example, if 2244 points exist between the cursor and time
marker then the result is a 2244 point transform if the compression factor equals 1. Leaving the markers' position
unchanged and incrementing the compression factor to 2 would yield a 1122 point transform since one point
representing the average of each two consecutive points is passed through the transform. Whenever a DFT is
activated using the distance marker method, the analysis reporting area will display the actual averaging factor as
follows:

POWER SPECTRUM MEASUREMENTS
CROSS HAIR ADJUSTMENT
The cross hair may be scrolled along the plot to examine other points of interest. As the cross hair is scrolled along
the plot, the frequency and magnitude at the cross hair origin are displayed in the analysis reporting area. The cross
hair can be scrolled by:
Dragging with the left mouse button anywhere in the FFT plot area.
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Note that the display of the cross hair may be toggled off and on by pressing ALT+F2.
POWER SPECTRUM WINDOWING
After the power spectrum is plotted, the type of windowing applied to the FFT calculation can be changed.
WWB/Tach supports four window types: Bartlett, Hanning, Hamming and Blackman. The window applied is
changed by:
Pointing to the Transform menu and dragging down to Windowed FFT…
This displays the FFT Window Type, Size, and Averaging dialog box, from which you simply select a different
window and activate the OK command button. The window designator is always displayed in the analysis reporting
area as follows:

POWER SPECTRUM SMOOTHING
After the power spectrum is plotted, a moving average filter can be applied for smoothing the spectrum. The
moving average utility takes X data points (you specify how many) from the spectrum, adds them together, divides
their sum by the total number of data points added, replaces the first data point in the power spectrum with the
average value just computed, repeats these steps with the second, third, and so on data points until the end of the
power spectrum data is reached. This technique attenuates random, small amplitude frequency spikes often
encountered in a power spectrum plot. You control the amount of smoothing by specifying the moving average
factor. Available factors are no averaging (1) or factors of 2, 3, 4, 5, 6, 8, 10, 12, 16, 20, 24, 32, 40, and 48. With a
power spectrum displayed, the spectrum can be smoothed as follows:
Point to the Transform menu and drag down to Average Power…
This displays the Power Spectrum Smoothing dialog box as follows:
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From this dialog box, you simply highlight the smoothing factor (or number of points to be averaged) and activate
the OK command button. This displays the FFT Window Type, Size, and Averaging dialog box, from which you
simply select a different window and activate the OK command button. The smoothing factor chosen is displayed
in the analysis reporting area as follows:

At the bottom of the dialog box, you will see the Mean Power Frequency. This number will tell you what the center
of gravity is for your power spectrum. If you made a hard copy of your power spectrum and carefully cut around it,
the Mean Power Frequency is the point at which you could balance it. The equation to find this number is:
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n

∑ fn • m2n

n=1
n

2

∑ mn

n=1

n = resolution of the FFT divided by 2
f = frequency
m = magnitude
X-AXIS SCALING
When a power spectrum is plotted, the entire spectrum is displayed on the screen regardless of the number of points
in the transform. If a transform containing a large number of points is performed, the resulting power spectrum is
compressed in order to fit on one screen width. This is fine for spotting the overall trend of a spectrum but what if
you wanted to examine a selected portion of the plot more closely? This can be done by scaling the frequency axis.
A video standard of 1024 x 768 provides 1024 picture elements (pixels) of horizontal resolution. If a 512-point FFT
is performed, the 256 points generated by the transform fit nicely on a screen capable of displaying 1024 points.
The same is true of a 1024-point FFT, where a 1024 pixel wide screen is more than adequate to contain the 512
points generated by the transform. The problem arises when a transform larger than 2048 points is performed.
Suppose an 8192-point FFT is performed. The 4096 points generated by the transform is much wider than the 1024
pixel width of the screen. So in order to get the entire power spectrum on one screen width, a compression factor (in
this case, a factor of 4) is automatically applied. To zoom in on the power spectrum and examine a selected portion
in greater detail, you must magnify the spectrum (or in effect, scale the frequency axis).
After the power spectrum is plotted, scaling of the frequency axis may be used to examine a selected portion of the
plot more closely. To do this, scroll the cross hair along the spectrum until it reaches the desired section of the plot
and:
Point to the Transform menu and drag down to Compress FRQ…
This displays the Frequency Compression dialog box as follows:

From this dialog box, you activate the Expand command button to change the spectrums frequency compression.
Successive activations apply increasing magnification scaling factors to a maximum value of 4X. When the desired
magnification factor is entered, activating the OK command button applies the magnification. When the spectrum
is magnified in a way that prohibits the display of the entire power spectrum on a single screen width, a scroll bar
appears at the bottom of the plot area, allowing you to pan the entire plot.
Activating the shrink command button decreases the magnification factor to a limit of ÷p, where p =
[(n/2+1)/640]+1 and is the number of pages needed to display individual frequencies of an n-point transform. The
current power of magnification is displayed in the analysis reporting area as follows:
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Panning the Power Spectrum
Whenever a magnification factor greater than 1/p is active, the entire power spectrum cannot appear on a single
screen width. For this reason, a scroll bar automatically appears at the bottom of the plot to allow you to easily
examine the entire plot.
Y-AXIS SCALING
After the power spectrum is plotted, the Y-axis can be re-scaled to aid spectrum analysis. Activating Y-axis scaling
causes the selected Y level to be plotted at the top of the screen and the rest of the plot to be re-scaled accordingly.
The dB values will also be re-scaled using the top of the screen as the 0 dB reference with decreasing values
displayed as the bottom of the screen is approached. With a power spectrum displayed, the Y-axis can be re-scaled
relative to the position of the horizontal cross hair as follows:
1.

Adjust the horizontal cross hair to the desired reference level by dragging with the left mouse button
in the left annotation margin of the bottom pane (or transform plot area).

2.

Re-scale the spectrum plot relative to the horizontal cross hair by pointing to the Transform menu and
dragging down to Scale DB.

If the results obtained from this re-scaling operation are unsatisfactory, the default Y-axis scale can be restored by
positioning the cross hair at the extreme bottom of the screen and repeating step 2 (in effect, re-scaling with the
cross hair positioned at the extreme bottom of the screen).
CHANGING POWER SPECTRUM AMPLITUDE UNITS
The strength of the frequency component can be displayed in either engineering units or relative magnitude in the
form of decibels (dB). The default scale of decibels (db), assuming the scale has not been changed by adjusting Yaxis scaling as described above, is derived from the following equation:
dB = 20 * log 10 (32768 * MAG / FS)
where MAG is the magnitude in engineering units of the frequency component and FS is the full scale value of the
Y-T waveform from which the transform was derived. For example: if the full scale value was 100 mmHg and the
magnitude at a given frequency component is 39.78, the dB value would be 82.30. After the power spectrum is
plotted, the strength of the frequency component can be toggled from engineering units to relative magnitude (or
vice versa) by:
Pointing to the Transform menu and dragging down to Mag Engr Units.
This causes the display in the analysis reporting area to change as follows:
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EXPORTING THE POWER SPECTRUM COORDINATES
While in the transform mode, it is possible to export the coordinates that define a transform plot to an ASCII file.
This is done by:
Pointing to the Transform menu and dragging down to Output FRQ Data…
This displays the Save Frequency Data to File dialog box as follows:

Enter in the text box the name of the data file (including desired path names) to which the ASCII file is to be
written. When a file name is entered and the OK command button is activated, a second dialog box is displayed as
follows:

From this dialog box, you can specify the type of frequency information to be saved as an ASCII file. The transform
plot information is saved as an ASCII file in the form of a three column spreadsheet. These three columns contain
the information necessary to reproduce the spectrum four different ways in any spreadsheet program (or in any
program that is capable of importing ASCII files). The FRQ DB MAG selection will reproduce the spectrum
showing magnitude and frequency information (exactly as displayed in the plot area of WWB/Tach). The FRQ
COSINE SINE selection will reproduce the spectrum in a rectangular coordinates format, showing phase
information with the cosine value representing the real component and the sine value representing the imaginary
component. The FRQ MAG RADIANS selection will reproduce the spectrum in a polar coordinates format,
showing the vector angle in radians. The FRQ MAG DEGREES selection will also reproduce the spectrum in polar
coordinates format, but with the vector angle in degrees.
When the desired file type is highlighted and the OK command button is activated, the transform plot is exported to
an ASCII file. The display will return to the power spectrum plot and analysis can be resumed.
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It is possible to reproduce the spectrum in WWB/Tach. This is useful when you wish to see phase information for a
plot currently displaying magnitude and frequency information. ASCII files are saved in the form of a three column
spreadsheet preceded by a header. The header contains the set up information used in the transform calculation
including: the filename of the waveform, the assigned channel, position in the file from which the FFT was taken,
compression applied to input, the number of averaged points in the FFT, window type used, and the size of the FFT.
A portion of a sample file is shown as follows:
FILE = sample.dat
CHANNEL = 1
DBF OF LEFT POINT = 1.86080
DBF OF CENTER POINT = 1.912
DBF OF RIGHT POINT = 1.96300
SCREEN COMPRESSION = 1
INPUT AVERAGING = 1
WINDOW TYPE = hanning
FRQ SMOOTHING FACTOR = 1
POINTS = 512
FRQ
DB
MAG
0. -6.02
7.6294E-05
10. 40.21
1.5640E-02
20. 39.19
1.3899E-02
29. 40.02
1.5302E-02
39. 40.21
1.5631E-02
49. 40.63
1.6023E-02
.
.
.
.
.
.
.
.
.
This header information may be used to completely reproduce the spectrum (in another format, if desired) through
WWB/Tach. An FFT may be reproduced as follows:
1.

With waveform compression equal to one, position the cursor in the original file so that DBF (in the bottom
annotation line) is equal to the DBF OF CENTER POINT value shown in the header.

2.

With SCROLL LOCK on, position the cursor and waveform at screen-center by pressing the gray asterisk (*)
key.

3.

Set the compression factor of the original file equal to the SCREEN COMPRESSION value shown in the
header.

4.

Reproduce the spectrum by pressing CTRL+W.

A DFT spectrum may be reproduced as follows:
1.

In the original file, set the waveform compression factor to 1.

2.

Move the cursor until DBF (in the bottom annotation line) is equal to the DBF OF RIGHT POINT value shown
in the header.

3.

With the cursor at this position, press F4 to set a time marker.

4.

Now set the waveform compression factor equal to the INPUT AVERAGING value shown in the header.

5.

Now move the cursor so that DBF (in the bottom annotation line) is equal to the DBF OF CENTER POINT
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value shown in the header.
6.

Reproduce the spectrum by pressing CTRL+F.

INVERSE FOURIER TRANSFORMATION (IFT)
EDITING THE POWER SPECTRUM
In many cases it is desirable to examine a waveform without any “noise” present to distort the true nature of the
signal. This can be done by applying high-pass, low-pass, band-pass, and notch filter functions to the power
spectrum to eliminate the noisy frequency components. WWB/Tach software provides high-pass filter, low-pass
filter, band-pass filter, and notch filter functions to eliminate these unwanted frequencies from the plot. The highpass filter removes all frequency components to the left of the position of the cross hair origin. The low-pass filter
removes all frequency components to the right of the cross hair origin. The notch filter removes the frequency (or
frequencies if the frequency axis is compressed) at the cross hair origin. The band-pass filter is a combination of
high-pass and low-pass filters applied to isolate a narrow band of interest on the spectrum. The power spectrum can
be edited as follows:
To apply a high pass filter (remove unwanted frequency components to the left of cross hair origin), position the
cross hair origin at the desired point on the spectrum and:
Point to the Transform menu and drag down to High-pass Filter.
To apply a low pass filter (remove unwanted frequency components to the right of cross hair origin), position the
cross hair origin at the desired point on the spectrum and:
Point to the Transform menu and drag down to Low-pass Filter.
To apply a notch filter (removes the frequency or frequencies if compressed, at the cross hair origin), position the
cross hair origin at the desired point on the spectrum and:
Point to the Transform menu and drag down to Erase Frequency.
The band pass filter is simply a combination of High-pass and Low-pass filters, applied to isolate a band of interest.
See the individual procedures as described above for details on applying each.
INVERSE FFT GENERATION
After editing the power spectrum, it is possible to perform an IFT by:
Pointing to the Transform menu and dragging down to Inverse Transform.
This generates a waveform in Y-T window 2 representing the edited power spectrum currently plotted in the FFT
plot area. This new waveform will be scaled like the original as well as having the current compression factor, but
will appear multiplied by the data window if an FFT was applied. From this point, the IFT waveform may be further
examined or exported by using the analysis functions provided by WWB/Tach from within the FFT mode or after
exiting the FFT mode by pressing CTRL+Y.
Note that when an IFT is generated, the previous IFT (if any) is not saved and therefore cannot be pasted together to
form a large waveform made up of several sections of different IFT's. The waveform originally occupying window 2
is deactivated, not removed from the waveform file. Window annotation “2=0” at the bottom of the screen is
automatically enabled by the software when it displays the IFT waveform. The original waveform may be restored
by typing
2=x
where x is the channel number of the originally displayed waveform.
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TRANSFORM CALCULATION TIME CONSIDERATIONS
Since some large transforms take a long time on computers without a numeric coprocessor, a status indicator in the
form of a letter (A, C, D, F, L, M, S, or W) is displayed in the analysis reporting area to indicate the FFT operation
currently in progress.

This feature is provided to indicate that the computer is currently active and to discourage you from activating the
transform again, thereby queuing up more time-consuming requests and tying up the machine for several minutes.
Another reason for providing the indicator is to indicate where the computer is spending its time through the course
of a transform calculation. Using the following table as a guide, the “Time-minimizing Element” column defines
what can be employed to minimize the time required to make the calculation:

L time, which is proportional to the height of the frequency part of the split screen, can be dramatically shortened
by a numeric coprocessor.
C time is roughly proportional to the number of transform points, and will show up each time the number of points
changes for FFTs.
D time is proportional to the total number of transform points and the number of data points to be averaged per
transform point. For forward transforms, it is also proportional to the number of channels in the file and the time
required for disk operations.
F, M, C, W, S, and A times are roughly proportional to the number of transform points and machine instruction
times. S and W will have to be recalculated after memory deallocation occurs to spawn another program, to perform
a maximum compression, or to enter the X-Y mode. But, memory is retained after an Exit/Enter Split from the FFT
mode to allow reentering with another Exit/Enter Split without a time penalty.

Format Screen
Used to select a specific waveform display format.
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ACTIVATING PROCEDURE
1.
2.

Point to the View menu and drag down to Format Screen.
In the format box, click the desired display format.

It is possible to display a format design other than the standard display formats listed. For example, suppose you
wanted to monitor three waveforms on the screen. Your best choice among the standard display formats capable of
displaying at least three waveforms is the four waveform format. However, the fourth displayed waveform would be
blank. It would simply occupy screen space without conveying any useful information. The tool used to devote the
entire screen to the exact number of waveforms you wish to monitor is called the User-specified format option. To
use the User-specified format option:
1.
2.

Point to the View menu and drag down to Format Screen.
In the format box, click User-specified format….

This displays the User-specified dialog box as follows:

When the User-specified dialog box is first displayed, a blinking vertical line (called the insertion point) appears
behind the number in the Number of Channels text box. This insertion point indicates the active area of the dialog
box—the next action you perform will occur in this area. To specify a non-standard format:
Enter the desired number of channels to be displayed (up to 32 overlapped), and click OK. You also have
the option of overlapping the specified number of waveforms. To overlap the waveforms, click the
Overlapped check box. An X appears in the box indicating an overlapped format. A subsequent click
removes the X, indicating a non-overlapped format.

Free/Lock Cursor
This function applies mostly to those who are using WWB/Tach without a mouse. It allows the cursor to be released
from its default position of screen-center. When released, it may be positioned anywhere on the screen while the
displayed waveforms remain stationary.
Pressing the SCROLL LOCK key will free the cursor and allow you to position it anywhere on the screen
using the ← and → cursor control keys. When the cursor is in its free state and if your computer's keyboard
provides an indicator light for SCROLL LOCK, the light will be off. The light will be on when the cursor is
in its locked state. The cursor state will toggle each time the SCROLL LOCK key is pressed.
The asterisk key (*) may be used to center the cursor in the waveform display window. If SCROLL LOCK is off
when the * key is pressed, the cursor alone moves to screen-center while waveforms remain stationary. If SCROLL
LOCK is on when the * key is pressed, cursor and waveforms scroll to screen-center together.

Go to Range…, Go to Distance…, Go to DM Position
Three separate functions that allow you to immediately vector or jump to a specific part of the file. Each feature is
described as follows:
74

PLAYBACK AND ANALYSIS USING WWB/Tach

Go to Range… - This function instantly moves the data cursor to the next or previous data point that is inside or
outside of a specified range of values on the selected channel. When a data point satisfying the range and
conditions has been found, the screen is scrolled to place the cursor at the value of the point found.
To use the Go to Range… feature:
1.

Select the window that contains the desired waveform:
Click the left mouse button in the unselected window’s annotation margin.

2.

Specify the range as follows:
Point to the Search menu and drag down to Go to Range…

This displays the Search for data range dialog box. The Go to Range function is controlled from this dialog box as
follows:

from lower limit - This text box allows you to enter a value representing the lower end of the range. If this text
box is left blank, the low end of the range is unbounded. This limit is retained until a search is done on a different
channel or a new file is opened. When limits are assigned, the << Inside Range, << Outside Range, Inside Range
>>, or Outside Range >> command buttons can be used to move the cursor to the next or previous data point
inside or outside of the specified range.
to upper limit - This text box allows you to enter a value representing the higher end of the range. If this text box
is left blank, the high end of the range is unbounded. This limit is retained until a search is done on a different
channel or a new file is opened. When limits are assigned, the << Inside Range, << Outside Range, Inside Range
>>, or Outside Range >> command buttons can be used to move the cursor to the next or previous data point
inside or outside of the specified range.
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<< Inside Range - This command button moves the cursor to the previous data point inside the specified range of
values on the selected channel. The limiting values are considered inside and are thus included in the range.
Inside Range >> - This command button moves the cursor to the next data point inside the specified range of
values on the selected channel. The limiting values are considered inside and are thus included in the range.
<< Outside Range - This command button moves the cursor to the previous data point outside the specified range
of values on the selected channel. The limiting values are not included.
Outside Range >> - This command button moves the cursor to the next data point outside the specified range of
values on the selected channel. The limiting values are not included.
Using the Go to Range… function on a compressed waveform (compression value greater than 1) will often result in
the displayed data disagreeing with the search range. This is because the Go to Range… function looks at
individual data values, and a compressed waveform is many individual data values compressed to form one line
segment. The obvious solution is to make sure the waveform is uncompressed when using this function. If
compression must be used, refer to the Help documentation for details on using this function with compression
enabled.
Next Location… - This function instantly moves the data cursor to the next occurrence of the specified location.
The entered common location value for these commands is retained as the default until a new file is opened, after
which it defaults to the current cursor location the first time this command is used.

Point to the Search menu and drag down to Next Location….
Previous Location… - This function instantly moves the data cursor to the previous occurrence of the specified
location. The entered common location value for these commands is retained as the default until a new file is
opened, after which it defaults to the current cursor location the first time this command is used.

Point to the Search menu and drag down to Previous Location….
Go to DM Position - This function instantly moves the display screen to the position of the file occupied by the
distance marker. When at the position of the distance marker, you can instantly move back to your original
position. To move to the distance marker position:
Point to the Search menu and drag down to Go to DM Position.
This moves the display to the position of the previously enabled distance marker. If the data cursor is enabled for
display, it will overlay the distance marker on the screen. Pointing to the Search menu and dragging down to Go to
DM Position a second time moves the display back to the original position.

Grids
Enables or disables the real time waveform display grid pattern.
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To enable grid lines for display (if disabled, or disable them if enabled):
Point to the Options menu and drag down to Grids.
When grid lines are enabled, a checkmark (√) is displayed on the Options menu immediately preceding the Grids
command. When grid lines are disabled, the checkmark is not displayed.

Invert
Allows you to flip the selected waveform upside down, exchanging the top and bottom limits.
To invert the waveform:
Point to the Scaling menu and drag down to Invert.
A subsequent activation of the Invert command flips the selected waveform back to its original orientation.
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Jump to Beginning/End of File
Instantly moves the display screen to the beginning or end of the waveform file, accomplished by:
Dragging the slider box in the horizontal scroll bar to the leftmost limit (for the beginning of the waveform
data file) or to the rightmost limit (for the end of the waveform data file).

Notepad Function (Note and Commented Note)
Allows individual data points to be written to a notepad data file on disk, with or without text annotation.
The data sent to the target file are those data points from each channel coincident with the position of the data
cursor at the time the NOTEPAD function is invoked.

The NOTEPAD function may be invoked at any time during data review. The first time during the review session
that NOTEPAD is invoked, the Open Notepad File dialog box will appear prompting you to name the file to which
screen data will be written. Any valid file name (including path names) may be entered. Thereafter, invoking
NOTEPAD sends the selected data directly to that file.
With the cursor positioned at the desired point on the waveform, data can be written to a notepad file as follows:
Note only (plain data, no annotated text)
1. Select File Note as follows:
Point to the File menu and drag down to Note.
When selected for the first time, the Open Notepad File dialog box is displayed on the screen:
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2.

In the Filename text box, enter the name of the file (including desired path names) to which WINDAQ is to write
the notepad data.

3.

Click OK.

The procedure for writing data and text information to a notepad file is similar. The text is entered in the Notepad
Annotation dialog box, which is displayed when the Commented Note command is chosen from the File menu. The
number of text characters that may be stored for each annotated note conforms to the following equation: (11 x # of
channels enabled) + 22. With the cursor positioned at the desired point on the waveform, data and comments can be
written to a notepad file as follows:
Commented Note (data with comments)
1. Select File Commented Note as follows:
Point to the File menu and drag down to Commented Note.
When selected, the Notepad Annotation dialog box is displayed on the screen as follows:

2.

In the Notepad Annotation text box, enter the desired comment.

3.

Click OK.

Data is written to the target file in a columnar format. A maximum of six columns may be written depending upon
the number of waveforms in the data file. When the WWB/Tach program is exited and a notepad file is typed to the
screen or printed, the columns seen are defined as follows:
Column 1 (left-most)
Column 2
Column 3
Column 4
Column 5
Column 6

Distance-to-beginning-of-file
Time marker
Channel zero data
Channel one data
Channel two data
Channel three data

Data for all waveform channels, distance-to-beginning-of-file, and distance marker data are all written to the
notepad file whenever the NOTEPAD function is invoked.
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All data is written in scientific notation format. The only exception to this rule is distance marker data. If a distance
marker was enabled at the time the NOTEPAD function was invoked, distance marker data will be annotated in
scientific notation. If the distance marker WAS NOT enabled, column two will contain nine zeros 000000000
indicating that the distance marker was not enabled.
If the channel has been calibrated, the data written to the notepad file will be in engineering units. Channels that
have not been calibrated will be written as raw analog voltages.
When NOTEPAD is activated with a compressed waveform display, waveform values reported to the notepad file
will be the minimum, maximum, or mid point value of the waveform's line segment that is coincident with the
cursor depending on the state of the cursor mode. Refer to the COMPRESSION section for complete details.
All NOTEPAD files are directly compatible with spreadsheet, ASYST, and ASYSTANT software. In the case of the
latter two, the notepad file will have to be converted from ASCII into the ASYST/ASYSTANT format before being
read. ASYST and ASYSTANT provide the file conversion utilities.
NOTE: When inserting comments in this mode, Control Q inserts the date and distance that the cursor appears. If
you want the time to represent the beginning distance of the file, place the cursor at the beginning and the distance
marker at the end.

Open…
Allows you to open and review files from within the WWB/Tach program.
Point to the File menu and drag down to Open….
This displays the following dialog box.

You are required to select one of these options for the current data file before you can switch to a different file.
Save All… command button - Saves the entire state of WWB/Tach data (including display format, scales, offsets,
compressions, calibration constants, etc.) before returning you to the Program Manager or to the desktop.
Save Calibration… command button - Saves the calibration data only. The next time the data file is reviewed, all
waveforms will appear calibrated without needing to repeat the calibration process.
Proceed with No Save… command button - Proceeds to the Program Manager or desktop without saving
calibration or state.
Cancel command button - Returns you to the WWB/Tach display without saving anything.
Following your selection of an option for the currently active data file, the Open dialog box will appear prompting
you for the new file name. Supply the name of the data file you wish to review (including path, if necessary).
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Palettes (Next Palette, Previous Palette, & User Palette)
Allows the selection of one of 16 pre-defined display palettes. Additionally, a user-palette option allows you to
redefine the color scheme of the displays by selecting different background, gridline, user annotation, and
waveform colors from among 16 choices.
A different palette can be displayed by selecting either the Next Palette or the Previous Palette command from the
View menu. These commands allow you to pan through and display all 16 palette selections in either a forward or
backward direction.
Display the Next Palette
Point to the View menu and drag down to Next Palette.
Display the Previous Palette
Point to the View menu and drag down to Previous Palette.
Note that you are not limited to the color combinations presented on the 16 pre-defined display palettes. It is
possible to tailor one, several, or all palettes to suit your color preference, taste, or room lighting requirements. The
tool used to accomplish this is the User Palette… command. The User Palette… command allows you to redefine
the palettes color scheme by selecting different background, gridlines and user annotation, or waveform colors from
among 16 color choices.
When a palette is changed, you have the option of making the new color scheme permanent or canceling all color
changes. If the changes are canceled, the palette reverts back to the original color scheme you started with. If the
changes are made permanent, the new color scheme is saved as one of the 16 display choices and the original color
combinations are overwritten.
To change a palettes color scheme:
1. Using the technique described above, display the palette you want to change.
2. Point to the View menu and drag down to User Palette…. This displays the Palette dialog box.
3. In the Palette dialog box, click the Background, Grid Lines and User Annotation, 1st Waveform, or 2nd
Waveform colors you want. A dotted box appears around the selected color sample.
4. Click Apply to apply the colors you have selected.
5. If you are satisfied with the color scheme you have selected, click OK. This saves the newly defined
color scheme as one of the 16 display palettes, overwriting the existing palette. If you are not satisfied,
repeat steps 3 and 4 above, or click Cancel to get back to the original palette you started with.
User Palette Dialog Box
The following information can be referred to when using the User Palette… function.
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Palette # = _ - Serves as a label or identifier for the selected color scheme. Range is from 0 to 15.
Increment command button - Displays the color scheme that defines the next palette. Activating this button
increments the Palette # and updates the background, waveform, and grid lines and user annotation color selection
bars to show what the palette will look like when the Apply command button is activated.
Decrement command button - Displays the color scheme that defines the previous palette. Activating this button
decrements the Palette # and updates the background, waveform, and grid lines and user annotation color selection
bars to show what the palette will look like when the Apply command button is activated.
OK command button - Saves the new color combination as one of the 16 display choices. When saved, the original
color combination is overwritten.
Apply command button - Allows you to apply or “try out” new color combinations without having to save them.
Also used in conjunction with the Increment/Decrement buttons to view the 16 defined palettes. For example, to
see what each palette currently looks like, activate the Apply button then the Increment button. Repeat this
procedure 16 times to see each defined palette.
Cancel command button - Allows you to cancel any color changes made to a palette, provided that the changes
have not been saved with the OK button. When canceled, the color scheme will revert back to the original palette
you started with.
Monochrome Displays
If you are using WWB/Tach software with a monochrome monitor, select the Monochrome color scheme from the
Windows Control Panel. Selecting a color scheme other than monochrome may cause display conflicts. For
example, with other color schemes, the cursor may seem to disappear when positioned coincident with a dark
vertical gridline. The same result can happen with a waveform that rides the window baseline (the signal seems to
disappear, but it is merely the same shade as the baseline). Selecting the monochrome color scheme ensures that
your monitor will show every shade it is capable of showing without any conflicts.
Color Selection Conflicts
When selecting color combinations, it is important to note that the cursor color (not modifiable) will always be the
inverse of the color chosen for the background. For example, if the background color is black the cursor color will
be white, or if the background color is red the cursor color will be dark cyan.
For this reason, do not pick the inverse color of the background for grid lines and user annotation. If you do, the
cursor will seem to disappear when coincident with a vertical grid line.
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As a general rule, do not assign the inverse color of the background to any other parameter (grid lines and user
annotation, 1st waveform, or 2nd waveform) and do not make both waveforms the same color.

Print
Allows any WWB/Tach display currently active on the monitor to be printed (hard copied) on a compatible
graphics printer.
This function offers a “print screen” feature, a “print rectangle only” feature, and a continuous hard copy feature.
The print screen feature prints whatever is currently displayed on your monitor in your choice of two formats and
two size options. The print rectangle only feature prints only the graphics enclosed by the graphic selection
rectangle. The continuous hard copy feature provides a continuous hard copy record of all data between the
distance marker and cursor. When executed, the continuous hard copy is printed immediately from within
WWB/Tach.
Print Screen Feature
To generate a print screen:
1. Point to the File menu and drag down to Print….
This displays the Print dialog box:

Entire Window - Prints everything as displayed on the screen, could be considered a “screen shot”.
Window Excluding Title and Menu Bars - Prints only the most pertinent information about the waveform file(s)
displayed on the screen. Does not print the title or menu bar at the top of the display.
Note that when either of these formats are selected, the Continuous Print Options are dimmed, thus not selectable.
However, the Window Print Options are selectable. These options control the size of the print screen. The two size
options are as follows:
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Best Fit - Maintains the aspect ratio of the display on the screen. The size of the printout fills the page as much as
possible without destroying the aspect ratio.
Stretch to Page - Fills the entire page with the printout. With the paper portrait oriented, the printed image is
stretched in the vertical direction to fill the entire page, thus not maintaining the aspect ratio of the display on the
screen.
The following illustrates a typical waveform printed on an 8 1/2 x 11 inch sheet of paper in each format and size
option.
Best Fit Option

Stretch to Page Option

Entire Window

Window Excluding
Title and Menu Bars

Graphic Selection Rectangle Feature
To generate a hard copy of only the waveform(s) bounded by the graphic selection rectangle, you must first draw
the graphic selection rectangle to enable the normally dimmed Graphic Selection Rectangle radio button. This is
done by clicking and holding the RIGHT mouse button anywhere in the waveform graphics to enclose the area of
interest. Once the rectangle is drawn, the Graphic Selection Rectangle radio button can be selected.
Continuous Hard Copy Feature
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To generate an immediate, continuous hard copy, you must first select a range of waveform data to be hard copied.
This range is defined as all data lying between the time marker and cursor.
To select the copy range:
1. Position the cursor at one end of the desired range (drag the left mouse button in the bottom annotation margin
to position the cursor).

2.

Enable the distance marker (by pressing the F4 key; by pointing to the Options menu and dragging down to
Enable Distance Marker; or by choosing Options Enable Distance Marker with ALT, O, M keystrokes)

3.

Move the cursor (in either direction) to the other end of the desired range (by dragging the left mouse button in
the bottom annotation margin).
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Although the range is specified only on display window one, when hard copied, data for all channels lying within
the range is hard copied.
Note that each waveform channel should be scaled, offset, calibrated, and compressed on the screen display exactly
the way you would like it to appear when hard copied. Also note that grid lines will be printed if enabled for
display.
When the hard copy ranges are selected as described above, the continuous hard copy feature is invoked by:
Pointing to the File menu and dragging down to Print….
This displays the Print dialog box. Select the Continuous From Cursor to Distance Marker (TM)… option button in
order to generate a continuous hard copy.

Note that when the Continuous From Cursor to Distance Marker (DM)… format is selected, the Window Print
Options are dimmed, thus not selectable. However, the Continuous Print Options are selectable. These check boxes
86

PLAYBACK AND ANALYSIS USING WWB/Tach

allow the user to enable or disable the annotations in the left and right margins of the hard copy and to set a
distance zoom factor. A distance zoom factor can be entered to enhance readability when printing on a high
resolution printer (300 dpi or higher). For example at a distance zoom factor of 1 printed at 300 dpi, there will be
300 samples per vertical inch of waveform. This may not reveal enough important detail in the waveform.
Increasing the distance zoom factor allows you to vertically spread out the samples (the horizontal dimension
remains unchanged) for better visibility. A time zoom factor of 2 would produce 150 samples per vertical inch and
thus more detail in the hard copy. Set these options as desired and activate the OK command button.
When the OK command button is activated, the screen will be cleared and the following dialog box will be
displayed:

You have the option of entering up to one full line (70 characters) of text (comments) that will be passed to the hard
copy record. After your comments are entered, or if you choose not to comment, activate the OK command button.
At this point, waveform hard copy will begin at your printer.
Interpreting the Hard Copy Record — The following describes the information provided by the record:
File Information - Original WINDAQ-formatted data file name, and the date and time when the file was last filled.
Your comments (if any) are shown as entered when the hard copy was enabled.
Waveform Information - Describes the ±full scale and base line values in whatever engineering unit was selected
for each waveform. If engineering units were not enabled, the units displayed will be volts. Any waveform scales,
offsets, or calibrations applied while using WWB/Tach will be similarly duplicated in the hard copy record. When
interpreting the hard copy record, the + full scale limit is the top-most horizontal grid line (be sure to orient hard
copy record with reference arrow pointing up), the - full scale limit is at the bottom-most horizontal grid line, and
mid scale limit is the horizontal grid line in the middle.
Also annotated is the Waveform Compression Factor selected at the distance the hard copy was enabled. This factor
is provided for reference only since all distance functions are automatically adjusted as a function of the
compression factor.
Distance Annotation - The hard copy produces two types of distance annotation: Distance referenced to the
beginning of the hard copy record (DBR); and distance referenced to the beginning of the parent data acquisition
file (DBF). The hard copy record yields a distance division marker approximately every 1cm. Each such marker is
annotated on the right and left chart-edge with DBR, and DBF in meters respectively. The need for DBR is obvious.
This annotation allows any waveform event to be placed in distance relative to the beginning of the hard copy
record. The need for DBF is more subtle, but just as important.
WWB/Tach provides a DBF (Distance-To-Beginning-Of-File) function which allows the current position of a
waveform cursor to be known relative to the distance in meters from the beginning of the file being reviewed. DBF
annotation provided by the hard copy directly correlates with WWB/Tach software’s DBF function. This means that
a waveform event occurring on the hard copy record can be similarly located on the computer-based record by
scrolling the waveforms forward or backward until DBF equals that observed in the hard copy record.
Correlation of a hard copy record with its computer-based parent is a valuable feature, especially when coupled
with Waveform Compression. Large portions, or even an entire data file may be compressed, hard copied, then used
as a tool for determining where detailed analysis should begin and end. In this manner, the feature allows you to get
a handle on large quantities of data in a purely logical and organized fashion.

87

PLAYBACK AND ANALYSIS USING WWB/TACH

FIGURE 1 — A sample of the hard copy output shows the file, waveform, and distance information provided. See
text for a complete description of each function.

Range of Channels (Assign Range, Forward Range,
Backward Range)
Three separate functions that allow you to conveniently monitor and manipulate all the channels you have enabled
when they can’t be displayed on the monitor all at once. These functions are most useful when many channels are
enabled (such as with an EXP Series channel multiplexer or with DI-500 Series channel expanders) and the size of
your monitor or the amount of screen space devoted to the WWB/Tach window prevents you from seeing them all.
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These functions are similar to the ASSIGN CHANNEL function in that they allow you to assign any enabled ADC
channel to a specific display window, however these functions differ by allowing you to assign or manipulate a
block of channels. The ASSIGN CHANNEL function only allows one channel assignment at a time.
Assign Range - This function is similar to the ASSIGN CHANNEL function in that it allows channel assignment to
a specific display window, however this function allows you to assign a block of any enabled consecutive ADC
channels rather than just a single channel. To assign a range of channels, you must first select the display window in
which you would like the block of channels to begin. This is done by:
1.

Clicking the left mouse button in the unselected channels annotation margin.

The focal point for selecting the desired display window is the variable waveform assignment indicator of each
channel. This is the two-element equality (X=Y) displayed for every enabled ADC channel. Element “X” is the
display window number or letter and element “Y” is the ADC channel number assigned to the window. Element “X”
(the display window) is always the element specified to enable the waveform contained in that window for
adjustment. When a display window is selected, a highlighted box surrounds the X=Y annotation, indicating that
the window is enabled for adjustment:

When the desired display window is selected, the channel range can be assigned as follows:
1.

Point to the View menu and drag down to Assign Range….

This causes the channel number (element “Y”) in the highlighted box surrounding the X=Y annotation to blink.
Enter the new or desired channel number here. If the box is still blinking after typing fewer than the maximum
number of digits, press a non-numeric key to stop it from blinking.
Display windows appearing on the monitor below the selected one are now assigned consecutively higher
numbered channels while the display windows appearing on the monitor above the selected one are now assigned
consecutively lower numbered channels.
For example, say you have 16 channels of data enabled for acquisition but for some reason can only display 8 at a
time on your monitor. You can use the Assign Range… command to conveniently see the remaining eight channels
of data. Just select display window 1, select Assign Range… from the View menu, and enter 8 in the blinking box.
Instead of channels 0 through 7, display windows 1 through 8 now show channels 8 through 15.

Forward Range - This function allows you to conveniently scroll through, in a forward direction, all the
consecutive channels you have enabled when they can’t be displayed on the monitor all at once. This function is
most useful when many channels are enabled (such as with an EXP Series channel multiplexer or with DI-500 Series
channel expanders) and the size of your monitor or the amount of screen space devoted to the WWB/Tach window
prevents you from seeing them all.
To display consecutive channels that are higher-numbered than the one at the bottom of your monitor:
Point to the View menu and drag down to Forward Range.
89

PLAYBACK AND ANALYSIS USING WWB/TACH

For example, say you have 32 channels of data enabled for acquisition but for ease of viewing and to keep a high
degree of detail, you want only 8 displayed at a time on your monitor. You can use the Forward Range command to
conveniently scroll forward through the remaining channels of data. Just select Forward Range from the View menu
(or use the CTRL+DOWN ARROW accelerator keystroke). The next higher-numbered 8 channels will be displayed.

Backward Range - This function allows you to conveniently scroll through, in a backward direction, all the
consecutive channels you have enabled when they can’t be displayed on the monitor all at once. This function is
most useful when many channels are enabled (such as with an EXP Series channel multiplexer or with DI-500 Series
channel expanders) and the size of your monitor or the amount of screen space devoted to the WWB/Tach window
prevents you from seeing them all.
To display consecutive channels that are lower-numbered than the one at the top of your monitor:
Point to the View menu and drag down to Backward Range.
For example, say you have 32 channels of data enabled for acquisition but for ease of viewing and to keep a high
degree of detail, you want only 8 displayed at a time on your monitor. You can use the Backward Range command
to conveniently scroll backward through the remaining channels of data. Just select Backward Range from the View
menu (or use the CTRL+UP ARROW accelerator keystroke). The next lower-numbered 8 channels will be
displayed.

Refresh
Updates the scroll bar position and %EOF field to reflect the new length of a file being acquired.

Point to the View menu and drag down to Refresh.

Save
Saves a copy of the file you are working with on disk. All header information is saved in the current data file,
resulting in the same display when the file is reviewed again. Note that this function does not cause you to exit the
file or prompt you for format or save options, it merely saves the current state of your data file.
Point to the File menu and drag down to Save.
Use the Save function when you want to update a file on disk with the most-recent changes. If you want to save a
copy of a file without affecting the version of the file already on disk, use the Save As function.
NOTE: When inserting comments in this mode, Control Q inserts the date and distance that the cursor appears. If
you want the time to represent the beginning distance of the file, place the cursor at the beginning and the distance
marker at the end.

Scaling and Offsetting a Waveform (Autoscale, Grow 2X,
Shrink 2X, Waveform Down 1 Pixel, Waveform Down 10
Pixels, Waveform Up 1 Pixel, Waveform Up 10 Pixels)
Used to dynamically scale or offset a specified channel's waveform on the real time display.
1.

Select the window that contains the desired waveform:
Click the left mouse button in the unselected window’s annotation margin.
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The waveform displayed in the selected window is now enabled for scale and offset adjustments.

Expanding the Waveform’s Amplitude
Point to the Scaling menu and drag down to Grow 2X. This expands the specified waveform two times
its original size in the amplitude direction.
OR
Point to the right or left annotation margin and click the left mouse button. This also expands the
specified waveform two times.
Contracting the Waveform’s Amplitude
Point to the Scaling menu and drag down to Shrink 2X. This contracts the specified waveform one-half
its original size in the amplitude direction.
OR
Point to the right or left annotation margin and click the right mouse button. This also contracts the
specified waveform one-half its original size.
Autoscaling the Specified Waveform
Point to the Scaling menu and drag down to Autoscale. This automatically adjusts the vertical scale to
place the highest and lowest points of the selected waveform at the top and bottom of the waveform
window. In other words, this command automatically scales the waveform to make it as large as
possible while staying within the top and bottom limits of the waveform window. For a single channel
display, this results in the maximum waveform image visible on screen.
Moving the Waveform Down ( Offsetting)
Point to the Scaling menu and drag down to Waveform Down 1 Pixel or Waveform Down 10 Pixels.
Waveform Down 1 Pixel moves the specified waveform down a single pixel in the strip and Waveform
Down 10 Pixels moves the specified waveform down 10 pixels in the strip.
Moving the Waveform Up ( Offsetting)
Point to the Scaling menu and drag down to Waveform Up 1 Pixel or Waveform Up 10 Pixels.
Waveform Up 1 Pixel moves the waveform up a single pixel in the window while Waveform Up 10
Pixels moves the waveform up 10 pixels.
As a scaling or offset operation is performed on any selected channel, the channel’s annotated ± full scale and base
line values will automatically adjust to reflect the operation.
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Scaling and offsetting data does not, in any way, affect the information stored to disk. These operations are only
provided to configure the real time display.

Select Live Display
Allows you to select between four different data formats for display in the live display field. These formats report
waveform information for the currently selected channel as: distance from beginning of file, difference from
distance marker point, % change from distance marker point, and slope of line to distance marker point.
Distance From Beginning of File - Annotates the quantity of distance from the beginning of the data file to the
point of waveform/cursor intersection in millimeters. To display distance from beginning of file in the live display
field:
1. Point to the Options menu and drag down to Select Live Display.
2. Click on Distance from Beginning of File.
When the Distance from Beginning of File format is selected, the live display field will show XXXXXXXX
M(DBF), where XXXXXXXX is the distance-to-beginning-of-file from the point of waveform/cursor intersection in
meters.

Difference From Distance Marker Point - This format annotates the difference in waveform values between the
distance marker position and the current cursor position. To display the difference from DM point in the live
display field:
1. Point to the Options menu and drag down to Select Live Display.
2. Click on Difference from DM pt.
When the difference from distance marker point format is selected, the live display field will show XXXXXXXX
DATA-DM, where XXXXXXXX is the difference in waveform values between distance marker position and cursor
position.

Note that the distance marker must be enabled for display with this format.
If the cursor is positioned directly on top of the distance marker and compression is 1, the live display field shows
zero (no difference).
It is possible to see a negative difference value in the live display field. This occurs when the cursor is moved to a
point on the waveform that is smaller than the value of the waveform at the distance marker.
If waveform compression is enabled, the data values reported by the distance marker and cursor will be MID, MIN,
or MAX line segment values rather than a single data point value that would be displayed on an uncompressed
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waveform.
Percent Change from Distance Marker Point - This format annotates the percent change in waveform values
between the distance marker position and the current cursor position. To display the percent change from DM point
in the live display field:
1. Point to the Options menu and drag down to Select Live Display.
2. Click on % Change from DM pt.
When selected, the live display field will show XXX.XX %CHANGE, where XXX.XX is the percent change in
waveform values between distance marker position and cursor position.

Note that the distance marker must be enabled for display with this format.
If the cursor is positioned directly on top of the distance marker and compression is 1, the live display field shows
zero (no change).
It is possible to see a negative percent change value in the live display field for this format. This occurs when the
cursor is moved to a point on the waveform that is larger than the value of the waveform at the distance marker.
If waveform compression is enabled, the data values reported by the distance marker and cursor will be MID, MIN,
or MAX line segment values rather than a single data point value that would be displayed on an uncompressed
waveform.
Slope of Line to Distance Marker Point - This format annotates the slope of an imaginary line formed by
connecting the waveform value at the distance marker position with the waveform value at the cursor position. To
display the slope of the line to DM point in the live display field:
1. Point to the Options menu and drag down to Select Live Display.
2. Click on Slope of line to DM pt.
When the slope of line to distance marker point format is selected, the live display field will show XXXXXXXXX
SLOPEDM, where XXXXXXXXX is the slope of an imaginary straight line between distance marker position and
cursor position (expressed in scientific notation).

Note that the distance marker must be enabled for display with this format.
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If the cursor is positioned directly on top of the distance marker and compression is 1, the live display field
indicates on because the function is undefined.
If waveform compression is enabled, the data values reported by the distance marker and cursor will be MID, MIN,
or MAX line segment values rather than a single data point value that would be displayed on an uncompressed
waveform.
Each of these display formats report waveform information for the currently selected channel. If no channel is
selected, the live display field shows Distance from Beginning of File.

Select Marker Display
Allows you to select between four different time formats for display in the marker display field. These formats report
the data lying between the distance marker and cursor as: distance from marker, samples from marker, cycles/m for
cycle to marker, and cycles/km for cycle to marker.
Distance From Marker - Annotates the distance difference from the cursor to the distance marker in seconds. To
display distance from marker in the marker display field:
1. Point to the Options menu and drag down to Select Marker Display.
2. Click on Distance from Marker.
When selected, the marker display field will show XXXX M(DM), where XXXX is the distance difference from the
cursor to the distance marker in seconds.

Samples from Marker - Annotates the number of samples (or individual data points) in the section of waveform
bounded by the cursor and distance marker. To display the number of data samples in the marker display field:
1. Point to the Options menu and drag down to Select Marker Display.
2. Click on Samples from Marker.
When selected, the marker display field will show XXXXX SMP(DM), where XXXXX is the number of samples in
the section of waveform bounded by the cursor and time marker.

Note that the distance marker must be enabled for display with this format.
If the cursor is positioned directly on top of the distance marker, the live display field shows zero (no samples).
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It is possible to see a negative samples value in the marker display field for this format. This occurs when the cursor
is moved to a point on the waveform left of the distance marker.
Cycles/m for Cycle to Marker - Displays a frequency (in cycles per meter) for the section of waveform (or cycle)
defined by the cursor and distance marker. To display the frequency (in cycles/meter) of the selected cycle in the
marker display field:
1.
2.

Point to the Options menu and drag down to Select Marker Display.
Click on Cycles/m for Cycle to Marker

When selected, the marker display field will show XXXXXXXX ~/m (DM), where XXXXXXXX is the frequency (in
scientific notation) of the cycle defined by the positions of the distance marker and cursor.

Note that the distance marker must be enabled for display with this format.
If the cursor is positioned directly on top of the distance marker, the marker display field displays on because a
cycle has not been defined.
Cycles/km for Cycles to Marker - Displays a frequency (in cycles per kilometer) for the section of waveform (or
cycle) defined by the cursor and distance marker. To display the frequency (in cycles/kilometer) of the selected
cycle in the marker display field:
1. Point to the Options menu and drag down to Select Marker Display.
2. Click on Cycles/km for Cycles to Marker.
When selected, the marker display field will show XXXXXXXX ~/km(DM), where XXXXXXXX is the frequency (in
scientific notation) of the cycle defined by the positions of the distance marker and cursor.

Note that the distance marker must be enabled for display with this format.
If the cursor is positioned directly on top of the distance marker, the marker display field displays on because a
cycle has not been defined.
The distance marker formats will be displayed in the marker display field only if distance markers are enabled for
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display. If distance markers are disabled, off is displayed in the marker display field rather than a numerical value.

Show Dynamic Range
Allows you to see the waveform file with respect to the entire dynamic range of the A/D converter. Activating this
function modifies the vertical scale (and automatically adjusts the waveform) so the + and - full scale counts are
placed at the top and bottom of the waveform strip.
By seeing your waveform with respect to the entire dynamic range of the A/D converter, you see how much of this
range you are using. Ideally, the waveform should use the entire dynamic range of the A/D converter in order to
take full advantage of its resolution.
To show the dynamic range of the A/D converter:
Point to the Scaling menu and drag down to Show Dynamic Range.
This modifies the vertical scale (and automatically adjusts the waveform) to place the + and - full scale A/D
converter counts at the top and bottom of the waveform strip, thus showing you the waveform file with respect to
the entire dynamic range of the A/D converter.
Subsequent activations of the Show Dynamic Range command does nothing, the function does not toggle. To
revert to the previous display (prior to activating the Show Dynamic Range function), use the Undo command on
the Edit menu.

Split Screen Operations (Split, Exit/Enter Split, More Bottom
Y, Less Bottom Y, Left Limit, Right Limit, Toggle Pane)
Seven individual functions provide a way for you to manipulate the split screens (or top and bottom panes), which
are present when the Fourier Transform Operations or X-Y Plotting functions have been used. Operations such as
Split, Exit/Enter Split, More Bottom Y, Less Bottom Y, Left Limit, Right Limit, and Toggle Pane allow you to
adjust, maneuver, or otherwise control the split screen display. Each function is described as follows:
SPLIT Function - This command allows you to adjust the size of the split between the top and bottom screen
sections or panes.
Point to the View menu and drag down to Split. This causes a horizontal bar to appear onscreen. Use the
mouse to move the bar to the desired position and click to anchor the split at the new location.
The split can also be adjusted by pointing to the split bar with the mouse as follows:

When positioned anywhere inside the split bar, the mouse pointer takes on a different shape, indicating that you
can now drag with the left mouse button to adjust the split, which divides the window into horizontal panes. When
the left mouse button is released, the split will appear where positioned.
The split function can be canceled by pressing the ESC key.
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EXIT/ENTER SPLIT Function - This command allows you to toggle between the regular and split screen
displays. This feature can be used after a Fourier Transform operation to examine a magnified display of the inverse
transform in waveform strip 2. When the split screen view is exited, the spectrum data displayed there is retained,
allowing quick access for subsequent looks at the split screen display. To exit from or return to the split screen
display, proceed as follows:
Point to the View menu and drag down to Exit/Enter Split.
MORE BOTTOM Y Function - This command increases the height of the bottom pane (allows you to see more of
the Y-axis) by 1/16th of the total plot height. To increase the height of the bottom pane by a fixed amount, proceed
as follows:
Point to the View menu and drag down to More Bottom Y.
LESS BOTTOM Y Function - This command decreases the height of the bottom pane (allows you to see less of the
Y-axis) by 1/16th of the total plot height. If the bottom pane is completely closed with this command, the spectrum
data retained in memory (including the inverse transform) will be lost. To decrease the height of the bottom pane by
a fixed amount, proceed as follows:
Point to the View menu and drag down to Less Bottom Y.
LEFT LIMIT Function - This command selects the left limit cursor in the Y-T waveform area (or upper pane),
allowing you to reposition it with the ← and → cursor control keys. Repositioning the left limit cursor allows you
to adjust the amount of data to be transformed, however the amount of travel is bounded by the left chart edge and
the center cursor. Note that when the left limit cursor is selected, it appears as a solid line while the center and right
cursors remain dotted. Note also that the left limit cursor may be selected and adjusted more easily by dragging
with the left mouse button just below it in the analysis reporting area. To select the left limit cursor for adjustment,
proceed as follows:
Point to the View menu and drag down to Left Limit.
RIGHT LIMIT Function - This command selects the right limit cursor in the Y-T waveform area (or upper pane),
allowing you to reposition it with the ← and → cursor control keys. Repositioning the right limit cursor allows you
to adjust the amount of data to be transformed, however the amount of travel is bounded by the right chart edge and
the center cursor. Note that when the right limit cursor is selected, it appears as a solid line while the center and left
cursors remain dotted. Note also that the right limit cursor may be selected and adjusted more easily by dragging
with the left mouse button just below it in the analysis reporting area. To select the right limit cursor for adjustment,
proceed as follows:
Point to the View menu and drag down to Right Limit.
TOGGLE PANE Function - This command allows you to toggle between the pane in which the cursor control keys
and numeric pad keys operate. When the upper pane is active (cursor control keys manipulate cursors in the upper
pane), the analysis reporting area contains DBF and DM data just as in a standard display. When the lower pane is
active (cursor control keys manipulate the cross hairs on the power spectrum plot), FRQ and DB or MAG data is
displayed, replacing the DBF and DM data. Note that either pane can be selected more easily by clicking with the
left mouse button in the desired pane. To make the desired pane active (if not already active), thus allowing the
cursor control keys to operate in that pane, proceed as follows:
Point to the View menu and drag down to Toggle Pane.

Statistics
Allows you to derive statistical information from specified segments of the enabled waveform channel. The
statistics function is available only from the Y - T display mode of WWB/Tach software. It is not available from the
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X - Y or FFT display modes.
Statistical information about a waveform is obtained by first enabling the window containing the waveform of
interest. Statistics may be reported for the entire length of the waveform channel, or any section of the channel by
isolating the area of interest between the distance marker and cursor. A distance marker is enabled by positioning
the cursor at the desired location and pressing the F4 function key.
Statistics may be reported for the area of the enabled waveform window isolated between the distance marker and
cursor by the following procedure:
Point to the View menu and drag down to Statistics…
Following this procedure, the screen will clear and the following window will be displayed:

The Write to File and Open New File command buttons are used for sending the reported information to a disk file.
The Write to File button originally appears dimmed because a file name has not yet been specified. To specify a
filename, you must first activate the Open New File command button. When activated, you will be prompted to
enter a file name (and path) on the Open Statistics File dialog box:

Respond by entering any valid DOS file name and any paths that may be necessary. Next, you will be prompted for
an optional comment to be associated with the data written to disk:
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Respond by entering a comment, or canceling the comment opportunity. After entering a comment or canceling, the
open windows will be cleared, and the WWB/Tach screen will be restored to the state that existed before activating
the STATISTICS function. When inserting a comment in this mode, Control Q inserts the distance of where the
cursor appears. If you want the distance to represent the beginning distance, place the cursor at the beginning and
the distance marker at the end.
Subsequent requests for statistical information allow the option of appending the reported information with
comments to the previously defined data file if you activate the Write to File command button. Activating the Open
New File command button will prompt you for a new file name, thus allowing you to send various statistical
information to different files if you desire.
Disk files created by the statistical routine are tabular ASCII files with a comma delimiter and are suitable for
importing to any spreadsheet and most other analysis software packages.
NOTE: If no channel is selected, a file will be written with statistics for all channels.

Distance Reference (Cursor Location, Start Time, End Time,
Distance per Division)
Four individual functions that when enabled provide a distance reference for the waveform as follows:
1.
1.
2.
3.

Cursor Location - Displays the location at the current cursor position.
Start Time - Displays the date and time the file was opened for acquisition.
End Time - Displays the date and time the file was closed for acquisition.
Distance/Division - Displays the distance per screen grid division.

Each of these four functions share the same display field (the lower right corner of the bottom annotation line),
therefore only one of these functions can be displayed at a time.
To Display Cursor Location:
Point to the Options menu and drag down to Cursor Location.
This displays the location at the current cursor position in the C display field at the lower right corner of the bottom
annotation line. This display option allows you to position the cursor anywhere in the data file and find out exactly
where a certain event occurred.
To Display Start Time:
Point to the Options menu and drag down to Start Time.
This displays the date and time the file was opened for acquisition in the S display field at the lower right corner of
the bottom annotation line.
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To Display End Time:
Point to the Options menu and drag down to End Time.
This displays the date and time the file was closed for acquisition in the E display field at the lower right corner of
the bottom annotation line.

To Display Distance/Division:
Point to the Options menu and drag down to Distance/Division.
This displays the distance per screen grid division in the T display field at the lower right corner of the bottom
annotation line.

Undo
Allows you to reverse the last screen scaling or offset operation performed on a selected channel.
When “undone”, the waveform will revert back to the original values before the previous scaling or offset
operation. Note that this feature only works on the same channel as the most recent scaling or offset operation.
Subsequent undo operations toggles between the previous and most recent versions of screen scaling or offset.
A scaling or offset operation must first be performed on a selected channel to make the Undo command selectable
(undimmed). Once Undo becomes selectable, you can perform any other operation (except another scaling or offset
operation) on any other channel and still have the capability to come back to the selected channel and undo the
last screen scaling or offset operation.
After scaling or offsetting a waveform, reverse the operation as follows:
Point to the Edit menu and drag down to Undo.

Waveform Display Annotation (Data Display, Limit &
Frequency Display, Acquisition Assignments, User
Annotation)
Allows you to configure waveform display annotation many different ways. Annotation options data display, limit
& frequency display, acquisition assignments, and user annotation can be enabled or disabled, in any combination,
to customize the waveform display.
Data Display - Enables/disables the display of data values or baseline values in the left/right annotation margin.
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If neither limit & frequency display nor acquisition assignments are enabled, the engineering units toggle on and
off along with the baseline value. To enable Data Display (if disabled, or disable it if enabled):
Point to the Options menu and drag down to Data Display.
When enabled, the annotation margin will have the following appearance and a checkmark (√) will be displayed on
the Options menu immediately preceding the Data Display command:

Data display enabled

Limit & Frequency Display - Enables/disables the display of upper and lower chart-edge limits in the left/right
annotation margin (assuming the display window is large enough to have limits).
If acquisition assignments were displayed when the limit & frequency display was enabled, engineering units
replace them at the baseline.
If data display is disabled when the limit & frequency display is enabled, engineering units toggle on and off along
with the limits. To enable Limit & Frequency display (if disabled, or disable it if enabled):
Point to the Options menu and drag down to Limit & Frequency Display.
When enabled, the annotation margin will have the following appearance and a checkmark (√) will be displayed on
the Options menu immediately preceding the Limit & Frequency Display command:

Limit display enabled

Acquisition Assignments - Enables/disables the display of acquisition assignments in the field normally used for
engineering units. When enabled, the logical vs. physical channel number assignments replace the engineering
units at the baseline, and upper and lower chart-edge values are also displayed. Note that it is impossible to enable
both acquisition assignments and the limit & frequency display option at the same time. If the data display option
is enabled, the logical vs. physical channel number assignments revert to engineering units instead of toggling off
when acquisition assignments are disabled. To enable Acquisition Assignments (if disabled, or disable them if
enabled):
Point to the Options menu and drag down to Acquisition Assignments.
When enabled, the annotation margin will have the following appearance and a check mark (√) will be displayed
on the Options menu immediately preceding the acquisition assignments command:
acquisition
assignments
enabled

101

PLAYBACK AND ANALYSIS USING WWB/TACH

User Annotation - Enables/disables the display of user channel annotation provided during acquisition. To enable
User Annotation (if disabled, or disable it if enabled):
Point to the Options menu and drag down to User Annotation.
When enabled, the waveform strip will have the following appearance and a check mark (√) will be displayed on
the Options menu immediately preceding the User Annotation command:

User annotation
enabled

Note that the display annotation options can be enabled in virtually any combination to provide the desired result.
However in some instances, one annotation option will override another. For example, it is not possible to enable
both limit & frequency display and acquisition assignments. When limit & frequency display is enabled, it will be
automatically disabled when you attempt to enable acquisition assignments, and vice versa.
A logical channel number corresponds to a channel number's appearance in a data file. The first channel acquired is
the first in the file, the second is the second, etc. In WWB/Tach, logical channels are always specified. However,
during acquisition you have the ability to acquire any number of channels, not necessarily in sequential order. For
example, you may have acquired channels 0, 2, and 3. These channel numbers are called physical channels ó
relating to the actual physical channel number that provided the waveform. Their logical channel numbers are 1, 2,
and 3. When acquisition assignments are active, L=P means logical channel number L is assigned to physical
channel number P.
Acquisition assignments annotation provides a convenient method of determining, for any given waveform, which
physical channel number provided the signal.

X-Y Plotting
Allows any two amplitude/time (Y-T) oriented waveforms to be plotted versus each other, one waveform designated
as the independent (or X-axis) variable and the other waveform as the dependent (or Y-axis) variable. Once plotted,
this function allows some analysis of the resulting X-Y plot (i.e., measure excursions, slopes, and areas).
Before an X-Y plot can be generated, you must decide which channel will be the independent (or X-axis) variable
and which will be the dependent (or Y-axis) variable. The channel assigned to display window 1 is defined as the X
waveform and the channel assigned to display window 2 is defined as the Y waveform. Any channels may be
assigned to display windows 1 and 2. For example, typing “1=3” and “2=12” causes waveform channel 3 to be
displayed in window 1, thus designating it as the independent (X) variable, and waveform channel 12 to be
displayed in window 2, thus designating it as the dependent (Y) variable. With the desired channels moved into
display windows 1 and 2, the X-Y plot can now be generated as follows:
Point to the XY menu and drag down to Exit/Enter XY.
This displays the following X-Y plotting screen:
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Left X-Y
Data
limit cursor cursor

Right X-Y
limit cursor

Window 1 (X)

Y-T waveform area {

Window 2 (Y)

Analysis reporting area {
Resulting X-Y plot
(from shaded area above)

X-Y plot area {

Cross hairs

Cross hair origin
indicates location
of data cursor

The X-Y plotting screen is composed of three basic sections; the Y-T waveform area, the analysis reporting area, and
the X-Y plot area. Each of these components and the purpose they serve will be discussed as follows:
Y-T Waveform Area
The Y-T waveform area is divided into two display windows (window 1 and window 2). Window 1 displays the
independent (X) variable channel and window 2 displays the dependent (Y) variable channel. The waveforms in
these windows may be manipulated in the same way and with the same functions (i.e., scrolling, scaling, offsetting,
etc.) that are available in the standard (non X-Y) WWB/Tach display mode. In other words, the way you review and
analyze the waveforms is still the same regardless of the fact that the waveforms are displayed in a smaller window
space.
Three cursors appear in the Y-T waveform area to show the portion of the waveform used to generate the X-Y plot.
They are the left X-Y limit cursor, the right X-Y limit cursor, and the data cursor.

Window 1 (X)
Window 2 (Y)
Left X-Y
limit cursor

Data cursor

Right X-Y
limit cursor

The portion of the Y-T waveforms to be plotted versus each other is all waveform information lying between the left
and right limit cursors (shown above as the shaded region). The left and right limit cursors and data cursor may be
placed anywhere in the Y-T waveform area with the following limitations:
1. The left limit cursor may not be moved to the right of the data cursor or past the left edge of the screen.
2. The right limit cursor may not be moved to the left of the data cursor or past the right edge of the screen.
3. Movement of the data cursor is restricted to the region between the left and right limit cursors. When the data
cursor is moved between the left and right limit cursors, the X-Y plot remains stable while the cross hairs trace
the X-Y plot to indicate the position of the data cursor on the X-Y plot.
To move the left or right limit cursor:
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1.

Position the mouse pointer in the analysis reporting area, directly underneath the desired limit cursor.

2.

Drag with the left mouse button to move the limit cursor to the desired position. Note that when the
left mouse button is pressed, the limit cursor changes from a dotted line to a solid line in the Y-T
waveform area. When the left mouse button is released, the limit cursor remains a solid line until a
different limit cursor is adjusted.

To move the data cursor:
1.

Position the mouse pointer in the analysis reporting area, directly underneath the data cursor.

2.

Drag with the left mouse button to move the data cursor to the desired position.

There are two ways to generate an X-Y plot; statically or dynamically. Both methods produce exactly the same
result and are presented as follows:
Static X-Y Plot Generation
The use of the word static here denotes that the Y-T waveforms are stable on the screen (not scrolling) and any X-Y
plots generated are those that result from adjusting the limit cursors (and the data cursor for the cross hair). As the
limit cursors are moved on the screen, the X-Y plot will update to reflect a plot of only the region of Y-T waveform
information isolated between the limit cursors. Movement of the data cursor, as described, allows the origin of the
cross hair to trace the X-Y plot. The origin of the cross hair at any given point on the X-Y plot correlates exactly
with the location of the data cursor on the Y-T plot.
Static X-Y plotting fully supports the waveform compression features of WWB/Tach software. This allows you to
compress entire files so they can be displayed on the screen in their entirety. Then the left limit cursor may be
moved to the left edge of the screen and the right limit cursor to the right edge of the screen to produce an X-Y plot
of one entire waveform file versus another entire waveform file. When waveform compression of any degree is
active, the representative X-Y plot may be a function of minimum, maximum, or mid-point compressed Y-T values.
While in the static X-Y plotting mode, it is possible to move the cross hair independently of the data cursor. This is
done as follows:

Dragging with the left mouse button to position the crosshair origin anywhere in the Y-T plot area.
This independent movement of the cross hair has absolutely no waveform measurement utility, but you will need
this feature when you want to determine areas bounded by curves using the area fill function described later. When
making these measurements, the cross hair origin is positioned anywhere within a confined region of the X-Y plot
before the area fill command is activated. We will discuss this capability in greater detail in paragraphs to follow.
Dynamic X-Y Plot Generation
The use of the word dynamic here denotes that the Y-T waveforms are scrolling on the screen and any X-Y plots
generated are those that result from the waveforms being scrolled through the region bounded by the limit cursors.
This mode of operation generates a very dynamic X-Y plot allowing large quantities of waveform information to be
examined quickly in an X-Y environment and within a defined span of time. Like static X-Y plotting, dynamic X-Y
plot generation fully supports waveform compression.
To generate a dynamic X-Y plot:
While pointing to the left or right scroll bar arrow in the analysis reporting area, press and hold the left
mouse button to scroll the waveform.
Analysis Reporting Area
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The analysis reporting area performs a dual role. When manipulating the waveforms in the Y-T area, the analysis
reporting area contains information about the waveforms in this area just as a typical WWB/Tach screen would.
When examining the X-Y plot, the analysis reporting area changes to display information about the X-Y plot such
as total area size, delta information, slope information, etc.
X-Y Plot Area
The X-Y plot area contains the actual X-Y plot of the waveforms. Examining the X-Y plot is possible through use of
a cross hair which may be moved anywhere on the plot.
Introduction to X-Y Plot Analysis
The X-Y plot utility of WWB/Tach software provides five analysis options that may be activated while an X-Y plot
is displayed. These are the calculation of X-Y plot excursions, instantaneous rate of change, 2-point rate of change,
linear regression rate of change, and area bounded by curve. The result of each analysis function is displayed
directly on the X-Y screen in the analysis reporting area as shown in the following figure:

Analysis
reporting area
This example
displays X-Y
excursion data

Text in the analysis reporting area will change depending upon the analysis option chosen. The following
examples appear in the analysis reporting area for each analysis option:
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Calculating X-Y Excursions
For any displayed X-Y plot, the total excursion in the X and Y directions may be reported. To report the total X and
Y direction excursions:
Point to the XY menu and drag down to Deltas.
This causes the analysis reporting area to display the following data:

Where the value to the left of DELTA X is the total X direction (peak-to-peak) excursion in channel X's unit of
measure, and the value to the left of DELTA Y is the total Y direction (peak-to-peak) excursion in channel Y's unit
of measure.
Calculating Instantaneous Rate of Change
An instantaneous rate of change for any point on an X-Y plot may be calculated. This is done by positioning the
cross hair at the point of interest on the X-Y plot, then:
Pointing to the XY menu and dragging down to Slopes.
When the instantaneous rate of change function is activated, the analysis reporting area will display:

Where the value to the left of TNSLOPE is equal to the instantaneous rate of change between the points to the left
and right of the point chosen (cross hair origin) in units of channel Y's units divided by channel X's units. For
example, if channel X's Y-T waveform is calibrated in units of PSI and channel Y's in units of Liters, the rate of
change is expressed in units of Liters/PSI.
Calculating 2-point and Linear Regression Rate of Change
Unlike the instantaneous rate of change, which calculates the rate of change at one point on a plot, the 2-point rate
of change allows the slope of a line connecting two defined points on the X-Y plot to be determined. Linear
regression rate of change reports the slope of a best-fit line between the two defined points. Both 2-point and linear
regression rates of change are reported simultaneously in the analysis reporting area.
The two points over which the rates of change will be calculated are defined by moving the data cursor between the
left and right limit cursors on the Y-T waveforms and enabling a distance marker on window 1's (X channel)
waveform. This defines the first point. The second point is defined by moving the data cursor to another point on
the Y-T plot (the cross hair moves automatically on the X-Y plot). Note that cursor movement must be done with
both “Scroll Lock” and “Caps Lock” off. Following your selection of the two points, the 2-point and linear
regression rate of change is displayed in the analysis reporting area by:
Pointing to the XY menu and dragging down to Slopes.
When the 2-point and linear regression rate of change function is activated, the analysis reporting area will display:

Where the value to the left of LRSLOPE is the rate of change of the best-fit linear regression line and the value to
the left of 2PSLOPE is the rate of change of a line intersecting the two defined points. In addition, a vector will be
drawn on the X-Y screen connecting the two points over which the 2-point derivative is calculated. As with
instantaneous rate of change, the derivative is presented in units of channel Y's units divided by channel X's units.
For example, if channel X's Y-T waveform is calibrated in units of PSI and channel Y's in units of Liters, the rate of
change is expressed in units of Liters/PSI.
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Calculating Areas Bounded By Curves
Using the cross hair to target specific bounded areas of the X-Y plot, it is possible to determine the area bounded by
the curve. When the desired X-Y plot is displayed on the screen and the plot area to be determined is completely
enclosed, adjust the cross hair such that its origin lies within the area to be determined. To fill the enclosed area and
calculate the area it occupies:
Point to the XY menu and drag down to Area.
When the area function is activated, the desired plot area is filled and the analysis reporting area will display:

Where the value to the left of NEWAREA is the area of the bounded curve just filled, and the value to the left of
TOTAREA is the accumulated result of all bounded and filled areas. The latter quantity (TOTAREA) is possible
since multiple area fills are possible for any given plot by repositioning the cross hair to a new area and filling
again as described above (ALT+F3 is the quickest). As consecutive areas of an X-Y plot are filled, TOTAREA
accumulates a total while NEWAREA displays the area of the last fill. Any given area may be unfilled by positioning
the cursor within the filled area and pressing ALT+F3 a second time. When this feature is activated, NEWAREA will
display a negative number equal to the area eliminated and TOTAREA will decrease by an equal amount.
The value displayed for NEWAREA and TOTAREA is in units of channel X's units times Channel Y's units. For
example, if channel X's Y-T waveform is calibrated in units of PSI and channel Y's in units of Liters, area is
expressed in units of Liters · PSI.
When using ALT+F3 to fill areas, it is possible for the screen to fill completely if the selected area was not
completely bound. If this happens, pressing ALT+F3 a second time without moving the cross hair will unfill the
screen. X-Y plots appearing on your screen that are not bound (i.e., areas that are not completely surrounded by an
X-Y trace) may be forced closed by:
Pointing to the XY menu and dragging down to Clear Areas.
When this feature is activated, the two end points of the X-Y plot are connected with a straight line allowing the
now closed area to be calculated using the procedure described above. If Clear Areas is chosen while there are
active area fills on the screen, they will be cleared and NEWAREA and TOTAREA are reset to zero.
Calculating Adjusted Area
When an X-Y plot is displayed with one or multiple area fills, an adjusted area may be displayed that includes all
X-Y traces passing through the filled area as well as half of the fill area's border. To adjust the enclosed area(s) and
calculate the area it occupies:
Point to the XY menu and drag down to Adjust Area.
When the adjust area function is activated, the desired plot area is adjusted and the analysis reporting area will
display:

Where the value to the left of NEWAREA is the amount by which the area was adjusted (the amount occupied by the
traces passing through the fill and half of the fill’s border), and the value to the left of ADJAREA is the total area
fills plus the value shown to the left of NEWAREA).
Selecting Adjust Area a second time causes the value to the left of NEWAREA to exclude the internal traces, which
were included the first time the command was selected.
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Amplitude Adjustments and Plot Scaling
Scaling of the X-Y plot automatically conforms to that of the associated Y-T waveforms. The “X” Y-T channel
scaled in mmHg will scale the X-Y plot's X axis in mmHg. Similarly, the “Y” Y-T channel scaled in ml will scale the
X-Y plot's Y axis in ml.
Beyond engineering units calibration, WWB/Tach software allows changes in amplitude and offset to be applied to
any Y-T waveform. As the X or Y channel of a Y-T waveform is adjusted for scale and offset, the X-Y plot
automatically adjusts. This feature may be used to center an X-Y plot on the screen (by applying offset adjustments
to the Y-T waveforms), or to bring off-scale portions of X-Y plots into view (by applying scaling adjustments to the
Y-T waveforms).
X-Y Plot Grids, Annotation, and Hard Copy
The Grid pattern and ±full scale annotation for the X-Y plot assume the same state as that enabled for normal
operation. In addition, the X-Y display mode of WWB/Tach software is supported by the print screen function
allowing a hard copy of any display to be generated.
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Index
Data Display, 100
DATA-TM, 11
DBF, 11
Delete Mark, 24
Deltas, 105
DFT, 61, 65
Difference from Distance Marker Point, 91
Distance from Beginning of File, 91
Distance from Marker, 93
distance reference functions, 12
distance zoom factor, 85
Distance/division (T), 12
distance-to-end-of-file function, 12
DM, 11

%
%CHANGE, 11
%EOF, 12, 27

±
±full scale values, 10

A
Acquisition Assignments, 101
Adjust Area, 107
always on top, 8
Assign Channel…, 24, 28, 64
Assign Range…, 24, 88
ASYST, 50
ASYSTANT, 51
Autoscale, 90
Autoscroll Left, 28
Autoscroll Right, 28
Average Power…, 66

E
Enable Live Display, 43
End Time, 99
End Time (E), 12
Erase Frequency, 71
Event Markers…, 24, 45
Exit, 24, 25
Exit/Enter Split, 60, 64, 96
Exit/Enter XY, 102
Exit…, 60

B
Backward Range, 89
baseline, 31
binary with CODAS header, 50
binary without CODAS header, 50
bipolar, 31

F
Fixed Calibration…, 24, 30
Format Screen, 73
Forward Range, 89

C

G

CALC, 51
calibration values, 33
Center Cursor, 41
Channel Settings…, 36
Clear Areas, 106
Clear Marks to TM, 47
close, 7
Commented Note, 78
Compress FRQ…, 25, 67
Compression…, 24, 37, 64
converting foreign data file formats, 5
Copy, 39
Cursor distance (C), 12
cursor mode indicator, 11

Go to DM Position, 75
Go to Range…, 74
Go to Time…, 75
graphic selection rectangle, 17, 39
Grids, 76
Grow 2X, 90

H
high calibrator, 31
High-pass Filter, 71
horizontal scroll bar, 12

I

D
Insert Mark, 24
insertion point, 14
Inverse Transform, 71

DADiSP, 51
Data Cursor, 4, 39, 41
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Select Live Display, 91
Select Marker Display, 93
selection cursor, 14
selection rectangle, 17
sequential ASCII, 50
Show Dynamic Range, 95
Shrink 2X, 90
size, 7
Slope of Line to Distance Marker Point, 92
Slopes, 105, 106
SLOPETM, 11
SMP, 11
Split, 95
split bar, 13
Spreadsheet Print, 51
Start Time, 99
Start time (S), 12
starting the WWB/Tach package, 6
Statistics, 97
switch to…, 7
system menu icon, 7

Invert, 76

L
Left Limit, 96
left/right annotation margin, 9
Less Bottom Y, 96
Limit & Frequency Display, 100
Limits…, 31, 35
live display field, 11
Low Calibration…, 24, 34
low calibrator, 31
Low-pass Filter, 71

M
Mag Engr Units, 25, 69
marker display field, 11
maximize, 7
menu bar, 8
minimize, 7
More Bottom Y, 96
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Time/Division, 99
title bar, 7
Toggle Pane, 97

Next Palette, 80
Note, 77
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Undo, 100
unipolar, 32, 33
User Annotation, 101
User Palette…, 80

Offsetting a Specified Channel’s Waveform, 18
Open…, 24, 79
Output FRQ Data…, 25, 69
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Percent Change from Distance Marker Point, 92
Previous Palette, 80
Print Setup…, 24
Print…, 24, 82, 85
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variable waveform assignment indicator, 9, 10, 88
Visible channels only check box, 54
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Waveform Down 1 Pixel, 90
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Waveform Up 1 Pixel, 90
Waveform Up 10 Pixels, 90
window sizing icons, 8
window title, 8
Windowed FFT, 55
Windowed FFT…, 25, 65
WWB/Tach command hierarchy, 24
WWB/Tach pull-down menus, 23

Refresh, 89
restore, 7
Right Limit, 97

S
samples from marker, 93
Save, 89
Save As…, 14, 24, 49, 53
Scale DB, 25, 68
Scaling a Specified Channel’s Waveform, 20
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